<!doctype html> <!--[if lt IE 7 ]><html class="no-js ie6" lang="en-US"> <![endif]--> <!--[if IE 7 ]><html class="no-js ie7" lang="en-US"> <![endif]--> <!--[if IE 8 ]><html class="no-js ie8" lang="en-US"> <![endif]--> <!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0"><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><meta name="google-site-verification" content="DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps" /><style media="all">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</style><title>FIT: 4 Fabulous Fitness Stocks to Buy Now</title><link rel="icon" type="image/png" href="" /><link rel='dns-prefetch' href='//www.google.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><meta property="og:title" content="FIT: 4 Fabulous Fitness Stocks to Buy Now | StockNews.com" /><meta property="og:description" content="The antidote for the stress of staying @ home so much is trying to stay physically fit. These 4 stocks are benefiting the most from that trend: FIT, GRPO, NKE and PTON. Read on..." /><meta property="og:type" content="article" /><meta property="og:url" content="https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" /><meta property="og:site_name" content="StockNews.com" /><meta property="og:image" content="https://stocknews.com/wp-content/uploads/2020/01/business-growth-1-1057028-1-scaled.jpg" /><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="FIT: 4 Fabulous Fitness Stocks to Buy Now | StockNews.com"><meta name="description" content="Fitbit Inc.(NYSE:FIT): The antidote for the stress of staying @ home so much is trying to stay physically fit. These 4 stocks are benefiting the most from that trend: FIT, GRPO, NKE and PTON. Read on..." /><meta name="keywords" content="NYSE:FIT, Fitbit Inc. , Athletics & Recreation, Commentary" /> <script type="application/ld+json">{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/"
 },
 "headline": "4 Fabulous Fitness Stocks to Buy Now",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2020/01/business-growth-1-1057028-1-scaled.jpg" },
  "datePublished": "2020-04-21T08:21:21-04:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
  "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Fitbit Inc.(NYSE:FIT) The antidote for the stress of staying @ home so much is trying to stay physically fit. These 4 stocks are benefiting the most from that trend: FIT, GRPO, NKE and PTON. Read on..."
}</script> <link rel="canonical" href="https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" /> <script type='text/javascript' src='https://stocknews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://stocknews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://stocknews.com/wp-content/themes/strappress/js/responsive-modernizr.js?ver=2.5.3'></script> <script type='text/javascript' src='https://stocknews.com/wp-content/themes/strappress/js/magnific.min.js?ver=0.9.4'></script> <script type='text/javascript' src='https://stocknews.com/wp-content/themes/strappress/js/bootstrap.js?ver=041fd1f4f2f59d46e35adac52db4cd73'></script> <link rel='https://api.w.org/' href='https://stocknews.com/wp-json/' /><link rel="alternate" type="application/json+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F" /><link rel="alternate" type="text/xml+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml" /> <script type="text/javascript">// 
    jQuery(document).ready(function($){
        $("a[rel='magnific']").magnificPopup({
                type:'image'
        });
    });  
    //</script> <!--[if lt IE 9]> <script src="https://stocknews.com/wp-content/themes/strappress/js/respond.min.js"></script> <![endif]--><link rel="stylesheet" href="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css"> <script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script> <script src="//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script> <script src="/wp-content/themes/strappress/js/bootstrap-table/dist/bootstrap-table.min.js"></script> <script src="/wp-content/themes/strappress-child/ims.js"></script> <script src="/wp-content/themes/strappress/js/bootstrap-table/dist/extensions/natural-sorting/bootstrap-table-natural-sorting.js"></script> <script src="/wp-content/themes/strappress/js/bootstrap-table/dist/extensions/mobile/bootstrap-table-mobile.js"></script> <script>jQuery(document).ready(function($){
    $('a.sn_pop').on('click', function(e) {e.preventDefault(); return true;});
    $( ".ticker-search" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $( ".ticker-search-big" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $('[data-toggle="popover"]').popover({html: true, trigger: 'focus'});
  });</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64545224-1', 'auto');
  ga('send', 'pageview');</script> <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript> <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" /> </noscript> <script type="text/javascript">var apntag = apntag || {};
apntag.anq = apntag.anq || [];
(function() {
  var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
  e.type = 'text/javascript';  e.async = true;
  e.src = 'https://acdn.adnxs.com/ast/ast.js';
  p.insertBefore(e, p.firstChild);
})();


apntag.anq.push(function() {
  apntag.setPageOpts({
    member: 6989
  });
});

apntag.anq.push(function() {

      apntag.defineTag({
    tagId: 13208681,
    sizes: [[550,480],[600,400],[640,480]],
    keywords: {'position': ['PopUp']},
    targetId: 'StockNews_PopUp_PopUp'
  });
      });

apntag.anq.push(function() {
  apntag.loadTags();
});</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MR8XMKP');</script> <script type="text/javascript">(function() { window.advBidxc = window.advBidxc || {}; window.advBidxc.startTime = new Date().getTime(); function loadScript(tagSrc) { var scriptTag = document.createElement('script'), placeTag = document.getElementsByTagName("script")[0]; scriptTag.type = 'text/javascript'; scriptTag.async = true; scriptTag.src = tagSrc; placeTag.parentNode.insertBefore(scriptTag, placeTag); } var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' + window.location.hostname; loadScript(mnSrc); })();</script> <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css"></head><body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78"> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MR8XMKP"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header><div style="background:#333;" class="headerstick"><div class="container"><div id="logo" class="hidden-sm hidden-xs"><a href="https://stocknews.com/" title="StockNews.com" rel="home"> <img src="/img/sn-green.png" alt="StockNews.com" style="width:360px;height:auto" /> </a></div><nav class="navbar-collapse collapse navbar-responsive-collapse"><ul class="nav navbar-bav navbar-right"><li class="menu-item menu-item-type-custom menu-item-object-custom"><p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning"> Join </a></p></li></ul><form class="navbar-form navbar-right" role="search" method="post" id="searchform" action="https://stocknews.com/"><div class="input-group"> <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" autocomplete="off" size="17"><div class="input-group-btn"> <button type="submit" class="btn btn-success">Search</button></div></div> <input type="hidden" id="symbol_search" name="symbol_search" value="9c9798f8a5" /><input type="hidden" name="_wp_http_referer" value="/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" /></form></nav><nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0"><div class="container-fluid"><div class="navbar-header"><div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href="https://stocknews.com/" title="StockNews.com" rel="home"> <img src="/img/sn-green.png" style="width:220px;height:auto" alt="StockNews.com" /> </a></div> <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span> <span class="fa fa-bars" style="color:#fff !important;"></span> </button> <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-search" aria-expanded="false"> <span class="sr-only">Toggle navigation</span> <span class="fa fa-search" style="color: #fff !important;"></span> </button></div><div class="collapse navbar-collapse" id="navbar"><ul id="menu-top-nav" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown"> <a class="dropdown-toggle" aria-expanded="false"> News<span class="caret"></span> </a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/top-stories/"> Top Stories </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/best-worst/"> Best & Worst Articles </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/video-news/"> Video News </a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown"> <a class="dropdown-toggle" aria-expanded="false"> Best Stocks<span class="caret"></span> </a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/best-stocks/"> "A" Rated Stocks </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/powr-upgrades-downgrades/"> Upgrades/Downgrades </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/high-yield-dividend-stocks/"> High Yield Dividend Stocks </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/stock-screener/"> Stock Screener </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/stocks/"> Industry Rank </a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown"> <a class="dropdown-toggle" aria-expanded="false"> Best ETFs <span class="caret"></span> </a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/best-etfs/"> "A" Rated ETFs </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/etfs/"> Best ETF Categories </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/high-yield-etfs/"> High Yield ETFs </a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/powr-ratings/"> POWR Ratings&trade; </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/powr-upgrades-downgrades/"> Upgrades/Downgrades </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/watchlist/"> Watchlist </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="/stock-screener/"> Screener </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown"> <a class="dropdown-toggle" aria-expanded="false"> Services <span class="caret"></span> </a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="https://members.stocknews.com" target="_blank"> Services Home </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="https://members.stocknews.com/reitmeister-total-return/" target="_blank"> Reitmeister Total Return </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="https://members.stocknews.com/service/powr-trends/" target="_blank"> POWR Trends </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"> <a href="https://stocknews.com/powr-ratings/" target="_blank"> Premium </a></li></ul></ul><ul class="nav navbar-nav hidden-lg hidden-md"><li class="menu-item menu-item-type-custom menu-item-object-custom"><p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning"> Join </a></p></li></ul></div><div class="collapse navbar-collapse" id="navbar-search"><form class="navbar-form hidden-lg hidden-md" role="search" method="post" id="searchform2" action="https://stocknews.com/"><div class="input-group"> <input name="ticker" id="ticker2" type="text" class="form-control ticker-search" placeholder="Ticker or Company" autocomplete="off" size="17"><div class="input-group-btn"> <button type="submit" class="btn btn-success">Search</button></div></div> <input type="hidden" id="symbol_search2" name="symbol_search2" value="9c9798f8a5" /><input type="hidden" name="_wp_http_referer" value="/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" /></form></div></div></nav></div></div></header> <br><br><br><br></div><div class="container"><div class="clearfix wrapper"><div align="center"><div id="StockNews_ROS_Top_Leaderboard"></div></div><div id="content"><article><header><div class="row margin-top"><div class="col-lg-0 col-md-2"></div><div class="col-lg-8 col-md-8"><div class="news-event"><h1 class="page-title no-pad-left big-margin-bottom bold"> 4 Fabulous Fitness Stocks to Buy Now</h1><h1 class="page-title no-pad-left big-margin-bottom bold"></h1><div class="text-center"></div><div class="row margin-top"><div class="col-lg-12 text-center"></div></div><div><div class="panel-body" style="padding: 0px !important;"><div class="row"><div class="col-lg-12" style="max-height:550px; overflow:hidden;"> <img src="https://stocknews.com/wp-content/uploads/2020/01/business-growth-1-1057028-1-scaled.jpg" alt="NYSE: FIT | Fitbit, Inc.  News, Ratings, and Charts" style="margin:auto; display:block; max-height: 550px;"></div><div class="col-lg-12 col-md-8"><p><strong><a href="/stock/FIT/">FIT</a></strong> &#8211; The antidote for the stress of staying @ home so much is trying to stay physically fit. These 4 stocks are benefiting the most from that trend: FIT, GRPO, NKE and PTON. Read on&#8230;</p></div></div><div class="row no-margin-top"><div class="col-lg-12"><section class="post-meta zero-padding pad-bottom"> <img src='https://stocknews.com/wp-content/uploads/2019/07/Screen-Shot-2019-07-23-at-2.05.03-PM.png' style="float:left; padding:5px;width:80px;"><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=steve-reitmeister">By Steve Reitmeister</a></strong></span><br> <a href="">Apr 21, 2020</a><div style="float:right;"><div class="social-wrapper no-margin-bottom no-margin-top"> <a href="https://twitter.com/intent/tweet?text=%24FIT+4+Fabulous+Fitness+Stocks+to+Buy+Now&amp;url=https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target="_blank"><i class="fa fa-twitter"></i></a> <a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" title="Share on Facebook" target="_blank" class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a> <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/&title=4+Fabulous+Fitness+Stocks+to+Buy+Now&summary=" title="Share on LinkedIn" target="_blank" class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a></div> <script>jQuery(document).ready(function($){
                jQuery("a.sn-social-share").click(function() {
                  window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');
                  return false;
                });
              });</script></div><br></section></div><div class="col-lg-6"><div class="post-categories zero-padding pull-right no-margin-bottom no-margin-top"></div></div></div></div></div></div><div class="right-margin-ad" style="position: absolute; right:-210px; top:20%"><div style="width:200px !important;"><div class="panel panel-default"><div class="panel-heading"><h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3></div><div class="panel-body"><form role="form" action="/v/" method="GET" class="form-inline"><p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><input name="tag_id" type="hidden" value="193"><input name="redirect_url" type="hidden" value="https://stocknews.com/registration/"><div class="input-group" style="display: block !important;"> <input class="form-control" type="email" name="email" value="" placeholder="Your Email Address..." id="email" style="font-size:13px !important;"><div align="center"><span class="input-group-btn"> <button style="background-color:#ffa200;-moz-border-radius:5px;-webkit-border-radius:5px;border-radius:5px;border:1px solid #92a394;display:inline-block;cursor:pointer;color:#ffffff;font-family:Arial;font-size:17px;padding: 5px 44px;text-decoration:none;text-shadow:0px 1px 0px #556353;margin-top: 5px;" type="submit">Subscribe</button> </span></div></div></form> <script type="text/javascript" src="https://sk687.infusionsoft.app/app/webTracking/getTrackingCode"></script><script type="text/javascript" src="https://sk687.infusionsoft.com/app/timezone/timezoneInputJs?xid=b8eca134cbe7a3685442b13f285af63c"></script></div></div></div></div><div class="post_content" style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><html><body><p>I can tell you first hand that staying @ home = eating @ home <em>ALL THE TIME!</em></p><p>Yes, easy access to food all day does lead to putting on a bit more weight. So like many I am trying to shake off the excess weight by staying more fit. And as I look around in the media I see that I am not alone in following this trend.</p><p>That is why it makes sense to turn the spotlight on the fitness companies that do best in when folks seek to work out more often on their own. These 4 stocks are the standouts: <strong>Fitbit, Inc (<a href="https://stocknews.com/stock/FIT/" data-cke-saved-href="https://stocknews.com/stock/FIT/">FIT</a>), GoPro (<a href="https://stocknews.com/stock/GPRO/" data-cke-saved-href="https://stocknews.com/stock/GPRO/">GPRO</a>), Nike (<a href="https://stocknews.com/stock/NKE/" data-cke-saved-href="https://stocknews.com/stock/NKE/">NKE</a>) and Peloton (<a href="https://stocknews.com/stock/PTON/" data-cke-saved-href="https://stocknews.com/stock/PTON/">PTON</a>). </strong>Let’s find out why…</p><p><strong>Fitbit, Inc (<a href="https://stocknews.com/stock/FIT/" data-cke-saved-href="https://stocknews.com/stock/FIT/">FIT</a>)</strong></p><div><div style="border-top:1px solid #eee; margin-top:10px; border-bottom:1px solid #eee; margin-bottom:10px;"><br><p style="text-align:center; font-family: arial; font-size:25px; font-weight:bold;"><a href="https://report.stocknews.com/9-must-have-stocks/?lead_source=sn-below_article&medium=spons-img&campaign=9btds" target="_blank">9 <em>"BUY THE DIP"</em> Growth Stocks For 2020</a></p></div></div><p>The beginning of the Stay @ Home directives may have felt a little bit like a quasi-vacation. No more getting up for work, grueling commutes, or client visits. Now, that we’ve all had the chance to settle in a bit, many people are looking for ways to make the most out of these quieter and slower-paced days. That explains why Fitbit (FIT) is enjoying an increase in demand due to increased use by folks still looking to maintain some level of activity throughout their days. Health tracking is likely to become more of a part of consumers’ everyday lives, even as we move past this period of mass quarantines. And FIT really is the most dedicated player in the space.</p><p>Our <a href="https://stocknews.com/powr-ratings/">POWR Rating model</a> shows FIT as “B” rated for Buy. That is because this is one of the few stocks that has actually landing in positive territory this year while most other stocks are in bear market territory. Going back 6 months we see that FIT shares are actually up 53%. The momentum is there for good reason and not likely to go away any time soon.</p><p><strong>Peloton (</strong><a href="https://stocknews.com/stock/PTON/" data-cke-saved-href="https://stocknews.com/stock/PTON/"><strong>PTON</strong></a><strong>)</strong></p><p>Peleton is the hot name in home fitness. And likely PTON only looks better as more folks are forced to work out at home which is their specialty.</p><p>I have to confess to being wooed in by Peleton as we bought a bike last year. And the thing that pulled me in was the countless recommendations from close friends who believed it was the best piece of home work out equipment. That is true. But what is even more impressive to me about PTON is the line up of non-cycle classes that I can stream online for core workouts, weights, yoga and more. I actually stream that more often than riding the bike itself.</p><p>Back to the investment picture for PTON, even though it is up this year, analysts are still calling for more. The average target on Wall Street is just shy of $38. But in the past week 3 fresh buy ratings came out on Peleton with targets ranging from $40 to $43. PTON is a fitness craze that is not going away and likely can ride it to the bank. (sorry for the bad cycling pun).</p><div class="text-center" id="StockNews_ROS_RightRail_1" style="padding-right:20px"></div><p><strong>GoPro (<a href="https://stocknews.com/stock/GPRO/" data-cke-saved-href="https://stocknews.com/stock/GPRO/">GPRO</a>)</strong></p><p>Like many hot IPOs, GoPro got a little too big for its britches as the reality of their growth did not meet up with the stratospheric projections. Since GPRO shares have plummeted back down to earth we see a much more interesting growth and value story emerging.</p><p>That is even true in the new Coronavirus economy as people are yearning to be outside…just not nearby any other humans. The solution is to consider more outdoor pursuits such as camping, fishing, mountain biking, and the like. It’s going to be a while before anyone’s completely ready to head back into crowded areas. In other words, a lot of families may be headed to State and National Parks rather than amusement parks for their annual vacation. That is a landscape that GPRO can thrive in.</p><p>Analysts are forecasting around <a href="https://www.tipranks.com/stocks/gpro/price-target" data-cke-saved-href="https://www.tipranks.com/stocks/gpro/price-target">40% upside</a> for GRPO with a price target of $3.55 up from the current level of $2.54. I definitely think it’s one to watch, and worth a closer look at this time.</p><p><strong>Nike (</strong><a href="https://stocknews.com/stock/NKE/" data-cke-saved-href="https://stocknews.com/stock/NKE/"><strong>NKE</strong></a><strong>)</strong></p><div class="text-center" id="StockNews_ROS_RightRail_2" style="float:right"></div><p>Everyone seems to love Nike, and with many consumers becoming more fitness and health-conscious, it’s easy to see NKE as the safe play. In addition to their sportswear, NKE also offers a good amount of outdoor gear, and I’m thinking that activities that lend themselves well to physical distancing are going to continue to perform well in the age of coronavirus.</p><p>Analysts over at <a href="https://www.tipranks.com/stocks/nke/price-target" data-cke-saved-href="https://www.tipranks.com/stocks/nke/price-target">TipRanks agree</a> with this assessment and show NKE as an appealing Buy target. The average projection is for shares to rise to $96, but there are some 5 Star analysts still calling for $115 a share.</p><p>NKE makes sense with current fitness trends. But in the long run, this is a quality company that makes sense in a lot of portfolios. So it is tempting for long term investors to swoop in and buy NKE shares at this level for the likely upside in the years to come.</p><p><strong><em>Want More Great Investing Ideas?</em></strong></p><p><a href="https://sk687.isrefer.com/go/9gs/sn/art_txt">9 “<em>BUY THE DIP</em>” Growth Stocks for 2020</a></p><p><a href="https://sk687.isrefer.com/go/7sh/sn/art_txt">7 “Safe-Haven” Dividend Stocks for Turbulent Times</a></p><p><a href="https://stocknews.com/news/spy-dia-iwm-mdy-qqq-investors-its-still-really-bad-out-there/">Investors Beware: It’s Still Really Bad Out There!</a></p><p> </p><hr><p>FIT shares fell $6.73 (-100.00%) in premarket trading Tuesday. Year-to-date, FIT has gained 2.44%, versus a -12.00% rise in the benchmark S&P 500 index during the same period.</p></body></html><div style="clear:both;"></div><br><h2>About the Author: Steve Reitmeister</h2><br><img src='https://stocknews.com/wp-content/uploads/2019/07/Screen-Shot-2019-07-23-at-2.05.03-PM.png' style="float:left; padding:5px;width:125px;"><p>Steve is better known to the StockNews audience as “Reity”. Not only is he the CEO of the firm, but he also shares his 40 years of investment experience in the <a href="https://stocknews.com/registration/trial-19/" title="More info about Reitmeister Total Return portfolio">Reitmeister Total Return portfolio</a>. Learn more about Reity’s background, along with links to his most recent articles and stock picks. <a href="https://stocknews.com/authors/?author=steve-reitmeister">More...</a></p><br><div style="clear:both;"></div><h2>More Resources for the Stocks in this Article</h2><table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;"><tr style="background-color:#5cb85c; color:white;"><td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style="text-align:center;"><td><a href="https://stocknews.com/stock/FIT/">FIT</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td></tr><tr style="text-align:center;"><td><a href="https://stocknews.com/stock/GPRO/">GPRO</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td></tr><tr style="text-align:center;"><td><a href="https://stocknews.com/stock/NKE/">NKE</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td></tr><tr style="text-align:center;"><td><a href="https://stocknews.com/stock/PTON/">PTON</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/" style="color:green; font-style:italic;">Get Rating</a></td></tr></table></div></div><div align="center"><div style="clear: both;"></div><div class="panel panel-default" style="max-width:750px;" id="topstories"><div class="panel-heading"><h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3></div><div class="panel-body"><p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><form role="form" method="GET" action="/v/" id="validate"> <input name="tag_id" type="hidden" value="199"> <input name="redirect_url" type="hidden" value="https://stocknews.com/thanks/"><div class="input-group"> <input class="form-control" type="email" name="email" value="" placeholder="Enter Your Email Address" id="email"> <span class="input-group-btn"> <input type="submit" class="btn btn-primary" data-enabled="enabled" role="button" value="Subscribe"> </span></div></form></div></div> <script>$(function(){
  $('form[name=cc_form]').submit(function(){
    $.post($(this).attr('action'), $(this).serialize(), function(json) {
      alert(json);
    }, 'json');
    return false;
  });
});</script> </div></div><div class="col-lg-2 col-md-2"></div></header><div></div><div class="row margin-top"><div class="col-lg-2 col-md-1"></div><div class="col-lg-8 col-md-10"><div id="stocknews_ros_belowpost_1"></div><br><h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Top Stories on StockNews.com</strong></h2><div class="margin-bottom"><div class="pull-left no-mobile-pull pad-right"> <a href="/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/"><img class="img-rounded three-hundo" src="https://stocknews.com/wp-content/uploads/2020/01/business-growth-1-1057028-1-scaled.jpg" alt="NYSE: FIT | Fitbit, Inc.  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top"> <a href="/news/fit-gpro-nke-pton-4-fabulous-fitness-stocks-to-buy-now/" class="black">4 Fabulous Fitness Stocks to Buy Now</a></h3> The antidote for the stress of staying @ home so much is trying to stay physically fit. These 4 stocks are benefiting the most from that trend: FIT, GRPO, NKE and PTON. Read on...<section class="post-meta zero-padding pad-bottom margin-top"> <a href="">Apr 21, 2020</a> <span class="light-gray">|</span> 8:21am</section></div></div><div class="clearfix"></div></div><div class="margin-bottom"><div class="pull-left no-mobile-pull pad-right"> <a href="/news/fb-snap-mcd-ko-gpro-facebook-snapchat-and-gopro-report-surging-traffic-during-lockdown/"><img class="img-rounded three-hundo" src="https://stocknews.com/wp-content/uploads/2020/04/shutterstock_219530599-scaled.jpg" alt="NASDAQ: FB | Facebook, Inc. -  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top"> <a href="/news/fb-snap-mcd-ko-gpro-facebook-snapchat-and-gopro-report-surging-traffic-during-lockdown/" class="black">Facebook, Snapchat and GoPro Report Surging Traffic During Lockdown</a></h3> The sharing trend has been growing for years, but you better believe the boost it received recently will drive up stocks that dominate the sector like: FB, SNAP, and GPRO.<section class="post-meta zero-padding pad-bottom margin-top"> <a href="">Apr 20, 2020</a> <span class="light-gray">|</span> 4:51pm</section></div></div><div class="clearfix"></div></div> <script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=98944&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed1277phwmyzxj&subId=[SUBID_ENCODED]"></script> <div class="margin-bottom"><div class="pull-left no-mobile-pull pad-right"> <a href="/news/dell-adbe-iac-3-tech-stocks-that-will-benefit-from-changes-in-the/"><img class="img-rounded three-hundo" src="https://stocknews.com/wp-content/uploads/2020/04/shutterstock_742434955-1-scaled.jpg" alt=": Dell | Dell Technologies Inc. Class C  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top"> <a href="/news/dell-adbe-iac-3-tech-stocks-that-will-benefit-from-changes-in-the/" class="black">3 Tech Stocks That Will Benefit From Changes in the Economy</a></h3> Three companies that may eventually benefit from the changes in the economy that come in the wake of the virus are Adobe (ADBE), Dell Technologies (DELL), and Interactive Corp (IAC)<section class="post-meta zero-padding pad-bottom margin-top"> <a href="">Apr 20, 2020</a> <span class="light-gray">|</span> 2:14pm</section></div></div><div class="clearfix"></div></div><div class="margin-bottom"><div class="pull-left no-mobile-pull pad-right"> <a href="/news/shop-chwy-ebay-meli-4-best-ecommerce-stocks-as-consumers-shop-from-home/"><img class="img-rounded three-hundo" src="https://stocknews.com/wp-content/uploads/2020/01/shutterstock_120044452-scaled.jpg" alt="NYSE: SHOP | Shopify Inc. Class A Subordinate Voting Shares News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top"> <a href="/news/shop-chwy-ebay-meli-4-best-ecommerce-stocks-as-consumers-shop-from-home/" class="black">4 Best Ecommerce Stocks as Consumers Shop from Home</a></h3> There are many other ecommerce firms, besides Amazon, that are benefiting from the Stay @ Home trends in the Covid-19 economy. Here are 4 others to consider adding to your cart at this time: SHOP, CHWY, EBAY & MELI. Read on...<section class="post-meta zero-padding pad-bottom margin-top"> <a href="">Apr 19, 2020</a> <span class="light-gray">|</span> 2:12pm</section></div></div><div class="clearfix"></div></div><div class="margin-bottom"><div class="pull-left no-mobile-pull pad-right"> <a href="/news/de-agco-cat-3-buy-the-dip-agriculture-equipment-stocks/"><img class="img-rounded three-hundo" src="https://stocknews.com/wp-content/uploads/2020/01/shutterstock_181864331-scaled.jpg" alt="NYSE: DE | Deere & Company  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top"> <a href="/news/de-agco-cat-3-buy-the-dip-agriculture-equipment-stocks/" class="black">3 “Buy the Dip” Agriculture Equipment Stocks</a></h3> No matter how bad the economy gets, people still need to eat. That is why investors should snap up the best agriculture equipment stocks on the recent dip. The 3 to focus on are DE, CAT and AGCO. Read on for more...<section class="post-meta zero-padding pad-bottom margin-top"> <a href="">Apr 19, 2020</a> <span class="light-gray">|</span> 11:17am</section></div></div><div class="clearfix"></div></div><h3> <a href="/top-stories/" class="btn btn-default width-full margin-top-less" role="button">Read More Stories</a></h3><div style="align:center"><div id="StockNews_ROS_Bottom_Leaderboard"></div></div></div></div><hr><div class="row margin-top"><div class="col-lg-12"><h3> More Fitbit, Inc. (FIT) News <a href="/stock/FIT/news/" class="btn btn-default" role="button">View All</a></h3><div class="panel panel-default"><table class="table-condensed table table-striped news mobile-card-view" id="news-stream"><thead><tr><th>Event/Date</th><th>Symbol</th><th>News Detail</th><th class="text-right" nowrap>Start Price</th><th class="text-right" nowrap>End Price</th><th nowrap>Change</th><th>POWR Rating</th></tr></thead><tbody><tr><td colspan="10" class="text-center">Loading, please wait...</td></tr></tbody></table></div> <a href="/stock/FIT/" class="btn btn-default width-full margin-top-less">View All FIT News</a></div></div></article></div> <script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script> <script src="//code.highcharts.com/stock/highstock.js"></script> <script src="//code.highcharts.com/highcharts-more.js"></script> <script src="//code.highcharts.com/stock/modules/exporting.js"></script> <script>$(function () {
    Highcharts.setOptions({
      global: {
              timezoneOffset: 5 * 60
          }
    });
    // Create the chart
    $('#chart-container').highcharts('StockChart', {

        
          
        

        exporting: { enabled: false },

        navigator : {
          enabled : false
        },

        scrollbar : {
          enabled : false
        },

        rangeSelector : {
          buttons: [{
            type: 'day',
            count: 1,
            text: '1d'
          },
          {
            type: 'day',
            count: 3,
            text: '3d'
          },
          {
            type: 'day',
            count: 5,
            text: '5d'
          },
          {
            type: 'month',
            count: 1,
            text: '1m'
          }],
          selected : 0, // 1 day chart
          inputEnabled: false,
          /*
          buttonTheme: {
            visibility: 'hidden'
          },
          labelStyle: {
            visibility: 'hidden'
          }
          */
        },

        title : {
          text : 'FIT Intraday - Apr 21, 2020',
          floating: true,
          y : 55,
          style : {
            "color": "#555555",
            "fontSize": "12px"
          }
        },

        series : [{
          name : 'FIT',
          data : [],
          tooltip: {
              valueDecimals: 2
          },
          type: 'area',
          fillColor: '#e0fadc',
          lineColor: '#8ed387',
          threshold: null
        }]
        
    });
  });
  jQuery(document).ready(function($){
    function symbol_get_snippets(symbol) {
      $.getJSON('https://stocknews.com/wp-content/themes/strappress-child/includes/snippet-json.php?symbol=FIT&limit=10&historical_prices=1',
        function (json) {
          $("table#news-stream tbody").html("");
          var tr=[];
          for (var i = 0; i < json.results.length; i++) {
            if ((json.results[i].top_story_headline != "") && (json.results[i].top_story_headline != null)) {
              var headline = json.results[i].top_story_headline;
            } else {
              var headline = json.results[i].notes;
            }
            tr.push('<tr>');
            tr.push('<td class="bullorbear-' + json.results[i].bull_or_bear + 'a"><strong>' + json.results[i].event_short + '</strong><br><span class="medium-gray">' + json.results[i].snippet_time + '</span></div>');
            tr.push('<td><strong><a href="/stock/' + json.results[i].symbol + '/">' +  json.results[i].symbol + '</strong></td>');
            //tr.push('<td><a href="/stock/' + json.results[i].symbol + '/">' + json.results[i].company + '</a></td>');
            tr.push('<td><span class="dark-gray"><a href="https://stocknews.com/news/' + json.results[i].post_slug + '">' + headline + '</a></span></td>');
            tr.push('<td class="text-right">' + json.results[i].price_when_added + '</td>');
            tr.push('<td class="text-right grade-' + json.results[i].day_change_color + '">' + json.results[i].day_close + '</td>');
            tr.push('<td class="grade-' + json.results[i].day_change_color + '">' + json.results[i].day_change + '<br>' + json.results[i].day_pct_change + '</td>');
            //tr.push('<td class="grade-' + json.results[i].ttm_color + '">' + json.results[i].ttm_pct_change_formatted + '</td>');
            tr.push('<td class="text-center grade-' + json.results[i].powr_grade_color + '"><strong>' + json.results[i].powr_grade + '</strong><br><small>' + json.results[i].powr_grade_text + '</small></td>');
                        tr.push('</tr>');
          }
          $(tr.join('')).appendTo($('table#news-stream tbody')).slideDown("slow");
      });
    }
    symbol_get_snippets('FIT');
  });</script> Page generated in 1.5867 seconds.</div></div><footer id="footer" class="clearfix"><div class="container"><hr><div id="footer-wrapper"><div class="row margin-bottom"><div class="col-lg-6"> &copy;2020 StockNews.com</div><div class="col-lg-6 text-right"> <a href="/about/">About Us</a> | <a href="/contact/">Contact Us</a> | <a href="/legal/">Terms of Use</a></div></div><div class="row"><div class="col-lg-6"><p><small>Copyright &copy; 2020. Market data provided is at least 10-minutes delayed and hosted by <a href="https://www.barchart.com/solutions" target="_blank">Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href="http://www.barchart.com/solutions/company/terms-and-privacy">disclaimer</a>.</small></p></div><div class="col-lg-6" <p><small>Automated Insights by <a href="https://sixjupiter.com" target="_blank">SixJupiter</a>. <br><br> <em>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" rel="nofollow">Privacy Policy</a> and <a href="https://policies.google.com/terms" rel="nofollow">Terms of Service</a> apply.</em></small></p></div></div></div></div></footer> <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='d1a293004a063000b79b40002eed8d007d2680005842eb00f4865000f034f400';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">var ajaxurl = "https://stocknews.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' src='https://stocknews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc&#038;ver=3.0'></script> <script type='text/javascript' src='https://stocknews.com/wp-content/themes/strappress/js/responsive-scripts.js?ver=1.1.0'></script> <script type='text/javascript' src='https://stocknews.com/wp-content/themes/strappress/js/responsive-plugins.js?ver=1.1.0'></script> <script type='text/javascript' src='https://stocknews.com/wp-includes/js/wp-embed.min.js?ver=041fd1f4f2f59d46e35adac52db4cd73'></script> <script type="text/javascript">( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc',
	{"homepage":"homepage","contactform":"contactform"}
);</script> <div id="StockNews_PopUp_PopUp" class="text-center"> <script type="text/javascript">apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });</script> </div></body></html>