<!doctype html>
<!--[if lt IE 7 ]><html
class="no-js ie6" lang=en-US> <![endif]-->
<!--[if IE 7 ]><html
class="no-js ie7" lang=en-US> <![endif]-->
<!--[if IE 8 ]><html
class="no-js ie8" lang=en-US> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html class=no-js lang=en-US> <!--<![endif]--><head><meta charset=UTF-8><meta name=viewport content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge,chrome=1"><meta name=google-site-verification content=DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps><style media=all>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</style><title>APHA: Are Shares of Aphria a Buy at the Current Price?</title><link rel=icon type=image/png href><link rel=dns-prefetch href=//www.google.com><link href=https://fonts.gstatic.com crossorigin=anonymous rel=preconnect><meta property=og:title content="APHA: Are Shares of Aphria a Buy at the Current Price? | StockNews.com"><meta property=og:description content="For the first time since the global coronavirus pandemic began, Aphria (APHA) traded above $5 last week"><meta property=og:type content=article><meta property=og:url content=https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/><meta property=og:site_name content=StockNews.com><meta property=og:image content=https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg><meta name=twitter:card content=summary_large_image><meta name=twitter:title content="APHA: Are Shares of Aphria a Buy at the Current Price? | StockNews.com"><meta name=description content="Aphria Inc.(NYSE:APHA): For the first time since the global coronavirus pandemic began, Aphria (APHA) traded above $5 last week"><meta name=keywords content=":APHA, Aphria Inc. Common Shares, Medical - Pharmaceuticals, Commentary"> <script type=application/ld+json>{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/"
 },
 "headline": "Are Shares of Aphria a Buy at the Current Price?",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg" },
  "datePublished": "2020-06-16T17:31:34-04:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
  "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Aphria Inc.(NYSE:APHA) For the first time since the global coronavirus pandemic began, Aphria (APHA) traded above $5 last week"
}</script> <link rel=canonical href=https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/> <script src='https://stocknews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script src='https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_bf9cfbce096edc9621b94f875e62eb56.js?ver=2.5.3'></script> <script src='https://stocknews.com/wp-content/themes/strappress/js/magnific.min.js?ver=0.9.4'></script> <script src='https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_8015042d0b4ac125867af5b096b175ce.js?ver=87771ef0222e30c9f86f6b0a623cf83a'></script> <link rel=https://api.w.org/ href=https://stocknews.com/wp-json/><link rel=alternate type=application/json+oembed href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F"><link rel=alternate type=text/xml+oembed href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml"> <script>// 
    jQuery(document).ready(function($){
        $("a[rel='magnific']").magnificPopup({
                type:'image'
        });
    });  
    //</script>
<!--[if lt IE 9]> <script src=https://stocknews.com/wp-content/themes/strappress/js/respond.min.js></script> <![endif]--><link rel=stylesheet href=//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css> <script src=//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js></script> <script src=//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js></script> <script src=/wp-content/themes/strappress/js/bootstrap-table/dist/bootstrap-table.min.js data-cfasync=false></script> <script src=https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_994f5ca310e9cca8391d17f33c95868c.js data-cfasync=false></script> <script src=https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_4ed395ae40e11dd806b1e5d73c182b20.js data-cfasync=false></script> <script src=https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_0f6d75fd461d7f795f9da10c4a1b9e4f.js data-cfasync=false></script> <script data-cfasync=false>jQuery(document).ready(function($){
    $('a.sn_pop').on('click', function(e) {e.preventDefault(); return true;});
    $( ".ticker-search" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class=sixteen>' + item.label + '</strong><br><span class=medium-gray>' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $( ".ticker-search-big" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class=sixteen>' + item.label + '</strong><br><span class=medium-gray>' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $('[data-toggle="popover"]').popover({html: true, trigger: 'focus'});
  });</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64545224-1', 'auto');
  ga('send', 'pageview');</script> <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript>
<img
src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1">
</noscript> <script data-cfasync=false>var apntag = apntag || {};
apntag.anq = apntag.anq || [];
(function() {
  var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
  e.type = 'text/javascript';  e.async = true;
  e.src = 'https://acdn.adnxs.com/ast/ast.js';
  p.insertBefore(e, p.firstChild);
})();


apntag.anq.push(function() {
  apntag.setPageOpts({
    member: 6989
  });
});

apntag.anq.push(function() {

      apntag.defineTag({
    tagId: 13208681,
    sizes: [[550,480],[600,400],[640,480]],
    keywords: {'position': ['PopUp']},
    targetId: 'StockNews_PopUp_PopUp'
  });
      });

apntag.anq.push(function() {
  apntag.loadTags();
});</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MR8XMKP');</script> <script data-cfasync=false>(function() { window.advBidxc = window.advBidxc || {}; window.advBidxc.startTime = new Date().getTime(); function loadScript(tagSrc) { var scriptTag = document.createElement('script'), placeTag = document.getElementsByTagName("script")[0]; scriptTag.type = 'text/javascript'; scriptTag.async = true; scriptTag.src = tagSrc; placeTag.parentNode.insertBefore(scriptTag, placeTag); } var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' + window.location.hostname; loadScript(mnSrc); })();</script> <link rel=stylesheet href=https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css></head><body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78">
<noscript><iframe
src="https://www.googletagmanager.com/ns.html?id=GTM-MR8XMKP"
height=0 width=0 style=display:none;visibility:hidden></iframe></noscript><header><div style=background:#333; class=headerstick><div class=container><div id=logo class="hidden-sm hidden-xs"><a href=https://stocknews.com/ title=StockNews.com rel=home>
<noscript><img
src=/img/sn-green.png alt=StockNews.com style=width:360px;height:auto></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src=/img/sn-green.png alt=StockNews.com style=width:360px;height:auto>
</a></div><nav class="navbar-collapse collapse navbar-responsive-collapse"><ul class="nav navbar-bav navbar-right"><li class="menu-item menu-item-type-custom menu-item-object-custom"><p class=navbar-btn><a href=https://stocknews.com/members/login class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
Join
</a></p></li></ul><form class="navbar-form navbar-right" role=search method=post id=searchform action=https://stocknews.com/><div class=input-group>
<input name=ticker id=ticker type=text class="form-control ticker-search" placeholder="Ticker or Company" autocomplete=off size=17><div class=input-group-btn>
<button type=submit class="btn btn-success">Search</button></div></div>
<input type=hidden id=symbol_search name=symbol_search value=6546c1abe2><input type=hidden name=_wp_http_referer value=/news/apha-after-a-10-retracement-is-aphria-a-buy/></form></nav><nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0"><div class=container-fluid><div class=navbar-header><div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href=https://stocknews.com/ title=StockNews.com rel=home>
<noscript><img
src=/img/sn-green.png style=width:220px;height:auto alt=StockNews.com></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src=/img/sn-green.png style=width:220px;height:auto alt=StockNews.com>
</a></div>
<button type=button class="navbar-toggle collapsed" data-toggle=collapse data-target=#navbar aria-expanded=false> <span class=sr-only>Toggle navigation</span>
<span class="fa fa-bars" style="color:#fff !important;"></span>
</button>
<button type=button class="navbar-toggle collapsed" data-toggle=collapse data-target=#navbar-search aria-expanded=false> <span class=sr-only>Toggle navigation</span>
<span class="fa fa-search" style="color: #fff !important;"></span>
</button></div><div class="collapse navbar-collapse" id=navbar><ul id=menu-top-nav class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
<a class=dropdown-toggle aria-expanded=false>
News<span class=caret></span>
</a><ul class=dropdown-menu><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/top-stories/>
Top Stories
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/best-worst/>
Best & Worst Articles
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/video-news/>
Video News
</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
<a class=dropdown-toggle aria-expanded=false>
Best Stocks<span class=caret></span>
</a><ul class=dropdown-menu><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/best-stocks/>
"A" Rated Stocks
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/powr-upgrades-downgrades/>
Upgrades/Downgrades
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/high-yield-dividend-stocks/>
High Yield Dividend Stocks
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/stock-screener/>
Stock Screener
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/stocks/>
Industry Rank
</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
<a class=dropdown-toggle aria-expanded=false>
Best ETFs <span class=caret></span>
</a><ul class=dropdown-menu><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/best-etfs/>
"A" Rated ETFs
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/etfs/>
Best ETF Categories
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/high-yield-etfs/>
High Yield ETFs
</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/powr-ratings/>
POWR Ratings&trade;
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/powr-upgrades-downgrades/>
Upgrades/Downgrades
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/watchlist/>
Watchlist
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=/stock-screener/>
Screener
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
<a class=dropdown-toggle aria-expanded=false>
Services <span class=caret></span>
</a><ul class=dropdown-menu><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=https://members.stocknews.com target=_blank>
Services Home
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=https://members.stocknews.com/reitmeister-total-return/ target=_blank>
Reitmeister Total Return
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=https://members.stocknews.com/service/powr-trends/ target=_blank>
POWR Trends
</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom">
<a href=https://stocknews.com/powr-ratings/ target=_blank>
Premium
</a></li></ul></ul><ul class="nav navbar-nav hidden-lg hidden-md"><li class="menu-item menu-item-type-custom menu-item-object-custom"><p class=navbar-btn><a href=https://stocknews.com/members/login class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
Join
</a></p></li></ul></div><div class="collapse navbar-collapse" id=navbar-search><form class="navbar-form hidden-lg hidden-md" role=search method=post id=searchform2 action=https://stocknews.com/><div class=input-group>
<input name=ticker id=ticker type=text class="form-control ticker-search" placeholder="Ticker or Company" autocomplete=off size=17><div class=input-group-btn>
<button type=submit class="btn btn-success">Search</button></div></div>
<input type=hidden id=symbol_search name=symbol_search value=6546c1abe2><input type=hidden name=_wp_http_referer value=/news/apha-after-a-10-retracement-is-aphria-a-buy/></form></div></div></nav></div></div></header><br><br><br><br></div><div class=container><div class="clearfix wrapper"><div align=center><div id=StockNews_ROS_Top_Leaderboard></div></div><div id=content><article><header><div class="row margin-top"><div class="col-lg-0 col-md-2"></div><div class="col-lg-8 col-md-8"><div class=news-event><h1 class="page-title no-pad-left big-margin-bottom bold">
Are Shares of Aphria a Buy at the Current Price?</h1><h1 class="page-title no-pad-left big-margin-bottom bold"></h1><div class=text-center></div><div class="row margin-top"><div class="col-lg-12 text-center"></div></div><div><div class=panel-body style="padding: 0px !important;"><div class=row><div class=col-lg-12 style="max-height:550px; overflow:hidden;">
<noscript><img
src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg" alt=": APHA | Aphria Inc. Common Shares News, Ratings, and Charts" style="margin:auto; display:block; max-height: 550px;"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg" alt=": APHA | Aphria Inc. Common Shares News, Ratings, and Charts" style="margin:auto; display:block; max-height: 550px;"></div><div class="col-lg-12 col-md-8"><p><strong><a href=/stock/APHA/>APHA</a></strong> &#8211; For the first time since the global coronavirus pandemic began, Aphria (APHA) traded above $5 last week.</p></div></div><div class="row no-margin-top"><div class=col-lg-12><section class="post-meta zero-padding pad-bottom">
<noscript><img
src='/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,width=80/https://stocknews.com/wp-content/uploads/2019/07/Aaron-Missere.jpg' style="float:left; padding:5px;width:80px;"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src='/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,width=80/https://stocknews.com/wp-content/uploads/2019/07/Aaron-Missere.jpg' style="float:left; padding:5px;width:80px;"><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=aaron-missere">By Aaron Missere</a></strong></span><br> <a href>Jun 16, 2020</a><div style=float:right;><div class="social-wrapper no-margin-bottom no-margin-top">
<a href="https://twitter.com/intent/tweet?text=%24APHA+Are+Shares+of+Aphria+a+Buy+at+the+Current+Price%3F&amp;url=https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target=_blank><i class="fa fa-twitter"></i></a>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/" title="Share on Facebook" target=_blank class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/apha-after-a-10-retracement-is-aphria-a-buy/&title=Are+Shares+of+Aphria+a+Buy+at+the+Current+Price%3F&summary=" title="Share on LinkedIn" target=_blank class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a></div> <script>jQuery(document).ready(function($){
                jQuery("a.sn-social-share").click(function() {
                  window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');
                  return false;
                });
              });</script></div><br></section></div><div class=col-lg-6><div class="post-categories zero-padding pull-right no-margin-bottom no-margin-top"></div></div></div></div></div></div><div class=right-margin-ad style="position: absolute; right:-210px; top:20%"><div style="width:200px !important;"><div class="panel panel-default"><div class=panel-heading><h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden=true></span> Get Free Updates</h3></div><div class=panel-body><form role=form action=/v/ method=GET class=form-inline><p class=fourteen>Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><input name=tag_id type=hidden value=193><input name=redirect_url type=hidden value=https://stocknews.com/registration/><div class=input-group style="display: block !important;"> <input class=form-control type=email name=email value placeholder="Your Email Address..." id=email style="font-size:13px !important;"><div align=center><span class=input-group-btn> <button style="background-color:#ffa200;-moz-border-radius:5px;-webkit-border-radius:5px;border-radius:5px;border:1px solid #92a394;display:inline-block;cursor:pointer;color:#ffffff;font-family:Arial;font-size:17px;padding: 5px 44px;text-decoration:none;text-shadow:0px 1px 0px #556353;margin-top: 5px;" type=submit>Subscribe</button> </span></div></div></form> <script src=https://sk687.infusionsoft.app/app/webTracking/getTrackingCode></script><script src="https://sk687.infusionsoft.com/app/timezone/timezoneInputJs?xid=b8eca134cbe7a3685442b13f285af63c"></script></div></div></div></div><div class=post_content id=articlecontent style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><html><body><p></p><p><span style="font-weight: 400;">For the first time since the global coronavirus pandemic began, Aphria (</span><a href=https://stocknews.com/stock/APHA/><span style="font-weight: 400;">APHA</span></a><span style="font-weight: 400;">) traded above $5 last week. </span></p><p><span style="font-weight: 400;">However, this bullish move was short lived.  By last Thursday, when the markets plummeted, shares of APHA fell and it is currently trading at about $4.50.</span></p><p><span style="font-weight: 400;">Is this recent down move a buying opportunity?</span></p><div><div style="border-top:1px solid #eee; margin-top:10px; border-bottom:1px solid #eee; margin-bottom:10px;"><br><p style="text-align:center; font-family: arial; font-size:25px; font-weight:bold;"><a href="https://report.stocknews.com/7-safe-haven-dividend-stocks/?lead_source=sn-below_article&medium=spons-img&campaign=7shds" target=_blank>7 <em>"SAFE HAVEN"</em> Dividend Stocks for Turbulent Times</a></p></div></div><p><span style="font-weight: 400;">In a sector where investors are laser-focused on profitability, or should we say lack of profitability, APHA has been a standout performer.  The company released its most recent earnings results in April and reported a profit.  This was the third quarter out of the past four quarters, that the company posted a profit.  That’s extremely impressive, especially when you look at APHA’s peers, most of whom report losses quarter after quarter.</span></p><p><span style="font-weight: 400;">APHA reported net sales of CA$144.4 million which were 19.7% higher compared to the previous quarter.</span></p><p><span style="font-weight: 400;">When it comes to operating expenses the company did burn through $124.4 million in operating expenses in the previous nine months.  However, APHA has a sizable cash position of roughly $515 million in cash. This cash position should prevent APHA from having to dilute their shares by selling stock to raise capital.  And it should give the company a buffer to weather the storm that the COVID-19 pandemic has created.</span></p><p><span style="font-weight: 400;">Therefore, in our opinion, this 10% sell-off that has occurred in the past week is a buying opportunity. </span></p><p><span style="font-weight: 400;">Next month, when APHA releases their next earnings report, investors should focus on Canadian recreational sales figures along with international revenues from Germany. The German cannabis market was one of the main drivers in revenues for APHA when they initially achieved profitability and investors will want to see that this revenue stream remains strong. </span></p><p><span style="font-weight: 400;">(Disclosure: The author is long APHA)</span></p><div class=text-center id=StockNews_ROS_RightRail_1 style=padding-right:20px></div><p></p><p><strong><em>Want More Great Investing Ideas?</em></strong></p><p><a href=https://stocknews.com/news/spy-inx-dia-iwm-qqq-do-not-buy-this-dip/>Do NOT Buy This Dip!</a> Are you prepared for the bear market’s return?</p><p><a href=https://sk687.isrefer.com/go/7sh/sn/art_txt>7 “Safe-Haven” Dividend Stocks for Turbulent Times</a></p><p><a href=https://sk687.isrefer.com/go/9gs/sn/art_txt>9 “<em>BUY THE DIP</em>” Growth Stocks for 2020</a></p><hr><div class=text-center id=StockNews_ROS_RightRail_2 style=float:right></div><p>APHA shares were unchanged in after-hours trading Tuesday. Year-to-date, APHA has declined -14.18%, versus a -2.19% rise in the benchmark S&P 500 index during the same period.</p><script defer src=https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_945a4fde07d43db923f3b675b67f616c.js></script></body></html><div style=clear:both;></div><br><h2>About the Author: Aaron Missere</h2><br><noscript><img
src=https://stocknews.com/wp-content/uploads/2019/07/Aaron-Missere.jpg style="float:left; padding:5px;width:125px;"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src=https://stocknews.com/wp-content/uploads/2019/07/Aaron-Missere.jpg style="float:left; padding:5px;width:125px;"><p>Aaron is an experienced investor who is also the CEO of Departures Capital. His primary focus is on the cannabis industry. He also hosts a weekly show on YouTube about marijuana stocks. Learn more about Aaron’s background, along with links to his most recent articles. <a href="https://stocknews.com/authors/?author=aaron-missere">More...</a></p><br><div style=clear:both;></div><h2>More Resources for the Stocks in this Article</h2><table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;"><tr style="background-color:#5cb85c; color:white;"><td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style=text-align:center;><td><a href=https://stocknews.com/stock/APHA/>APHA</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td></tr></table></div></div><div align=center class=margin-top><div style="clear: both;"></div><div class="panel panel-default" style=max-width:750px; id=topstories><div class=panel-heading><h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden=true></span> Get Free Updates</h3></div><div class=panel-body><p class=fourteen>Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><form role=form method=GET action=/v/ id=validate>
<input name=tag_id type=hidden value=199>
<input name=redirect_url type=hidden value=https://stocknews.com/thanks/><div class=input-group>
<input class=form-control type=email name=email value placeholder="Enter Your Email Address" id=email>
<span class=input-group-btn>
<input type=submit class="btn btn-primary" data-enabled=enabled role=button value=Subscribe>
</span></div></form></div></div> <script>$(function(){
  $('form[name=cc_form]').submit(function(){
    $.post($(this).attr('action'), $(this).serialize(), function(json) {
      alert(json);
    }, 'json');
    return false;
  });
});</script> </div></div><div class="col-lg-2 col-md-2"></div></header><div></div><div class="row margin-top"><div class="col-lg-2 col-md-1"></div><div class="col-lg-8 col-md-10"><div id=stocknews_ros_belowpost_1></div><br><h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Top Stories on StockNews.com</strong></h2><div class=margin-bottom><div class="pull-left no-mobile-pull pad-right">
<a href=/news/dkng-mgm-penn-gmbl-4-stocks-to-gamble-on-sports-betting/><noscript><img
class="img-rounded three-hundo" src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_38241721-scaled.jpg" alt=": DKNG | DraftKings Inc. Cl A News, Ratings, and Charts"></noscript><img class="lazyload img-rounded three-hundo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_38241721-scaled.jpg" alt=": DKNG | DraftKings Inc. Cl A News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top">
<a href=/news/dkng-mgm-penn-gmbl-4-stocks-to-gamble-on-sports-betting/ class=black>4 Stocks to Gamble on Sports Betting</a></h3>
MGM Resorts (MGM), Penn National Gaming (PENN), DraftKings (DKNG), and Esports Entertainment Group (GMBL) could have a good chance of moving upwards in the months to come<section class="post-meta zero-padding pad-bottom margin-top">
<a href>Jun 16, 2020</a> <span class=light-gray>|</span> 7:30pm</section></div></div><div class=clearfix></div></div><div class=margin-bottom><div class="pull-left no-mobile-pull pad-right">
<a href=/news/lly-bbby-x-kss-vmc-top-5-large-cap-dividend-stocks-for-june-16-2020/><noscript><img
class="img-rounded three-hundo" src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_1537864670-scaled.jpg" alt="NYSE: LLY | Eli Lilly and Company  News, Ratings, and Charts"></noscript><img class="lazyload img-rounded three-hundo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_1537864670-scaled.jpg" alt="NYSE: LLY | Eli Lilly and Company  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top">
<a href=/news/lly-bbby-x-kss-vmc-top-5-large-cap-dividend-stocks-for-june-16-2020/ class=black>Top 5 Large Cap Dividend Stocks for June 16, 2020</a></h3>
The top winners in the large cap US dividend space for Tuesday, June 16, 2020 are LLY, BBBY, X, KSS, and VMC<section class="post-meta zero-padding pad-bottom margin-top">
<a href>Jun 16, 2020</a> <span class=light-gray>|</span> 6:43pm</section></div></div><div class=clearfix></div></div> <script language=javascript src="https://live.sekindo.com/live/liveView.php?s=98944&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed1277phwmyzxj&subId=[SUBID_ENCODED]"></script> <div class=margin-bottom><div class="pull-left no-mobile-pull pad-right">
<a href=/news/apha-after-a-10-retracement-is-aphria-a-buy/><noscript><img
class="img-rounded three-hundo" src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg" alt=": APHA | Aphria Inc. Common Shares News, Ratings, and Charts"></noscript><img class="lazyload img-rounded three-hundo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_190592735-scaled.jpg" alt=": APHA | Aphria Inc. Common Shares News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top">
<a href=/news/apha-after-a-10-retracement-is-aphria-a-buy/ class=black>Are Shares of Aphria a Buy at the Current Price?</a></h3>
For the first time since the global coronavirus pandemic began, Aphria (APHA) traded above $5 last week<section class="post-meta zero-padding pad-bottom margin-top">
<a href>Jun 16, 2020</a> <span class=light-gray>|</span> 5:31pm</section></div></div><div class=clearfix></div></div><div class=margin-bottom><div class="pull-left no-mobile-pull pad-right">
<a href=/news/nflx-ftnt-2-tech-stocks-to-buy-on-dips/><noscript><img
class="img-rounded three-hundo" src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/05/shutterstock_574362022-scaled.jpg" alt="NASDAQ: NFLX | Netflix, Inc. News, Ratings, and Charts"></noscript><img class="lazyload img-rounded three-hundo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/05/shutterstock_574362022-scaled.jpg" alt="NASDAQ: NFLX | Netflix, Inc. News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top">
<a href=/news/nflx-ftnt-2-tech-stocks-to-buy-on-dips/ class=black>2 Tech Stocks to Buy on Dips</a></h3>
Netflix (NFLX) and Fortinet (FTNT), and both look like attractive buy-the-dip candidates if we see any further weakness<section class="post-meta zero-padding pad-bottom margin-top">
<a href>Jun 16, 2020</a> <span class=light-gray>|</span> 2:04pm</section></div></div><div class=clearfix></div></div><div class=margin-bottom><div class="pull-left no-mobile-pull pad-right">
<a href=/news/mgm-mlco-wynn-lvs-eri-5-casino-stocks-to-roll-the-dice-on/><noscript><img
class="img-rounded three-hundo" src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_551104375-scaled.jpg" alt="NYSE: MGM | MGM Resorts International  News, Ratings, and Charts"></noscript><img class="lazyload img-rounded three-hundo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/06/shutterstock_551104375-scaled.jpg" alt="NYSE: MGM | MGM Resorts International  News, Ratings, and Charts"></a></div><div class="overflow-fix margin-top-mobile"><div class="pad-left pad-top bb-2"><h3 class="bold zero-margins pad-bot pad-top">
<a href=/news/mgm-mlco-wynn-lvs-eri-5-casino-stocks-to-roll-the-dice-on/ class=black>5 Casino Stocks to Roll the Dice On</a></h3>
Las Vegas Sands Corp (LVS), Wynn Resorts (WYNN), MGM Resorts International (MGM), Melco Resorts (MLCO) and Eldorado Resorts (ERI) are worth keeping an eye on as gambling resumes<section class="post-meta zero-padding pad-bottom margin-top">
<a href>Jun 16, 2020</a> <span class=light-gray>|</span> 12:35pm</section></div></div><div class=clearfix></div></div><h3>
<a href=/top-stories/ class="btn btn-default width-full margin-top-less" role=button>Read More Stories</a></h3><div style=align:center><div id=StockNews_ROS_Bottom_Leaderboard></div></div></div></div><hr><div class="row margin-top"><div class=col-lg-12><h3>
More Aphria Inc. Common Shares (APHA) News
<a href=/stock/APHA/news/ class="btn btn-default" role=button>View All</a></h3><div class="panel panel-default"><table class="table-condensed table table-striped news mobile-card-view" id=news-stream><thead><tr><th>Event/Date</th><th>Symbol</th><th>News Detail</th><th class=text-right nowrap>Start Price</th><th class=text-right nowrap>End Price</th><th nowrap>Change</th><th>POWR Rating</th></tr></thead><tbody><tr><td colspan=10 class=text-center>Loading, please wait...</td></tr></tbody></table></div>
<a href=/stock/APHA/ class="btn btn-default width-full margin-top-less">View All APHA News</a></div></div></article></div> <script src=//ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js></script> <script src=//code.highcharts.com/stock/highstock.js></script> <script src=//code.highcharts.com/highcharts-more.js></script> <script src=//code.highcharts.com/stock/modules/exporting.js></script> <script>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</script> </div></div><footer id=footer class=clearfix><div class=container><hr><div id=footer-wrapper><div class="row margin-bottom"><div class=col-lg-6>
&copy;2020 StockNews.com</div><div class="col-lg-6 text-right">
<a href=/about/>About Us</a> | <a href=/contact/>Contact Us</a> | <a href=/legal/>Terms of Use</a></div></div><div class=row><div class=col-lg-6><p><small>Copyright &copy; 2020. Market data provided is at least 10-minutes delayed and hosted by <a href=https://www.barchart.com/solutions target=_blank>Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href=http://www.barchart.com/solutions/company/terms-and-privacy>disclaimer</a>.</small></p></div><div class=col-lg-6 <p><small>Automated Insights by <a href=https://sixjupiter.com target=_blank>SixJupiter</a>.
<br><br>
<em>This site is protected by reCAPTCHA and the Google <a href=https://policies.google.com/privacy rel=nofollow>Privacy Policy</a> and <a href=https://policies.google.com/terms rel=nofollow>Terms of Service</a> apply.</em></small></p></div></div></div></div></footer> <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='d1a293004a063000b79b40002eed8d007d2680005842eb00f4865000f034f400';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script>var ajaxurl = "https://stocknews.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }</script> <noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize=1>window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize=1 src='https://stocknews.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.6.1'></script><script>var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script src='https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_1534f06aa2b1b721a45372f8238e2461.js?ver=5.1.6'></script> <script src='https://www.google.com/recaptcha/api.js?render=6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc&#038;ver=3.0'></script> <script src='https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_82fb120c8ccd0ce427dd72c1e68c1430.js?ver=1.1.0'></script> <script src='https://stocknews.com/wp-content/cache/autoptimize/js/autoptimize_single_eaff9ed998e807ee389da27a2faa9bdb.js?ver=1.1.0'></script> <script>( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc',
	{"homepage":"homepage","contactform":"contactform"}
);</script> <div id=StockNews_PopUp_PopUp class=text-center> <script>apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });</script> </div></body></html>