<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-M36BQWD');</script>
    <!-- End Google Tag Manager -->

<!--Session Page view:  -->
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="google-site-verification" content="DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps" />

<title>RBLX: Is Roblox a Good Video Game Stock to Add to Your Portfolio?</title>
<!--| StockNews.com-->
<link rel="icon" type="image/png" href="" />
<link rel="amphtml" href="https://stocknews.com/single-snippet-page/amp/" /><meta name="generator" content="AMP for WP 1.0.68.1"/><link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
            <meta property="og:title" content="RBLX: Is Roblox a Good Video Game Stock to Add to Your Portfolio? | StockNews.com"/>
            <meta property="og:description" content="Online gaming platform provider Roblox’s (RBLX) shares have been galloping since its stock market debut on March 10, 2021. However, because children—who are its target audience—are expected to return to school soon, is it wise to bet on the stock now? Let’s find out."/>
            <meta property="og:type" content="article"/>
            <meta property="og:url" content="https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/"/>
            <meta property="og:site_name" content="StockNews.com"/>
            <meta property="og:image" content="https://stocknews.com/wp-content/uploads/2021/05/shutterstock_663218446-scaled.jpg"/>
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:title" content="RBLX: Is Roblox a Good Video Game Stock to Add to Your Portfolio? | StockNews.com">
            <meta name="description" content="Roblox Corporation(NYSE:RBLX): Online gaming platform provider Roblox’s (RBLX) shares have been galloping since its stock market debut on March 10, 2021. However, because children—who are its target audience—are expected to return to school soon, is it wise to bet on the stock now? Let’s find out."/>
            <meta name="keywords" content=":RBLX, Roblox Corp., Entertainment - Toys & Video Games, Commentary"/>
            <script type="application/ld+json">
{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/"
 },
 "headline": "Is Roblox a Good Video Game Stock to Add to Your Portfolio?",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2021/05/shutterstock_663218446-scaled.jpg" },
  "datePublished": "2021-05-27T10:44:51-04:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
 "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Roblox Corporation(NYSE:RBLX) Online gaming platform provider Roblox’s (RBLX) shares have been galloping since its stock market debut on March 10, 2021. However, because children—who are its target audience—are expected to return to school soon, is it wise to bet on the stock now? Let’s find out."
}
</script>
			        <link rel="canonical" href="https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/"/>
				<script type="lazyload_ext">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/stocknews.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://stocknews.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tboot_shortcode_styles-css'  href='https://stocknews.com/wp-content/plugins/bootstrap-sc-plugin/includes/css/tboot_shortcodes_styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://stocknews.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://stocknews.com/wp-content/themes/strappress/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-styles-css'  href='https://stocknews.com/wp-content/themes/strappress/css/layouts/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://stocknews.com/wp-content/themes/strappress/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css'  href='https://stocknews.com/wp-content/themes/strappress/css/magnific.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-style-css'  href='https://stocknews.com/wp-content/themes/strappress-child/style.css' type='text/css' media='all' />


<script src="https://stocknews.com/wp-content/themes/strappress/js/responsive-modernizr.js" ></script>


<link rel='https://api.w.org/' href='https://stocknews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.1.23" />    <script type="lazyload_ext">
    // <![CDATA[
    jQuery(document).ready(function($){
        $("a[rel='magnific']").magnificPopup({
                type:'image'
        });
    });  
    // ]]>
    </script>
		<style id="wp-custom-css">
			@media (max-width:1199px) and (min-width:992px) {
    .responsive_head_fix {
        margin-top: 65px;
    }
}

.mobileShow {
  display: none;
}

/* full width of parent */
.mobileShow img{
    width: 100%;
}

/* Smartphone Portrait and Landscape */
@media only screen and (min-device-width: 320px) and (max-device-width: 480px) {
  .mobileShow {
    /*position: fixed; bottom: 0;z-index: 111;display:block;left:10%;padding-bottom:12px;*/
    max-width:320px;
    width:90%;
    position: fixed;
    bottom:0;
    z-index:111;
    display:block;
    left:0;
    padding-bottom:12px;
    right:0;
    margin:0 auto;

  }
}
.close_btn::before
{
content: '✖';
  color: #000;
  font-weight: 600;
  font-family: Arial, sans-serif;
  float:right;
  opacity: 0.5;
  font-size:16px;
}		</style>
		


<!-- Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="https://stocknews.com/wp-content/themes/strappress/js/respond.min.js"></script>
<![endif]-->

<link rel="stylesheet" href="https://fonts.googleapis.com/css?display=swap&family=Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&display=swap">
<!--
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script>
    -->

    

    
 


    
<!--
<script src="//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script>
-->








<script type="lazyload_ext">
  jQuery(document).ready(function($){
    $('a.sn_pop').on('click', function(e) {e.preventDefault(); return true;});
      jQuery( ".ticker-search" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };


    $( ".ticker-search-big" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
  });
	jQuery(document).ready(function($){
		$('[data-toggle="popover"]').popover({html: true, trigger: 'focus'});
	});

</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','/wp-content/themes/strappress-child/js/analytics.js','ga');

  ga('create', 'UA-64545224-1', 'auto');
  ga('send', 'pageview');
</script>












<!-- google ads 072120 -->
    <script defer="defer" data-ad-client="ca-pub-6654551967172224" async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_int" ></script>












    <script async="" data-src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" type="lazyload_int" ></script>

    












           <script> window._F20 = window._F20 || [];
            !(function(e, f, u) {
                e.async = 1;
                e.src = u;
                f.parentNode.insertBefore(e, f);
            })(
                document.createElement('script'),
                document.getElementsByTagName('script')[0],
                'https://feed.exchange.entrepreneur.com/loader.js',
            );
            _F20.push({publisher: 'stocknews', css:'https://feed.exchange.entrepreneur.com/ecn.css'});
            var url = window.location != window.parent.location ? document.referrer : document.location.href;
            _F20.push({referer: url});
        </script>
    <script type="lazyload_ext">
        (function (d, s, b) {
            var mElmt, primisElmt = d.createElement('script');
            primisElmt.setAttribute('type', 'text/javascript');
            primisElmt.setAttribute('async','async');
            primisElmt.setAttribute('src',  s);
            var elmtInterval = setInterval(function() {
                mElmt = d.getElementById(b);
                if (mElmt) {
                    mElmt.parentNode.insertBefore(primisElmt, mElmt.nextSibling);
                    mElmt.parentNode.removeChild(mElmt);
                    return clearInterval(elmtInterval);
                }
            }, 1000);
        })(document, 'https://live.sekindo.com/live/liveView.php?s=107234', 'widgetLoaded');

        var $ = jQuery;
        $(window).scroll(function() {
            var $p_distanceFromTop = $(document).scrollTop();
            var $p_top_of_element = $("#primmrk").offset().top;

            if(($p_distanceFromTop+(window.visualViewport['height'])) < $p_top_of_element){
                $("#primisPlayerContainerDiv").hide()
            } else{$("#primisPlayerContainerDiv").show()}

        })

    </script>
   <script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/stocknews.com/articles', [[970,250],[728,90]], 'stocknews-com-articles-top-banner').setTargeting('pos', ['top']).addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });


  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
      googletag.defineSlot('/21771534901/stocknews.com//articles', [[970,250],[728,90]], 'stocknews-com-articles-twelfth-banner').setTargeting('pos', ['art-mid']).addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

window.googletag = window.googletag || {cmd: []};
      googletag.cmd.push(function() {
          googletag.defineSlot('/21771534901/stocknews.com/articles', [300,250], 'stocknews-com-articles-top-banner-mobile').addService(googletag.pubads());
          googletag.pubads().enableSingleRequest();
          googletag.enableServices();
      });

  
</script>


<script>
	var gptadslots = [];
  var googletag = googletag || {cmd:[]};
  googletag.cmd.push(function() {
  var REFRESH_KEY = 'refresh';
  var REFRESH_VALUE = 'true';
  // This slot is allowed to refresh, as it contains the targeting keys which have
  // been declared for refresh.
  googletag.defineSlot('/21771534901/stocknews.com//articles',[[300,600],[300,250]], 'stocknews-com-articles-right-sticky').
    setTargeting(REFRESH_KEY, REFRESH_VALUE).
    setTargeting('pos', ['mid']).
    addService(googletag.pubads());
  // Number of seconds to wait after the slot becomes viewable.
  var SECONDS_TO_WAIT_AFTER_VIEWABILITY = 30;
  googletag.pubads().addEventListener('impressionViewable', function(event) {
    var slot = event.slot;
    if (slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE) > -1) {
      setTimeout(function() {
        googletag.pubads().refresh([slot]);
      }, SECONDS_TO_WAIT_AFTER_VIEWABILITY * 1000);
    }
  });
    googletag.enableServices();
  });
</script>




 <script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/stocknews.com//articles', [[970,250],[728,90]], 'stocknews-com-articles-bottom').setTargeting('pos', ['bot']).addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  </script>




	 


   






</head>

<body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M36BQWD"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->






        <header>

    

<div style="background:#333;"  class="headerstick">
<div class="container">
<div id="logo" class="hidden-sm hidden-xs" style="height: 40px;width: 360px;"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
    <img src="/img/sn-green.png" alt="StockNews.com" style="width:360px;height:auto" width="360px" height="40px"/>
</a></div>


<nav class="navbar-collapse collapse navbar-responsive-collapse">

<ul class="nav navbar-bav navbar-right">
    <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
  </ul>

<form class="navbar-form navbar-right" role="search" method="post" id="searchform" action="https://stocknews.com/">
  <div class="input-group">
    <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
    <div class="input-group-btn">
      <button type="submit" class="btn btn-success">Search</button>
    </div>
  </div>
  <input type="hidden" id="symbol_search" name="symbol_search" value="11766eaf41" /><input type="hidden" name="_wp_http_referer" value="/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/" /></form>

</nav>

<nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0">
  <div class="container-fluid">

    <div class="navbar-header">
      <div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
        <img src="/img/sn-green.png" style="width:220px;height:auto" width="220px" height="24px" alt="StockNews.com" />
    </a></div>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-bars" style="color:#fff !important;"></span>
      </button>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-search" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-search" style="color: #fff !important;"></span>
      </button>
    </div>

    <div class="collapse navbar-collapse" id="navbar">
                        <ul id="menu-top-nav" class="nav navbar-nav">
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    News<span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/top-stories/">
                                            Top Stories
                                        </a>
                                    </li>

                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/video-news/">
                                            Video News
                                        </a>
                                    </li>

                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://pr.stocknews.com">
                                            Press Releases
                                        </a>
                                    </li>
                                    <!--<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/featured-articles/">
										Featured Articles
									  </a>
									</li>-->
                                </ul>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Best Stocks<span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/best-stocks/">
                                            "A" Rated Stocks
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/powr-upgrades-downgrades/">
                                            Upgrades/Downgrades
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/high-yield-dividend-stocks/">
                                            High Yield Dividend Stocks
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/stock-screener/">
                                            Stock Screener
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="/top-stocks-price-target/">
                      Top Stocks by Target Price
                  </a>
              </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/top-dividend-discount-model/">
                                            Dividend Discount Model Stock Valuation
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/stocks/">
                                            Industry Rank
                                        </a>
                                    </li>
                                    <!--  <li class="divider"></li>
									  <li class="menu-item menu-item-type-custom menu-item-object-custom">
										<a href="/powr-ratings/">
										  POWR Ratings&trade;
										</a>
									  </li> -->

                                </ul>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Best ETFs <span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/best-etfs/">
                                            "A" Rated ETFs
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/etfs/">
                                            Best ETF Categories
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/high-yield-etfs/">
                                            High Yield ETFs
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://report.stocknews.com/7-best-etfs-for-the-next-bull-market/?lead_source=sn-best_etfs_menu&medium=spons-txt&campaign=7etfs&Pagesource=StockNews">
                                            7 Best ETFs
                                        </a>
                                    </li>
                                </ul>
        </li>
          <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a  aria-expanded="false" href="/powr-ratings/">
                  POWR Ratings
              </a>

                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/powr-upgrades-downgrades/">
                                    Upgrades/Downgrades<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
                                </a>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/watchlist/">
                                    Watchlist<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
                                </a>
                            </li>

                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/stock-screener/">
                                    Screener
                                </a>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Services <span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com" target="_blank">
                                            Services Home
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com/reitmeister-total-return/" target="_blank">
                                            Reitmeister Total Return
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com/powr-charts/" target="_blank">
                                            POWR Charts
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com/powr-growth/" target="_blank">
                                            POWR Growth
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com/powr-value/" target="_blank">
                                            POWR Value
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com/service/powr-trends/" target="_blank">
                                            POWR Trends
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://stocknews.com/powr-ratings/" target="_blank">
                                            Premium
                                        </a>
                                    </li>

                                </ul>


                                <!--
								<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
								  <a href="/screeners/" class="dropdown-toggle" data-toggle="dropdown" aria-expanded="false">
									Screeners <span class="caret"></span>
								  </a>
								  <ul class="dropdown-menu">
									<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/stock-screener/">
										Stock Screener
									  </a>
									</li>
									<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/etf-screener/">
										ETF Screener
									  </a>
									</li>
								  </ul>
								</li>
								-->
                        </ul>
                        <ul class="nav navbar-nav hidden-lg hidden-md">
							                                <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
                                            Join
                                        </a>
                                    </p>
                                </li>
							                        </ul>
                    </div>
    <div class="collapse navbar-collapse" id="navbar-search"> <form class="navbar-form hidden-lg hidden-md" role="search" method="post" id="searchform2" action="https://stocknews.com/">
          <div class="input-group">
            <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
            <div class="input-group-btn">
              <button type="submit" class="btn btn-success">Search</button>
            </div>
          </div>
         <input type="hidden" id="symbol_search" name="symbol_search" value="11766eaf41" /><input type="hidden" name="_wp_http_referer" value="/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/" />      </form></div>
  </div>
</nav>
</div>
</div>






</header><!-- end of header -->


<br><br><br><br>
  <!--  <div class="text-center center-block" style="background-color:#f0f0f0; padding-bottom:5px; min-height:130px; text-align:center !important; padding-top:110px;"> -->
 <!-- <div id="StockNews_ROS_Top_Leaderboard" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Top_Leaderboard');
    });
    </script>
</div>
</div> -->




<div class="container">
  <div class="clearfix wrapper ">

    
<div id="content">
    <article style="position:relative;">

            
           <div id='right-outer-sticky' style='position: absolute;top: 1600px;
    left: 85%;'>


<div class="right-margin-ad1" style='position:sticky;top:12%;'><div id='stocknews-com-articles-right-sticky'></div><div class="margin-top">
        <div class="top-stories-sidebar" id="top-stories-sidebar">
    <h3 style="padding-left: 15px;">Most Popular Stories
    </h3>

                    <h4 class="feature-sub bold top-stories-homepage"><a href="/news/spy-inx-dia-iwm-qqq-am-i-wrong-about-stock-market-correction/" class="blue">&bull; Am I Wrong About a Stock Market Correction?</a></h4>
                                    <h4 class="feature-sub bold top-stories-homepage"><a href="/news/pltr-dkng-spce-3-popular-reddit-stocks-to-liquidate-before-another-market-selloff/" class="blue">&bull; 3 Popular Reddit Stocks to Liquidate Before Another Market Selloff</a></h4>
                                                <h4 class="feature-sub bold top-stories-homepage"><a href="/news/spy-inx-dia-iwm-qqq-do-calmer-waters-lie-ahead-for-the-markets/" class="blue">&bull; Do Calmer Waters Lie Ahead for the Stock Market?</a></h4>
                                                            <h4 class="feature-sub bold top-stories-homepage"><a href="/news/spy-inx-dia-iwm-qqq-3-signs-of-a-new-stock-market-bubble/" class="blue">&bull; 3 Signs of a NEW Stock Market Bubble</a></h4>
                                                                        <h4 class="feature-sub bold top-stories-homepage"><a href="/news/gevo-wait-for-lower-prices-then-add-gevo-to-your-sustainability-focused/" class="blue">&bull; Wait for Lower Prices, Then Add Gevo to Your Sustainability-Focused Holdings</a></h4>
                                                 <a href="/top-stories/" class="btn btn-default">View All Top Stories</a>
    </div>

</div></div></div>                <script>
                    window._F20 = window._F20 || [];
                    _F20.push({container: 'F20WidgetContainer', placement: '', count: 3});
                    _F20.push({finish: true});
                </script>

                    <header class="news-header">

			
			            <div class="row margin-top">
                <div class="col-lg-0 col-md-2"></div>
                <div class="col-lg-8 col-md-8">


                    <div class="news-event first-news-event">

						                        <h1 class="page-title no-pad-left big-margin-bottom bold">
							Is Roblox a Good Video Game Stock to Add to Your Portfolio?</h1>
						                            <h1 class="page-title no-pad-left big-margin-bottom bold">
								                            </h1>
                            <div class="text-center">
                                <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div> -->
                            </div>
						
						
                        <div class="row margin-top">
                            <div class="col-lg-12 text-center">
                                <!--   <div id="StockNews_ROS_Textlink" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Textlink');
    });
    </script>
</div>
 -->
                            </div>
                        </div>

                        <div><div class="panel-body" style="padding: 0px !important;">
																                                <div class="row">
                                    <div class="col-lg-12" style="max-height:550px; overflow:hidden;min-height:540px;">
                                        <img src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2021/05/shutterstock_663218446-scaled.jpg" alt=": RBLX | Roblox Corp. News, Ratings, and Charts" class="no-lazy" style="height:100%; width:100%; object-fit: cover; margin:auto; display:block; max-height: 550px;min-height:540px;" width="550px" height="367px">
                                    </div>

                                    <div class="col-lg-12 col-md-8">
										<p><strong><a href="/stock/RBLX/">RBLX</a></strong> &#8211; Online gaming platform provider Roblox’s (RBLX) shares have been galloping since its stock market debut on March 10, 2021. However, because children—who are its target audience—are expected to return to school soon, is it wise to bet on the stock now? Let’s find out.</p>
										

										                                    </div>
                                </div>
							                                <div class="row no-margin-top">
                                    <div class="col-lg-12">

                                        <section class="post-meta zero-padding pad-bottom">
											<img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="https://stocknews.com/wp-content/uploads/2020/10/Manisha-Chatterjee-1-scaled-200x200.jpeg" width="70" height="70" alt="Manisha Chatterjee" class="avatar avatar-70 wp-user-avatar wp-user-avatar-70 alignnone photo" /><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=manisha-chatterjee">By Manisha Chatterjee</a></strong></span><br>											<p style="font-size: 13px; font-weight: 700; color: #777; font-style: normal; display: inline-block;">May 27, 2021</a>											                                            <div style="float:right;">                                    <div class="social-wrapper no-margin-bottom no-margin-top">
              <!-- Twitter -->
              <a href="https://twitter.com/intent/tweet?text=%24RBLX+Is+Roblox+a+Good+Video+Game+Stock+to+Add+to+Your+Portfolio%3F&amp;url=https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target="_blank"><i class="fa fa-twitter"></i></a>
              <!-- Facebook -->
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/" title="Share on Facebook" target="_blank" class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a>
              <!-- Google+ 
              <a href="https://plus.google.com/share?url=https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/" title="Share on Google+" target="_blank" class="sn-social-share btn btn-googleplus"><i class="fa fa-google-plus"></i></a> -->
              <!-- LinkedIn -->
              <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/rblx-is-roblox-a-good-video-game-stock-to-add-to/&title=Is+Roblox+a+Good+Video+Game+Stock+to+Add+to+Your+Portfolio%3F&summary=" title="Share on LinkedIn" target="_blank" class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a>
            </div>
            <script type="lazyload">
              jQuery(document).ready(function($){
                jQuery("a.sn-social-share").click(function() {
                  window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');
                  return false;
                });
              });
            </script></div><br>

                                        </section>

                                    </div>
                                </div></div></div></div></div>
                <div class="col-lg-0 col-md-2"></div>
            </div>
        </header>
        <div class="row">
            <div class="col-lg-12">
                <div style="margin: auto; width: fit-content;">

					                        <div class="text-center" id="stocknews-com-articles-top-banner" style="display:inline;">

                            <script>
                                googletag.cmd.push(function() { googletag.display('stocknews-com-articles-top-banner'); });
                            </script>
                        </div>

					                </div>
            </div>
        </div>
    </article>
        <div class="row margin-top">
            <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-8">
                <div class="news-event">

															                </div>




				<div class="post_content" id="articlecontent" style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>Roblox Corporation (<a href="https://stocknews.com/stock/RBLX/">RBLX</a>) develops and operates an online entertainment platform that leverages its various offerings, such as Roblox Client and Roblox Studio, which have 3D features, and Roblox Cloud, among others. Because children spent more time over the last year playing online games in the absence of physical school classes amid the COVID-19 pandemic, RBLX’s revenue grew significantly for the quarter ended March 31, 2021.</p>
<p>The stock has advanced by 19.8% over the past month to close yesterday’s trading session at $89.71, after hitting its all-time high of $95.</p>
<p>But RBLX has so far not been very successful in its efforts to expand its market reach beyond children. Furthermore, as the economy gradually reopens, children are expected to resume in-school classes and are unlikely to spend as much time on online games as they did at home during the pandemic. So, even though the company had an impressive market debut on March 10, 2021, we think its near-term prospects look uncertain.</p>
<p><a href="https://stocknews.com/news/ea-atvi-grvy-video-game-industry-in-2021-the-complete-investors-guide/"><strong><em>Click here to check out our Video Game Industry Report for 2021</em></strong></a></p>
<p>Here are the factors that we think could influence RBLX’s performance in the coming months:</p>
<p><strong>Impressive Market Debut</strong></p>
<div><div id='primmrk' style="height:300px;"> <p id="widgetLoaded" style="width:0px;height:0px;"></p></div></div><p>RBLX made its market debut on March 10, 2021 via a<a href="https://www.investopedia.com/terms/d/directpublicoffering.asp"> direct listing,</a> thus allowing its existing shareholders to sell immediately without being subject to a lockup period. On the day of listing, its shares<a href="https://edition.cnn.com/2021/03/10/investing/roblox-stock-direct-listing/index.html"> surged nearly 55% to $69.50</a>, valuing the company at more than $45 billion. It now has a market capitalization of $51.12 billion. RBLX is unique because it doesn’t make the content for its platform itself  but is reliant on a growing community of more than eight million content creators and developers.</p>
<p><strong>Mixed Financials</strong></p>
<p>RBLX’s revenue for its fiscal first quarter ended March 31 came in at $386.98 million, which represents a 139.5% year-over-year rise. Its bookings for the quarter increased 161% year-over-year to $652.30 million and its average daily active users (DAUs) increased 79% year-over-year to 42.10 million.</p>
<p>However, the company’s loss from operations increased more than 85% year-over-year to $135.06 million in the quarter. Its net loss increased 80.5% year-over-year to $134.22 million. And its  loss per share for the quarter was $0.46 compared to $0.44 in the prior-year period.</p>
<p><strong>Stretched Valuation</strong></p>
<p>In terms of forward non-GAAP P/E ratio, RBLX’s 107.87x is 433.7% higher than the 20.21x industry average. Its 19.89x forward EV/S is 612.9% higher than the 2.79x industry average. Also, the stock’s 20.46x and 81.51x respective forward P/S and forward EV/EBITDA are higher than the 2.25x and 10.56x industry averages.</p>
<div><div id ="stocknews-com-articles-twelfth-banner" ></div></div><p><strong>POWR Ratings Reflect Uncertainty</strong></p>
<p>RBLX has an overall C rating, which equates to Neutral in our<a href="https://stocknews.com/powr-ratings/"> POWR Ratings</a> system. The POWR Ratings are calculated by considering 118 different factors, with each factor weighted to an optimal degree.</p>
<p>Our proprietary rating system also evaluates each stock based on eight different categories. RBLX has a C grade for Growth, which is justified given that its revenue and EPS are expected to grow in the near- to mid-term, but at a moderate rate. Its annual revenue is expected to increase 19.3% year-over-year to $3.12 billion in its fiscal year 2022, while its EPS is expected to grow 2.5% year-over-year to $0.81.</p>
<p>It has a D grade for Value, which is in sync with its higher-than-industry valuation ratios. The stock has a D grade for Stability as well.</p>
<p>Of 23 stocks in the C-rated<a href="https://stocknews.com/category/entertainment-video-games/"> Entertainment – Toys & Video Games</a> industry, RBLX is ranked #16. In addition to the POWR Ratings grades we’ve just highlighted, we’ve also rated it for Momentum, Quality and Sentiment. Get all RBLX’s ratings<a href="https://stocknews.com/stock/RBLX/"> here</a>.</p>
<p>Better than RBLX:<a href="https://stocknews.com/category/entertainment-video-games/"> Click here to access five top-rated stocks</a> in the Entertainment – Toys & Video Games industry.</p>
<p><strong>Bottom Line</strong></p>
<p>RBLX looks significantly overvalued now because the pandemic-driven surge in demand for its online games is expected to decline in the near term with children going back to school. So, we think it’s wise to wait for better entry points in the stock.</p>
<p><a href="https://stocknews.com/news/ea-atvi-grvy-video-game-industry-in-2021-the-complete-investors-guide/"><strong><em>Click here to check out our Video Game Industry Report for 2021</em></strong></a></p>
<div class="p_content2"><p><b><i>Want More Great Investing Ideas?</i></b></p><p><a href="https://report.stocknews.com/9-must-have-stocks/?formplacement=artbottom9g"><span style="font-weight: 400;">9 "Must Own" Growth Stocks for 2021</span></a></p><p><a href="https://stocknews.com/news/spy-inx-dia-iwm-qqq-top-10-value-stocks/"><span style="font-weight: 400;">Top 10 Value Stocks</span></a></p><p><a href="https://report.stocknews.com/5-winning/?formplacement=artbottom5w"><span style="font-weight: 400;">5 WINNING Stocks Chart Patterns</span></a></p><p><a href="https://stocknews.com/news/spy-inx-dia-iwm-qqq-3-signs-of-a-new-stock-market-bubble/"><span style="font-weight: 400;">3 Signs of a NEW Stock Market Bubble</span></a></p></div>
<hr><p>RBLX shares were trading at $92.15 per share on Thursday morning, up $2.44 (+2.72%). Year-to-date, RBLX has gained 32.59%, versus a 12.79% rise in the benchmark S&P 500 index during the same period.</p><script>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</script></body></html>
<div id="mnet_articles_Desktop"></div>
							<div style="clear:both;"></div><br><h2>About the Author: Manisha Chatterjee</h2><br><img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src='https://stocknews.com/wp-content/uploads/2020/10/Manisha-Chatterjee-1-scaled.jpeg' style="float:left; padding:5px;width:125px;"  width="125px"  height="83px"><p>Since she was young, Manisha has had a strong interest in the stock market.   <a href="https://www.linkedin.com/in/manisha-chatterjee-543aa8151/"> She majored in Economics in college</a> and has a passion for writing, which has led to her career as a research analyst. <a href="https://stocknews.com/authors/?author=manisha-chatterjee">More...</a></p><br><div style="clear:both;"></div><h2>More Resources for the Stocks in this Article</h2>
<table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;" >
<tr style="background-color:#5cb85c; color:white;">
    <td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/RBLX/">RBLX</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr></table></div></div>                <div align="center" class="margin-top"></div>
            </div>
            <div class="col-lg-2 col-md-2"></div><!-- end of column -->





        </div>
        <!--   <div style="width:100%; padding:5px;">
    



    <div id="mnet_articles_Desktop" class="text-center">

    </div>
      </div>-->




        <div class="row margin-top">
            <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-10">
                <div id="ent-wid"> <div id="F20WidgetContainer"></div>

                    </div>
                <h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Most Popular Stories on StockNews.com</strong></h2>
				





			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-am-i-wrong-about-stock-market-correction/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2021/05/shutterstock_151258910-scaled.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="257px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-am-i-wrong-about-stock-market-correction/" class="black">Am I Wrong About a Stock Market Correction?</a>
				  				</h3>
				For the past couple weeks I have been stating that it is not yet time to buy the dip. And yet the S&P 500 (SPY) just keeps climbing back towards 4,200 and seems hungry for more. Am I wrong? Or am I early? That will be the focus of today’s conversation. Read on below to find out more…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">May 26, 2021</a> <span class="light-gray">|</span> 12:39pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>





						<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/pltr-dkng-spce-3-popular-reddit-stocks-to-liquidate-before-another-market-selloff/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2021/04/shutterstock_309326384-scaled.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="240px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/pltr-dkng-spce-3-popular-reddit-stocks-to-liquidate-before-another-market-selloff/" class="black">3 Popular Reddit Stocks to Liquidate Before Another Market Selloff</a>
				  				</h3>
				The stock market is expected to remain under pressure in the near term on concerns over rising inflation. Since the wallstreetbets’ short squeeze saga has now abated considerably, analysts believe three of the most heavily discussed Reddit stocks—Palantir Technologies (PLTR), DraftKings (DKNG), and Virgin Galactic (SPCE)—will witness massive corrections in the near term. So, we think it’s wise to liquidate one’s investments in them as quickly as possible. Let’s take a closer look.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">May 24, 2021</a> <span class="light-gray">|</span> 10:43am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>











			  <div style="width:100%; padding:5px;">
    



    <div id="mnet_Desktop" class="text-center">

    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-do-calmer-waters-lie-ahead-for-the-markets/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2021/05/vrts.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="221px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-do-calmer-waters-lie-ahead-for-the-markets/" class="black">Do Calmer Waters Lie Ahead for the Stock Market?</a>
				  				</h3>
				As a former competitive swimmer, I can definitely say I preferred swimming in a calm pool rather than a choppy sea, which parallels investing. Most of us would prefer a relatively calm market to the choppiness that we have seen with the S&P 500 (SPY) over the past couple of weeks. But we deal with the cards that are dealt to us. We continue to see volatility in the markets as last week started the same as the previous week, with three straight days of losses, only to rebound on Thursday. Value investors continue to worry about the Fed increasing rates, while growth investors fear inflation and an increase in bond yields. The key to investing in volatile periods is to stay the course and not panic. So, in today's commentary, I will highlight the market over the past week and what I expect this week. Read on below to find out more…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">May 25, 2021</a> <span class="light-gray">|</span> 1:56pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>









			  <div style="width:100%; padding:5px;">
    



    <div id="mnet_Desktop" class="text-center">

    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-3-signs-of-a-new-stock-market-bubble/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2019/09/balloon.jpg" alt=":  |  News, Ratings, and Charts" width="300px"  height="225px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-3-signs-of-a-new-stock-market-bubble/" class="black">3 Signs of a NEW Stock Market Bubble</a>
				  				</h3>
				Value investors are pounding the table that the stock market (SPY) is already in bubble territory not unlike 1999. Indeed they are right about the lofty valuation levels. But they are wrong that it’s time to get ready for the next bear market to emerge. Check out Steve Reitmeister's game plan to ride the bubble up and then parachute out at the right time. Read on for more...				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">May 14, 2021</a> <span class="light-gray">|</span> 3:59pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>







			  <div style="width:100%; padding:5px;">
    



    <div id="mnet_Desktop" class="text-center">

    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-do-calmer-waters-lie-ahead-for-the-markets/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2021/05/vrts.jpg" alt=":  |  News, Ratings, and Charts" width="300px"  height="221px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-do-calmer-waters-lie-ahead-for-the-markets/" class="black">Do Calmer Waters Lie Ahead for the Stock Market?</a>
				  				</h3>
				As a former competitive swimmer, I can definitely say I preferred swimming in a calm pool rather than a choppy sea, which parallels investing. Most of us would prefer a relatively calm market to the choppiness that we have seen with the S&P 500 (SPY) over the past couple of weeks. But we deal with the cards that are dealt to us. We continue to see volatility in the markets as last week started the same as the previous week, with three straight days of losses, only to rebound on Thursday. Value investors continue to worry about the Fed increasing rates, while growth investors fear inflation and an increase in bond yields. The key to investing in volatile periods is to stay the course and not panic. So, in today's commentary, I will highlight the market over the past week and what I expect this week. Read on below to find out more…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">May 25, 2021</a> <span class="light-gray">|</span> 1:56pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>

  <div style="width:100%; padding:5px;">
    



    <div id="mnet_Desktop" class="text-center">

    </div>
      </div>

                <h3>
                    <a href="/top-stories/" class="btn btn-default width-full margin-top-less" role="button">Read More Stories</a>
                </h3>
                <div align="center"><script async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_int" ></script>
                    <!-- Bottom Article Banner Ad (4) -->
                    <ins class="adsbygoogle"
                         style="display:block"
                         data-ad-client="ca-pub-6654551967172224"
                         data-ad-slot="1071597498"
                         data-ad-format="auto"
                         data-full-width-responsive="true"></ins>
                    <script>
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    </script></div>

            </div>
        </div>



        <div class="row margin-top">
	        <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-10"><div class="col-lg-12">
                <h3>
                    More Roblox Corp. (RBLX) News
                    <a href="/stock/RBLX/news/" class="btn btn-default" role="button">View All</a>
                </h3>
                <div class="panel panel-default">
                    <table class="table-condensed table table-striped news mobile-card-view" id="news-stream">
                        <thead>
                        <tr>
                            <th>Event/Date</th>
                            <th>Symbol</th>
                            <th>News Detail</th>
                            <th class="text-right" nowrap>Start Price</th>
                            <th class="text-right" nowrap>End Price</th>
                            <th nowrap>Change</th>
                            <th>POWR Rating</th>
                        </tr>
                        </thead>
                        <tbody>
                        <tr><td colspan="10" class="text-center">Loading, please wait...</td></tr>
                        </tbody>
                    </table>
                </div>
                <a href="/stock/RBLX/" class="btn btn-default width-full margin-top-less">View All RBLX News</a>
            </div></div>
        </div><!-- end of row -->


</div>



<div align="center">

	<div id='stocknews-com-articles-bottom'>
  <script>
    googletag.cmd.push(function() { googletag.display('stocknews-com-articles-bottom'); });
  </script>
</div>


</div>

<style>
    .mobileShow {
        display: none;
    }

    /* full width of parent */
    .mobileShow img{
        width: 100%;
    }

    /* Smartphone Portrait and Landscape */
    @media only screen and (min-device-width: 320px) and (max-device-width: 480px) {
        .mobileShow {
            /*position: fixed; bottom: 0;z-index: 111;display:block;left:10%;padding-bottom:12px;*/
            max-width:320px;
            width:90%;
            position: fixed;
            bottom:0;
            z-index:111;
            display:block;
            left:0;
            padding-bottom:12px;
            right:0;
            margin:0 auto;

        }
    }
    .close_btn::before
    {
        content: '✖';
        color: #000;
        font-weight: 600;
        font-family: Arial, sans-serif;
        float:right;
        opacity: 0.5;
        font-size:10px;
    }
</style>




<!-- end of content -->



<script type="lazyload">
    jQuery(document).ready(function($){
        function symbol_get_snippets(symbol) {
            $.getJSON('https://stocknews.com/wp-content/themes/strappress-child/includes/snippet-json.php?symbol=RBLX&limit=10&historical_prices=1',
                function (json) {
                    $("table#news-stream tbody").html("");
                    var tr=[];
                    for (var i = 0; i < json.results.length; i++) {
                        if ((json.results[i].top_story_headline != "") && (json.results[i].top_story_headline != null)) {
                            var headline = json.results[i].top_story_headline;
                        } else {
                            var headline = json.results[i].notes;
                        }
                        tr.push('<tr>');
                        tr.push('<td class="bullorbear-' + json.results[i].bull_or_bear + 'a"><strong>' + json.results[i].event_short + '</strong><br><span class="medium-gray">' + json.results[i].snippet_time + '</span></div>');
                        tr.push('<td><strong><a href="/stock/' + json.results[i].symbol + '/">' +  json.results[i].symbol + '</strong></td>');
                        //tr.push('<td><a href="/stock/' + json.results[i].symbol + '/">' + json.results[i].company + '</a></td>');
                        tr.push('<td><span class="dark-gray"><a href="https://stocknews.com/news/' + json.results[i].post_slug + '">' + headline + '</a></span></td>');
                        tr.push('<td class="text-right">' + json.results[i].price_when_added + '</td>');
                        tr.push('<td class="text-right grade-' + json.results[i].day_change_color + '">' + json.results[i].day_close + '</td>');
                        tr.push('<td class="grade-' + json.results[i].day_change_color + '">' + json.results[i].day_change + '<br>' + json.results[i].day_pct_change + '</td>');
                        //tr.push('<td class="grade-' + json.results[i].ttm_color + '">' + json.results[i].ttm_pct_change_formatted + '</td>');
                        tr.push('<td class="text-center grade-' + json.results[i].powr_grade_color + '"><strong>' + json.results[i].powr_grade + '</strong></td>');
						                        tr.push('</tr>');
                    }
                    $(tr.join('')).appendTo($('table#news-stream tbody')).slideDown("slow");
                });
        }
        symbol_get_snippets('RBLX');
    });

    //Make all extrnal links target '_blank'
    jQuery(function($) {

        $('.post_content').find('a[href^="http"]').not('a[href*=stocknews]').attr('target','_blank');
    });

    //Change Stock Tickers to Get Rating Links

    let tickerPos, ratingReplace = "";

    let stockData = {"replace_stocks":[{"stock":"RBLX"}]};

	
    for (tickerPos in stockData.replace_stocks) {
        ratingReplace = '(<strong><a href="https://stocknews.com/stock/' + stockData.replace_stocks[tickerPos].stock + '">' + stockData.replace_stocks[tickerPos].stock + '</a></strong> - <a href="https://stocknews.com/registration/free/?tag_id=3269" style="color:green; font-style:italic;">Get Rating</a>)'
        replaceTickers(tickerPos);
    }
	
    function replaceTickers(tickerPos) {
        let stockTicker = stockData.replace_stocks[tickerPos].stock;
        let regexTicker = new RegExp('\\(([^)]+)(\\b'+ stockTicker +'\\b)([^)]+)\\)', 'g')
        let str = document.getElementById("articlecontent").innerHTML;
        let res = str.replace(regexTicker, ratingReplace);
        document.getElementById("articlecontent").innerHTML = res;
    }
</script>


        

</div><!-- end of wrapper-->


</div><!-- end of container -->

<footer id="footer" class="clearfix">
  <div class="container">
    <hr>
    <div id="footer-wrapper">
      <div class="row margin-bottom">
        <div class="col-lg-6">
          ©2021 StockNews.com                </div><!-- end column -->
                          <div class="col-lg-6 text-right">
                <a href="/about/">About Us</a> | <a href="/contact/">Contact Us</a> | <a href="/legal#performance">Performance</a>
                |<a href="/privacy/">Privacy Policy</a> | <a href="/legal/">Terms of Use</a>
            </div>
              </div><!-- end row -->
            <div class="row">
        <div class="col-lg-6">
          <p><small>Copyright © 2021. Market data provided is at least 10-minutes delayed and hosted by <a href="https://www.barchart.com/solutions" target="_blank">Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href="http://www.barchart.com/solutions/company/terms-and-privacy">disclaimer</a>.</small></p>
        </div>
        <div class="col-lg-6"
          <p><small>Automated Insights by <a href="https://sixjupiter.com"  target="_blank">SixJupiter</a>.
          <br><br>
          <em>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" rel="nofollow">Privacy Policy</a> and <a href="https://policies.google.com/terms" rel="nofollow">Terms of Service</a> apply.</em></small>
          </p>
        </div>
      </div>
          </div><!-- end #footer-wrapper -->
  </div> <!-- end container -->
</footer><!-- end #footer -->


<script type="lazyload_ext"async="">(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='d1a293004a063000b79b40002eed8d007d2680005842eb00f4865000f034f400';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>    <script type="lazyload">
      var ajaxurl = "https://stocknews.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
    <script>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type="lazyload_int" data-src="https://stocknews.com/wp-content/cache/wnw-cache/all-js/3edcb789e5ecdbceca80b43464b72b8e.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js?render=6LcSLq8UAAAAADO3HTWuB2LvCuMip3r9ZcPMAZF9" type="lazyload_ext" ></script>
<script>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcSLq8UAAAAADO3HTWuB2LvCuMip3r9ZcPMAZF9","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>





<!-- AST – IMS - [StockNews_PopUp] -->
<div id="StockNews_PopUp_PopUp" class="text-center">
  <!--<script>
  apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });
  </script>-->
</div>
<!-- End AST – IMS - [StockNews_PopUp] -->


<!-- Push Monkey code  -->

<!-- dfp script-->
<script type="lazyload_ext"defer="defer"data-cfasync="false"> (function() { window.advBidxc = window.advBidxc || {}; window.advBidxc.startTime = new Date().getTime(); function loadScript(tagSrc) { var scriptTag = document.createElement('script'), placeTag = document.getElementsByTagName("script")[0]; scriptTag.type = 'text/javascript'; scriptTag.async = true; scriptTag.src = tagSrc; placeTag.parentNode.insertBefore(scriptTag, placeTag); } var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' + window.location.hostname; loadScript(mnSrc); })(); </script>
<!-- dfp script -->

<!-- sn media net script -->

<script type="lazyload_ext">
 (function () {
  window.advBidxc = window.advBidxc || {};
  window.advBidxc.customerId = "8CUJ1CM79";
  window.advBidxc.domain = window.location.hostname;
  window.advBidxc.version = 5.1;
  window.advBidxc.startTime = new Date().getTime();

  function loadScript(tagSrc) {
    var scriptTag = document.createElement('script'),
      placeTag = document.getElementsByTagName("script")[0];
    scriptTag.type = 'text/javascript';
    scriptTag.async = true;
    scriptTag.src = tagSrc;
    placeTag.parentNode.insertBefore(scriptTag, placeTag);
  }
  var mnSrc = 'https://hbx.media.net/bidexchange.js?cid=' + window.advBidxc.customerId + "&version=" + window.advBidxc.version + '&dn=' + window.advBidxc.domain;
  loadScript(mnSrc);
})();
</script>

<!-- sn media net script -->

<!-- pardot script -->
<script type="lazyload_ext">
piAId = '890453';
piCId = '1072';
piHostname = 'pi.pardot.com';

(function() {
	function async_load(){
		var s = document.createElement('script'); s.type = 'text/javascript';
		s.src = ('https:' == document.location.protocol ? 'https://pi' : 'http://cdn') + '.pardot.com/pd.js';
		var c = document.getElementsByTagName('script')[0]; c.parentNode.insertBefore(s, c);
	}
	if(window.attachEvent) { window.attachEvent('onload', async_load); }
	else { window.addEventListener('load', async_load, false); }
})();
</script>

<span></span>

<!-- pardot script -->
<div class="mobileShow" id="mobileShow">
	<span class="close_btn" onclick="document.getElementById('mobileShow').style.display='none'"></span>
<div id='stocknews-com-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('stocknews-com-mobile-sticky'); });
  </script>
</div>
</div>
<script type="lazyload">
    var $ = jQuery;
    $(function(){
        $globFAllow = false;
        $('form[class=infusion-form]').on('submit', function(e){


                console.log(e)
                if($globFAllow){}else{ e.preventDefault();}

                $email = $(this).find("input[type='email']").val();

                if($email == undefined){
                    $email = $(this).find("#email").val();
                }

                $form = $(this)
                var xhr = new XMLHttpRequest();
                xhr.onload = function() {

                        $tst = JSON.parse(this.responseText)[0];
                        console.log(this.responseText);
                        if($tst == 'true')
                        {
                            $globFAllow = true;

                            $success_str = $form.find("#success_location").val()
                                $sstr_pos = "https://stocknews.com/cr/thanks/";

                            if($sstr_pos >=0){
                            $emailval = "https://stocknews.com/cr/thanks/?email="+$email;
                            $form.find("#success_location").val($emailval)
                        }

                            e.currentTarget.submit();
                            return true;
                        }
                        else {
                            // $form.find("#emailnotice").html(this.responseText).show()
                            $form.append("</br><span style='color: #ff0000'>"+$tst+"</span>");
                            $globFAllow = false;
                            return false;
                        }
                    if($form.attr("id") == "home"||$form.attr("id") == "free-ns-form")
                    {
                    grecaptcha.reset();}
                };
                var data = new FormData();
                data.append("email", $email);


                    if($form.attr("id") == "home")
        {
            data.append("f-id", "home");
            data.append("g-recaptcha-response", grecaptcha.getResponse(1));

        } else if($form.attr("id") == "free-ns-form"){
            data.append("f-id", "free-ns-form");
            data.append("g-recaptcha-response", grecaptcha.getResponse(0));






                }else{

                    data.append("f-id", "none");

                }

                xhr.open("POST", "https://stocknews.com/v/index_tst.php?", true);
                xhr.send(data);



        });
    });
</script>
<script type="lazyload_int" data-src="https://stocknews.com/wp-content/cache/wnw-cache/all-js/bf139be17b301849cc8e86f96494cf17.js"></script><script>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</script></body>
</html>