<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>

<!--Session Page view:  -->
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="google-site-verification" content="DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps" />

<title>HD: 4 "Strong Buy" Stocks to Add to Your Portfolio Before 2021  </title>
<!--| StockNews.com-->
<link rel="icon" type="image/png" href="" />

<link rel="amphtml" href="https://stocknews.com/single-snippet-page/amp/" /><meta name="generator" content="AMP for WP 1.0.66.3"/><link rel='dns-prefetch' href='//www.google.com' />
<meta property="og:title" content="HD: 4 "Strong Buy" Stocks to Add to Your Portfolio Before 2021   | StockNews.com"/>
<meta property="og:description" content="We are nearing the most bullish time of the year for the stock market. Stocks are seasonally strong during the last two weeks of December and the first week of January. Four to consider getting long are GOOG, UPS, PEP, and HD."/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/"/>
<meta property="og:site_name" content="StockNews.com"/>
<meta property="og:image" content="https://stocknews.com/wp-content/uploads/2020/11/nio-nee-enph-fslr-scaled.jpg"/>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="HD: 4 "Strong Buy" Stocks to Add to Your Portfolio Before 2021   | StockNews.com">
<meta name="description" content="Home Depot, Inc.(NYSE:HD): We are nearing the most bullish time of the year for the stock market. Stocks are seasonally strong during the last two weeks of December and the first week of January. Four to consider getting long are GOOG, UPS, PEP, and HD."/>
<meta name="keywords" content="NYSE:HD, Home Depot Inc. (The) , Home Improvement & Goods, Commentary"/>
<script type="application/ld+json">
{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/"
 },
 "headline": "4 \"Strong Buy\" Stocks to Add to Your Portfolio Before 2021  ",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2020/11/nio-nee-enph-fslr-scaled.jpg" },
  "datePublished": "2020-11-17T14:44:30-05:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
  "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Home Depot, Inc.(NYSE:HD) We are nearing the most bullish time of the year for the stock market. Stocks are seasonally strong during the last two weeks of December and the first week of January. Four to consider getting long are GOOG, UPS, PEP, and HD."
}
</script>
<link rel="canonical" href="https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/"/>








<script src="https://stocknews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp" ></script>

<script src="https://stocknews.com/wp-content/themes/strappress/js/responsive-modernizr.js?ver=2.5.3" ></script>


<link rel='https://api.w.org/' href='https://stocknews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml" />
    <script type="lazyload_ext">
    // <![CDATA[
    jQuery(document).ready(function($){
        $("a[rel='magnific']").magnificPopup({
                type:'image'
        });
    });  
    // ]]>
    </script>
		<link rel="stylesheet" href="https://stocknews.com/wp-content/cache/wnw-cache/all-css/92545bd58e41cd19dc82b7184ddd9e0c.css" /><style id="wp-custom-css">
			@media (max-width:1199px) and (min-width:992px) {
    .responsive_head_fix {
        margin-top: 65px;
    }
}		</style>
		

<!-- Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="https://stocknews.com/wp-content/themes/strappress/js/respond.min.js"></script>
<![endif]-->



<!--
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script>
-->
<script src="https://stocknews.com/wp-content/themes/strappress-child/jquery-ui.min.js" ></script>







<!--
<script src="//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script>
-->








<script>
  jQuery(document).ready(function($){
    $('a.sn_pop').on('click', function(e) {e.preventDefault(); return true;});
    $( ".ticker-search" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $( ".ticker-search-big" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
     
  });
</script>
<script type="lazyload">
	jQuery(document).ready(function($){
		$('[data-toggle="popover"]').popover({html: true, trigger: 'focus'});
	});
</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64545224-1', 'auto');
  ga('send', 'pageview');
</script>



<script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" ></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21625568658/IMS/StockNews_Video', [760, 400], 'div-gpt-ad-1601396695524-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>







<!-- Google Tag Manager -->
<script type="lazyload_ext"async="">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MR8XMKP');</script>
<!-- End Google Tag Manager -->






<!-- google ads 072120 -->
    <script defer="defer" data-ad-client="ca-pub-6654551967172224" async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_int" ></script>



</head>

<body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78">
	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MR8XMKP"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->



        <header>

    

<div style="background:#333;"  class="headerstick">
<div class="container">
<div id="logo" class="hidden-sm hidden-xs"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
    <img src="/img/sn-green.png" alt="StockNews.com" style="width:360px;height:auto" />
</a></div>


<nav class="navbar-collapse collapse navbar-responsive-collapse">

<ul class="nav navbar-bav navbar-right">
    <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
  </ul>

<form class="navbar-form navbar-right" role="search" method="post" id="searchform" action="https://stocknews.com/">
  <div class="input-group">
    <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
    <div class="input-group-btn">
      <button type="submit" class="btn btn-success">Search</button>
    </div>
  </div>
  <input type="hidden" id="symbol_search" name="symbol_search" value="fdbe8dd2ca" /><input type="hidden" name="_wp_http_referer" value="/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/" /></form>

</nav>

<nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0">
  <div class="container-fluid">

    <div class="navbar-header">
      <div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
        <img src="/img/sn-green.png" style="width:220px;height:auto" alt="StockNews.com" />
    </a></div>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-bars" style="color:#fff !important;"></span>
      </button>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-search" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-search" style="color: #fff !important;"></span>
      </button>
    </div>

    <div class="collapse navbar-collapse" id="navbar">
      <ul id="menu-top-nav" class="nav navbar-nav">
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            News<span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/top-stories/">
                Top Stories
              </a>
            </li>

             <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/video-news/">
                Video News
              </a>
            </li>
            <!--<li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/featured-articles/">
                Featured Articles
              </a>
            </li>-->
          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Best Stocks<span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/best-stocks/">
                "A" Rated Stocks
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/powr-upgrades-downgrades/">
                Upgrades/Downgrades
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/high-yield-dividend-stocks/">
                High Yield Dividend Stocks
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stock-screener/">
                Stock Screener
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="/top-dividend-discount-model/">
                      Dividend Discount Model Stock Valuation
                  </a>
              </li>
             <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stocks/">
                Industry Rank
              </a>
            </li>
          <!--  <li class="divider"></li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/powr-ratings/">
                POWR Ratings&trade;
              </a>
            </li> -->

          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Best ETFs <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/best-etfs/">
                "A" Rated ETFs
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/etfs/">
                Best ETF Categories
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/high-yield-etfs/">
                High Yield ETFs
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="https://report.stocknews.com/7-best-etfs-for-the-next-bull-market/?lead_source=sn-best_etfs_menu&medium=spons-txt&campaign=7etfs">
                      7 Best ETFs
                  </a>
              </li>
          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/powr-ratings/">
            POWR Ratings&trade;
          </a>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/powr-upgrades-downgrades/">
            Upgrades/Downgrades<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
          </a>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/watchlist/">
            Watchlist<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
          </a>
        </li>

        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/stock-screener/">
            Screener
          </a>
        </li>
         <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Services <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com" target="_blank">
                Services Home
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com/reitmeister-total-return/" target="_blank">
                Reitmeister Total Return
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="https://members.stocknews.com/powr-charts/" target="_blank">
                      POWR Charts
                  </a>
              </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com/service/powr-trends/" target="_blank">
                POWR Trends
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://stocknews.com/powr-ratings/" target="_blank">
                Premium
              </a>
            </li>

          </ul>


        <!--
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a href="/screeners/" class="dropdown-toggle" data-toggle="dropdown" aria-expanded="false">
            Screeners <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stock-screener/">
                Stock Screener
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/etf-screener/">
                ETF Screener
              </a>
            </li>
          </ul>
        </li>
        -->
      </ul>
      <ul class="nav navbar-nav hidden-lg hidden-md">
                 <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
              </ul>
    </div>
    <div class="collapse navbar-collapse" id="navbar-search"> <form class="navbar-form hidden-lg hidden-md" role="search" method="post" id="searchform2" action="https://stocknews.com/">
          <div class="input-group">
            <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
            <div class="input-group-btn">
              <button type="submit" class="btn btn-success">Search</button>
            </div>
          </div>
         <input type="hidden" id="symbol_search" name="symbol_search" value="fdbe8dd2ca" /><input type="hidden" name="_wp_http_referer" value="/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/" />      </form></div>
  </div>
</nav>
</div>
</div>

    <!--nada -->


</header><!-- end of header -->


<br><br><br><br>
  <!--  <div class="text-center center-block" style="background-color:#f0f0f0; padding-bottom:5px; min-height:130px; text-align:center !important; padding-top:110px;"> -->
 <!-- <div id="StockNews_ROS_Top_Leaderboard" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Top_Leaderboard');
    });
    </script>
</div>
</div> -->




<div class="container">
  <div class="clearfix wrapper">

    
  <div id="content">
    <article>
      <header>

      
        <div class="row margin-top">
          <div class="col-lg-0 col-md-2"></div>
          <div class="col-lg-8 col-md-8">
            <div class="news-event">

                  <h1 class="page-title no-pad-left big-margin-bottom bold">
                4 "Strong Buy" Stocks to Add to Your Portfolio Before 2021  </h1>
                            <h1 class="page-title no-pad-left big-margin-bottom bold">
                              </h1>
              <div class="text-center">
   <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div> -->
  </div>
              
              
              <div class="row margin-top">
                <div class="col-lg-12 text-center">
               <!--   <div id="StockNews_ROS_Textlink" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Textlink');
    });
    </script>
</div>
 -->
                </div>
              </div>

              <div><div class="panel-body" style="padding: 0px !important;">

                                  <div class="row">
                    <div class="col-lg-12" style="max-height:550px; overflow:hidden;">
                      <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2020/11/nio-nee-enph-fslr-scaled.jpg" alt="NYSE: HD | Home Depot, Inc. (The)  News, Ratings, and Charts" style="margin:auto; display:block; max-height: 550px;">
                    </div>

                    <div class="col-lg-12 col-md-8">
                       <p><strong><a href="/stock/HD/">HD</a></strong> &#8211; We are nearing the most bullish time of the year for the stock market. Stocks are seasonally strong during the last two weeks of December and the first week of January. Four to consider getting long are GOOG, UPS, PEP, and HD.</p>
                

                                    </div>
                  </div>
                                <div class="row no-margin-top">
                  <div class="col-lg-12">

                    <section class="post-meta zero-padding pad-bottom">
                     <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src='https://stocknews.com/wp-content/uploads/2020/05/patrick-ryan.jpg' style="float:left; padding:5px;width:80px;" class="author-meta-image"><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=patrick-ryan">By Patrick Ryan</a></strong></span><br>                  <p style="font-size: 13px; font-weight: 700; color: #777; font-style: normal; display: inline-block;">Nov 17, 2020</a>                                    <div style="float:right;">                                    <div class="social-wrapper no-margin-bottom no-margin-top">
              <!-- Twitter -->
              <a href="https://twitter.com/intent/tweet?text=%24HD+4+%22Strong+Buy%22+Stocks+to+Add+to+Your+Portfolio+Before+2021+%C2%A0&amp;url=https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target="_blank"><i class="fa fa-twitter"></i></a>
              <!-- Facebook -->
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/" title="Share on Facebook" target="_blank" class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a>
              <!-- Google+ 
              <a href="https://plus.google.com/share?url=https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/" title="Share on Google+" target="_blank" class="sn-social-share btn btn-googleplus"><i class="fa fa-google-plus"></i></a> -->
              <!-- LinkedIn -->
              <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/hd-pep-ups-googl-goog-4-strong-buy-stocks-to-add-to-your-portfolio-before/&title=4+%22Strong+Buy%22+Stocks+to+Add+to+Your+Portfolio+Before+2021+%C2%A0&summary=" title="Share on LinkedIn" target="_blank" class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a>
            </div>
            <script type="lazyload">
              jQuery(document).ready(function($){
                jQuery("a.sn-social-share").click(function() {
                  window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');
                  return false;
                });
              });
            </script></div><br>

                </section>

                  </div>
                </div></div></div></div></div>
            <div class="col-lg-0 col-md-2"></div>
        </div>
      </header>
          <div class="row">
              <div class="col-lg-12">
                  <div style="margin: auto; width: fit-content;">
                        <div id="StockNews_Articles_Top_Leaderboard"></div>
                  </div>
              </div>
          </div>

          <div class="row margin-top">
              <div class="col-lg-0 col-md-2"></div>
              <div class="col-lg-8 col-md-8">
                  <div class="news-event">

                                                      </div>




            <div class="right-margin-ad" style="position: absolute; right:-210px; top:20%"><div style="width:200px !important;"><div class="panel panel-default"> <div class="panel-heading"> <h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3> </div><div class="panel-body"> <form role="form" action="/v/" method="GET" class="form-inline"> <p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><input name="tag_id" type="hidden" value="193"><input name="redirect_url" type="hidden" value="https://stocknews.com/registration/"> <div class="input-group" style="display: block !important;"> <input class="form-control" type="email" name="email" value="" placeholder="Your Email Address..." id="email" style="font-size:13px !important;"> <div align="center"><span class="input-group-btn"> <button style="background-color:#ffa200;-moz-border-radius:5px;-webkit-border-radius:5px;border-radius:5px;border:1px solid #92a394;display:inline-block;cursor:pointer;color:#ffffff;font-family:Arial;font-size:17px;padding: 5px 44px;text-decoration:none;text-shadow:0px 1px 0px #556353;margin-top: 5px;" type="submit">Subscribe</button> </span></div></div></form> <script data-src="https://sk687.infusionsoft.app/app/webTracking/getTrackingCode" type="lazyload_int" ></script><script data-src="https://sk687.infusionsoft.com/app/timezone/timezoneInputJs?xid=b8eca134cbe7a3685442b13f285af63c" type="lazyload_int" ></script></div></div></div></div><div class="post_content" id="articlecontent" style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><div>The New Year is quickly approaching, which means the most bullish time of the year is arriving. Do your homework now and you will be able to enjoy the holidays knowing you are well-positioned for the transition to ’21.</div>
<div>
&nbsp<br>
Market uncertainty resulting from the second wave of the virus is likely to steer money away from risky stocks toward those with a “Strong Buy” rating. The right combination of value stocks and tech stocks will bode well for your portfolio in the potentially tumultuous months ahead.<br>
&nbsp<br>
Let’s take a look at four “Strong Buy” stocks every investor should consider adding to his or her portfolio before the new year: Alphabet (GOOGL), Home Depot (HD), PepsiCo (PEP), and United Parcel Service (UPS).<br>
&nbsp<br><strong>Alphabet (<a href="https://stocknews.com/stock/GOOGL/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/stock/GOOGL/&source=gmail&ust=1605720470668000&usg=AFQjCNH15QxlAlNBZdfO_JLM_Z7SLjwC4g">GOOGL</a>)</strong>
<p>Though GOOGLE had its first-ever reduction in revenue this past second quarter, it is only a matter of time until search advertising returns to normal, helping the stock move even higher. GOOGLE has a wide variety of business segments designed with stay-at-home entertainment squarely in mind. From YouTube to its popular app store and beyond, the company rakes in the cash from those who remain at home, locked onto their screens. Furthermore, if there is a successful coronavirus vaccine, the travel industry will bounce back, helping GOOGL increase even more.</p>
<p>The <a href="https://stocknews.com/powr-ratings/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/powr-ratings/&source=gmail&ust=1605720470668000&usg=AFQjCNGTGtOAFVk-ihvxyyYTPBcwPGWLHg">POWR Ratings</a> show GOOGL has “A” grades in the Industry rank, Peer Grade, Buy & Hold Grade, and Trade Grade components. GOOGL is ranked second of nearly 60 publicly traded companies in the Internet space. The <a href="https://www.tipranks.com/stocks/googl/forecast" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://www.tipranks.com/stocks/googl/forecast&source=gmail&ust=1605720470668000&usg=AFQjCNEzVRDnGEGLzvFnHkD434gBiHE_cA">average analyst price target for GOOGL is $1,928.70</a>, meaning the stock has the potential to increase by 10% soon.</p>
<p>Do not be scared away by GOOGL’s forward P/E ratio of 34.81. This is a high-flying tech stock that is likely undervalued compared to its peers.</p>
<div><div style="border-top:1px solid #eee; margin-top:10px; border-bottom:1px solid #eee; margin-bottom:10px;"><br><p style="text-align:center; font-family: arial; font-size:25px; font-weight:bold;"><a href="https://report.stocknews.com/9-must-have-stocks-stl/?lead_source=sn-below_article&medium=spons-img&campaign=9mogs" target="_blank">9 <em>"MUST OWN"</em> Growth Stocks For 2021</a></p></div></div><p><strong>Home Depot (<a href="https://stocknews.com/stock/HD/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/stock/HD/&source=gmail&ust=1605720470668000&usg=AFQjCNEgCyKyyS5is66UD7gthN_ZyijYBg">HD</a>)</strong></p>
<p>As the largest home improvement retailer on the planet, HD is deserving of your attention. More and more homeowners are visiting HD as most other businesses have temporarily closed or restricted offerings due to the pandemic. HD is enjoying quite the revenue spike simply because more people are improving their homes during the pandemic as this is where most individuals are spending the majority of their time while social distancing.</p>
<p>The POWR Ratings reveal HD has “A” grades in the Buy & Hold Trade Grade and Industry Rank components. HD is ranked first of 69 publicly traded companies in the Home Improvement & Goods category. Check out the analysts’ take on HD and you will find they are bullish, having set <a href="https://www.tipranks.com/stocks/hd/forecast" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://www.tipranks.com/stocks/hd/forecast&source=gmail&ust=1605720470668000&usg=AFQjCNHCOllVzEWsu1TSoeCU3Rp6r0fO6g">an average price target of $313.32</a>.</p>
<div class="text-center" id="StockNews_ROS_Intext_Rectangle" style="padding-right:20px"></div><p>Look for HD to move back to $300, possibly blasting through its summer high of $291 as holiday home-related spending increases all the more.</p>
<p><strong>PepsiCo (<a href="https://stocknews.com/stock/PEP/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/stock/PEP/&source=gmail&ust=1605720470668000&usg=AFQjCNH1FS6Q729pmtXIfVTNM0jeKHyvRQ">PEP</a>)</strong></p>
<p>Snacks and sugary beverages are selling quite well during the pandemic. Instead of eating out at local restaurants and traveling, people are hunkering down and eating junk food sold by the likes of PEP. The POWR Ratings reveal PEP has “A” grades in the Peer Grade, Buy & Hold Grade, Trade Grade, and Industry Rank components. PEP is ranked first of 29 publicly traded stocks in the Beverages category.</p>
<div class="text-center" id="StockNews_ROS_Top_Leaderboard" style="margin-bottom:6px"></div><p>The top analysts have set an average price target of $152.27 for the stock, indicating it has around 6% upside. It should come as no surprise that PEP has quickly returned to its pre-COVID trading level of $140 to $150. Though the company certainly took a hit in the reduction in consumer spending at fast-food restaurants, the shortfall was made up through grocery store sales.</p>
<p>PEP’s most profitable segment, FritoLay, is generating considerable growth as people buy more snacks while remaining indoors during the pandemic, a habit that is likely to continue even if a vaccine proves effective.</p>
<p><strong>United Parcel Service (<a href="https://stocknews.com/stock/UPS/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/stock/UPS/&source=gmail&ust=1605720470668000&usg=AFQjCNGtpAeeCdmtKyiHlx4HZujJ9Bg4jw">UPS</a>)</strong></p>
<p>UPS has taken off like a rocket in recent months. The stock has clearly benefited from the reduction in foot traffic and the hike in shipping. Check out the POWR Ratings for UPS and you will find the stock has “A” grades in the Buy & Hold and Trade Grade components. UPS is ranked first of 9 stocks in the Air Freight & Shipping Services category.</p>
<p>The <a href="https://www.tipranks.com/stocks/ups/forecast" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://www.tipranks.com/stocks/ups/forecast&source=gmail&ust=1605720470668000&usg=AFQjCNEuqqTHxezj5YE__56z9UhFg9jwBQ">average analyst price target for the stock is nearly $179</a>, meaning there is an 8% upside. In short, UPS is a roundabout means of investing in eCommerce simply because the company plays an increasingly important part in transporting the products people and businesses need.</p>
<p>Take advantage of UPS’s record-setting revenue, scoop up this stock before the new year and the holiday sales figures should help your investment grow.</p>
<p><strong>Want More Great Investing Ideas?</strong></p>
<p><a href="https://sk687.isrefer.com/go/9mo21/sn/art_txt">9 “MUST OWN” Growth Stocks for 2021</a></p>
<p><a href="https://stocknews.com/news/spy-inx-dia-iwm-qqq-is-the-bull-market-back-on-track/">Is the Bull Market Back on Track?</a></p>
<p><a href="https://sk687.isrefer.com/go/5wtext/sn/cod">5 WINNING Stocks Chart Patterns</a></p>
</div>
<hr><p>HD shares were trading at $272.40 per share on Tuesday afternoon, down $7.17 (-2.56%). Year-to-date, HD has gained 26.99%, versus a 13.96% rise in the benchmark S&P 500 index during the same period.</p><script>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</script></body></html>
<div id="StockNews_ROS_Bottom_Leaderboard"></div><div style="clear:both;"></div><br><h2>About the Author: Patrick Ryan</h2><br><img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src='https://stocknews.com/wp-content/uploads/2020/05/patrick-ryan.jpg' style="float:left; padding:5px;width:125px;"><p>Patrick Ryan has more than a dozen years of investing experience with a focus on information technology, consumer and entertainment sectors. In addition to working for StockNews, Patrick has also written for Wealth Authority and Fallon Wealth Management. <a href="https://stocknews.com/authors/?author=patrick-ryan">More...</a></p><br><div style="clear:both;"></div><h2>More Resources for the Stocks in this Article</h2>
<table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;" >
<tr style="background-color:#5cb85c; color:white;">
    <td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/HD/">HD</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/PEP/">PEP</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/UPS/">UPS</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/GOOGL/">GOOGL</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/GOOG/">GOOG</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr></table></div></div>           <div align="center" class="margin-top"><div style="clear: both;"></div>
<div class="panel panel-default" style="max-width:750px;" id="topstories">

  <div class="panel-heading">
    <h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3>
  </div>
  <div class="panel-body">


            <p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p>
            <!-- The following code must be included to ensure your sign-up form works properly. -->
            <form role="form" method="GET" action="/v/" id="validate">
             <input name="tag_id" type="hidden" value="203">
    <input name="redirect_url" type="hidden" value="https://stocknews.com/thanks/">
            <div class="input-group">
            <input class="form-control" type="email" name="email" value="" placeholder="Enter Your Email Address" id="email">
            <span class="input-group-btn">
              <input type="submit" class="btn btn-primary" data-enabled="enabled" role="button" value="Subscribe">
            </span>
            </div>
          </form>


  </div>
</div>
<script type="lazyload">
var $ = jQuery;
$(function(){
  $('form[name=cc_form]').submit(function(){
    $.post($(this).attr('action'), $(this).serialize(), function(json) {
      alert(json);
    }, 'json');
    return false;
  });
});
</script>
</div>
          </div>
              <div class="col-lg-2 col-md-2"></div><!-- end of column -->



    </div>
     <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>-->




      <div class="row margin-top">
        <div class="col-lg-2 col-md-1"></div>
      <div class="col-lg-8 col-md-10">
        <div id="StockNews_ROS_BelowPost_1"></div><br>
      <h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Most Popular Stories on StockNews.com</strong></h2>
     





			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/pypl-sq-crwd-okta-4-tech-stocks-that-should-continue-to-soar-into-2021/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/11/pypl-sq-crwd-okta-scaled.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/pypl-sq-crwd-okta-4-tech-stocks-that-should-continue-to-soar-into-2021/" class="black">4 Tech Stocks That Should Continue to Soar into 2021</a>
				  				</h3>
				Technology stocks were already big winners of the pandemic. With no end in sight to this virus, the technology sector is more essential than ever despite seeing a correction last week. A sound business model and solid price momentum make PayPal Holdings (PYPL), Square (SQ), CrowdStrike Holdings (CRWD), and Okta (OKTA) solid bets as we enter 2021.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Nov 16, 2020</a> <span class="light-gray">|</span> 1:43pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>





						<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-is-the-bull-market-back-on-track/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/11/Bull-starting-down-bear-.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-is-the-bull-market-back-on-track/" class="black">Is the Bull Market Back on Track?</a>
				  				</h3>
				Investors got a double dose of news that gets them in a bullish mood for stocks (SPY). So even this once crusty bear is ready to ride these trends to new highs in the year ahead. Get full details below…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Nov 11, 2020</a> <span class="light-gray">|</span> 12:56pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>







<!-- code from Primis - stocknews.com NVU 760*400 -->
<script language="javascript" data-src="https://live.sekindo.com/live/liveView.php?s=98944&cbuster=%%CACHEBUSTER%%&pubUrl=%%REFERRER_URL_ESC%%&subId=[SUBID_ENCODED]&x=%%WIDTH%%&y=%%HEIGHT%%" type="lazyload_int" ></script>
<!-- code from Primis -->






			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/tmo-dg-ste-pki-spyg-4-top-rated-growth-stocks-for-uncertain-markets/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/11/tmo-dg-ste-pki-spyg.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/tmo-dg-ste-pki-spyg-4-top-rated-growth-stocks-for-uncertain-markets/" class="black">4 Top-Rated Growth Stocks for Uncertain Markets</a>
				  				</h3>
				With uncertainty circling the market, investors should consider safe growth stocks such as Thermo Fisher Scientific Inc (TMO), Dollar General Corporation (DG), STERIS plc (STE), and PerkinElmer, Inc. (PKI). These companies have low beta, healthy balance sheets, and a strong history of growth.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Nov 16, 2020</a> <span class="light-gray">|</span> 6:24pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>









			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/acb-apha-aurora-cannabis-vs-aphria-which-stock-is-a-better-buy/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/11/shutterstock_66190774-scaled.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/acb-apha-aurora-cannabis-vs-aphria-which-stock-is-a-better-buy/" class="black">Aurora Cannabis vs. Aphria: Which Stock is a Better Buy?</a>
				  				</h3>
				Biden’s win has boosted the $13.6 billion US cannabis industry, and companies like Aurora Cannabis (ACB) and Aphria (APHA). Will APHA lead the race to garner a higher market share, or will ACB recover from its prior year-losses to regain its luster? Read more to find out.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Nov 16, 2020</a> <span class="light-gray">|</span> 3:38pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>







			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/tmo-dg-ste-pki-spyg-4-top-rated-growth-stocks-for-uncertain-markets/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/11/tmo-dg-ste-pki-spyg.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/tmo-dg-ste-pki-spyg-4-top-rated-growth-stocks-for-uncertain-markets/" class="black">4 Top-Rated Growth Stocks for Uncertain Markets</a>
				  				</h3>
				With uncertainty circling the market, investors should consider safe growth stocks such as Thermo Fisher Scientific Inc (TMO), Dollar General Corporation (DG), STERIS plc (STE), and PerkinElmer, Inc. (PKI). These companies have low beta, healthy balance sheets, and a strong history of growth.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Nov 16, 2020</a> <span class="light-gray">|</span> 6:24pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>

  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>

       <h3>
            <a href="/top-stories/" class="btn btn-default width-full margin-top-less" role="button">Read More Stories</a>
          </h3>
          <div align="center"><script async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_int" ></script>
<!-- Bottom Article Banner Ad (4) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6654551967172224"
     data-ad-slot="1071597498"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

      </div>
      </div>



      <div class="row margin-top">
        <div class="col-lg-12">
          <h3>
            More Home Depot, Inc. (The)  (HD) News
            <a href="/stock/HD/news/" class="btn btn-default" role="button">View All</a>
          </h3>
          <div class="panel panel-default">
            <table class="table-condensed table table-striped news mobile-card-view" id="news-stream">
              <thead>
                <tr>
                  <th>Event/Date</th>
                  <th>Symbol</th>
                  <th>News Detail</th>
                  <th class="text-right" nowrap>Start Price</th>
                  <th class="text-right" nowrap>End Price</th>
                  <th nowrap>Change</th>
                  <th>POWR Rating</th>
                </tr>
              </thead>
              <tbody>
                <tr><td colspan="10" class="text-center">Loading, please wait...</td></tr>
              </tbody>
            </table>
          </div>
          <a href="/stock/HD/" class="btn btn-default width-full margin-top-less">View All HD News</a>
        </div>
      </div><!-- end of row -->

    </article>


  </div><!-- end of content -->
  


  <script src="https://code.jquery.com/jquery-2.2.4.min.js" ></script>
  <script type="lazyload">
  jQuery(document).ready(function($){
    function symbol_get_snippets(symbol) {
      $.getJSON('https://stocknews.com/wp-content/themes/strappress-child/includes/snippet-json.php?symbol=HD&limit=10&historical_prices=1',
        function (json) {
          $("table#news-stream tbody").html("");
          var tr=[];
          for (var i = 0; i < json.results.length; i++) {
            if ((json.results[i].top_story_headline != "") && (json.results[i].top_story_headline != null)) {
              var headline = json.results[i].top_story_headline;
            } else {
              var headline = json.results[i].notes;
            }
            tr.push('<tr>');
            tr.push('<td class="bullorbear-' + json.results[i].bull_or_bear + 'a"><strong>' + json.results[i].event_short + '</strong><br><span class="medium-gray">' + json.results[i].snippet_time + '</span></div>');
            tr.push('<td><strong><a href="/stock/' + json.results[i].symbol + '/">' +  json.results[i].symbol + '</strong></td>');
            //tr.push('<td><a href="/stock/' + json.results[i].symbol + '/">' + json.results[i].company + '</a></td>');
            tr.push('<td><span class="dark-gray"><a href="https://stocknews.com/news/' + json.results[i].post_slug + '">' + headline + '</a></span></td>');
            tr.push('<td class="text-right">' + json.results[i].price_when_added + '</td>');
            tr.push('<td class="text-right grade-' + json.results[i].day_change_color + '">' + json.results[i].day_close + '</td>');
            tr.push('<td class="grade-' + json.results[i].day_change_color + '">' + json.results[i].day_change + '<br>' + json.results[i].day_pct_change + '</td>');
            //tr.push('<td class="grade-' + json.results[i].ttm_color + '">' + json.results[i].ttm_pct_change_formatted + '</td>');
            tr.push('<td class="text-center grade-' + json.results[i].powr_grade_color + '"><strong>' + json.results[i].powr_grade + '</strong><br><small>' + json.results[i].powr_grade_text + '</small></td>');
                        tr.push('</tr>');
          }
          $(tr.join('')).appendTo($('table#news-stream tbody')).slideDown("slow");
      });
    }
    symbol_get_snippets('HD');
  });

  jQuery(function($) {

      $('.post_content').find('a[href^="http"]').not('a[href*=stocknews]').attr('target','_blank');
      });

  //Change Stock Tickers to Get Rating Links

  let tickerPos, ratingReplace = "";

  let stockData = {"replace_stocks":[{"stock":"HD"},{"stock":"PEP"},{"stock":"UPS"},{"stock":"GOOGL"},{"stock":"GOOG"}]};

  
  for (tickerPos in stockData.replace_stocks) {
      ratingReplace = '(<strong><a href="https://stocknews.com/stock/' + stockData.replace_stocks[tickerPos].stock + '">' + stockData.replace_stocks[tickerPos].stock + '</a></strong> - <a href="https://stocknews.com/registration/free/?tag_id=3269" style="color:green; font-style:italic;">Get Rating</a>)'
      replaceTickers(tickerPos);
  }
  
  function replaceTickers(tickerPos) {
      let stockTicker = stockData.replace_stocks[tickerPos].stock;
      let regexTicker = new RegExp('\\(([^)]+)(\\b'+ stockTicker +'\\b)([^)]+)\\)', 'g')
      let str = document.getElementById("articlecontent").innerHTML;
      let res = str.replace(regexTicker, ratingReplace);
      document.getElementById("articlecontent").innerHTML = res;
  }
  </script>


        </div><!-- end of wrapper-->


</div><!-- end of container -->

<footer id="footer" class="clearfix">
  <div class="container">
    <hr>
    <div id="footer-wrapper">
      <div class="row margin-bottom">
        <div class="col-lg-6">
          ©2020 StockNews.com                </div><!-- end column -->
                      <div class="col-lg-6 text-right">
          <a href="/about/">About Us</a> | <a href="/contact/">Contact Us</a> | <a href="/privacy/">Privacy Policy</a> | <a href="/legal/">Terms of Use</a>
        </div>
              </div><!-- end row -->
            <div class="row">
        <div class="col-lg-6">
          <p><small>Copyright © 2020. Market data provided is at least 10-minutes delayed and hosted by <a href="https://www.barchart.com/solutions" target="_blank">Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href="http://www.barchart.com/solutions/company/terms-and-privacy">disclaimer</a>.</small></p>
        </div>
        <div class="col-lg-6"
          <p><small>Automated Insights by <a href="https://sixjupiter.com"  target="_blank">SixJupiter</a>.
          <br><br>
          <em>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" rel="nofollow">Privacy Policy</a> and <a href="https://policies.google.com/terms" rel="nofollow">Terms of Service</a> apply.</em></small>
          </p>
        </div>
      </div>
          </div><!-- end #footer-wrapper -->
  </div> <!-- end container -->
</footer><!-- end #footer -->


<script type="lazyload_ext"async="">(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='d1a293004a063000b79b40002eed8d007d2680005842eb00f4865000f034f400';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>    <script>
      var ajaxurl = "https://stocknews.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
    <script>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type="lazyload_int" data-src="https://stocknews.com/wp-content/cache/wnw-cache/all-js/f203bb315d0c5a4dd90a3a7f7a1e6d65.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js?render=6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc&ver=3.0" type="lazyload_int" ></script>
<script>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>



<script type="lazyload_int" data-src="https://stocknews.com/wp-content/cache/wnw-cache/all-js/924c4ed91613f5c3c88d1b3a2990f571.js"></script>

<!-- AST – IMS - [StockNews_PopUp] -->
<div id="StockNews_PopUp_PopUp" class="text-center">
  <!--<script>
  apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });
  </script>-->
</div>
<!-- End AST – IMS - [StockNews_PopUp] -->


<!-- Push Monkey code  -->

<!-- dfp script-->
<script type="lazyload_ext"defer="defer"data-cfasync="false"> (function() { window.advBidxc = window.advBidxc || {}; window.advBidxc.startTime = new Date().getTime(); function loadScript(tagSrc) { var scriptTag = document.createElement('script'), placeTag = document.getElementsByTagName("script")[0]; scriptTag.type = 'text/javascript'; scriptTag.async = true; scriptTag.src = tagSrc; placeTag.parentNode.insertBefore(scriptTag, placeTag); } var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' + window.location.hostname; loadScript(mnSrc); })(); </script>
<!-- dfp script -->

<!-- pardot script -->
<script>
piAId = '890453';
piCId = '1072';
piHostname = 'pi.pardot.com';

(function() {
	function async_load(){
		var s = document.createElement('script'); s.type = 'text/javascript';
		s.src = ('https:' == document.location.protocol ? 'https://pi' : 'http://cdn') + '.pardot.com/pd.js';
		var c = document.getElementsByTagName('script')[0]; c.parentNode.insertBefore(s, c);
	}
	if(window.attachEvent) { window.attachEvent('onload', async_load); }
	else { window.addEventListener('load', async_load, false); }
})();
</script>

<!-- pardot script -->


<script>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</script></body>
</html>