<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head><script>var w3_googlefont=[];</script><script>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</script>

    <script type="lazyload_ext" >(function(){window.advBidxc=window.advBidxc||{};window.advBidxc.customerId="8CUJ1CM79";window.advBidxc.domain=window.location.hostname;window.advBidxc.version=5.1;window.advBidxc.startTime=new Date().getTime();function loadScript(tagSrc){var scriptTag=document.createElement('script'),placeTag=document.getElementsByTagName("script")[0];scriptTag.type='text/javascript';scriptTag.async=true;scriptTag.src=tagSrc;placeTag.parentNode.insertBefore(scriptTag,placeTag);var scriptTag1=document.createElement('script'),placeTag1=document.getElementsByTagName("script")[0];scriptTag1.type='text/javascript';scriptTag1.async=true;scriptTag1.src='https://securepubads.g.doubleclick.net/tag/js/gpt.js';placeTag1.parentNode.insertBefore(scriptTag1,placeTag1);}
var mnSrc='https://hbx.media.net/bidexchange.js?cid='+window.advBidxc.customerId+"&version="+window.advBidxc.version+'&dn='+window.advBidxc.domain;loadScript(mnSrc);})();</script>

    <!-- Google Tag Manager -->
    <script type="lazyload_int" async="" defer="defer" >(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-M36BQWD');</script>
    <!-- End Google Tag Manager -->

<!--Session Page view:  -->
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="google-site-verification" content="DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps" />
    <meta name="robots" content="max-image-preview:large">

<title>MSFT: Looking for a Deal? 2 Stocks to Buy for a Bargain Right Now</title>
<!--| StockNews.com-->
<link rel="icon" type="image/png" href="" />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
            <meta property="og:title" content="MSFT: Looking for a Deal? 2 Stocks to Buy for a Bargain Right Now | StockNews.com"/>
            <meta property="og:description" content="The Fed is expected to slow down its rate hike aggression amid positive inflation data expectations. Moreover, the U.S. consumer sentiment remains strong despite rampant macro headwinds. Amid the broader market sell-off, investor sentiment toward value stocks has improved significantly. Therefore, Investors looking for a good deal might buy quality stocks Microsoft (MSFT) and Taiwan Semiconductor (TSM) for a bargain. Keep reading…"/>
            <meta property="og:type" content="article"/>
            <meta property="og:url" content="https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/"/>
            <meta property="og:site_name" content="StockNews.com"/>
            <meta property="og:image" content="https://stocknews.com/wp-content/uploads/2021/05/shutterstock_114650083-1-scaled.jpg"/>
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:title" content="MSFT: Looking for a Deal? 2 Stocks to Buy for a Bargain Right Now | StockNews.com">
            <meta name="description" content="Microsoft Corporation(NASDAQ:MSFT): The Fed is expected to slow down its rate hike aggression amid positive inflation data expectations. Moreover, the U.S. consumer sentiment remains strong despite rampant macro headwinds. Amid the broader market sell-off, investor sentiment toward value stocks has improved significantly. Therefore, Investors looking for a good deal might buy quality stocks Microsoft (MSFT) and Taiwan Semiconductor (TSM) for a bargain. Keep reading…"/>
            <meta name="keywords" content="NASDAQ:MSFT, Microsoft Corp., Software - Business, Commentary"/>
            <script type="application/ld+json">
{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/"
 },
 "headline": "Looking for a Deal? 2 Stocks to Buy for a Bargain Right Now",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2021/05/shutterstock_114650083-1-scaled.jpg" },
  "datePublished": "2022-12-13T08:37:13-05:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
 "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Microsoft Corporation(NASDAQ:MSFT) The Fed is expected to slow down its rate hike aggression amid positive inflation data expectations. Moreover, the U.S. consumer sentiment remains strong despite rampant macro headwinds. Amid the broader market sell-off, investor sentiment toward value stocks has improved significantly. Therefore, Investors looking for a good deal might buy quality stocks Microsoft (MSFT) and Taiwan Semiconductor (TSM) for a bargain. Keep reading…"
}
</script>
			        <link rel="canonical" href="https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/"/>
				<script type="lazyload_ext" >window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/stocknews.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://stocknews.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tboot_shortcode_styles-css'  href='https://stocknews.com/wp-content/plugins/bootstrap-sc-plugin/includes/css/tboot_shortcodes_styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://stocknews.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://stocknews.com/wp-content/themes/strappress/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-styles-css'  href='https://stocknews.com/wp-content/themes/strappress/css/layouts/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://stocknews.com/wp-content/themes/strappress/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css'  href='https://stocknews.com/wp-content/themes/strappress/css/magnific.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-style-css'  href='https://stocknews.com/wp-content/themes/strappress-child/style.css' type='text/css' media='all' />
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/b1334df70266c8b6dbc18e667d977587.js"></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/006afb6673518d44a03628677ceb6c7a.js"></script>
<script type="text/javascript" src="https://stocknews.com/wp-content/cache/w3-cache/js/4dfd39d8b5c70d3a48583dc0e520f374.js" ></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/1a017f5b37d166145077520ff1b61f3b.js"></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/ac779cfc01a8f8162cc48026c2963d78.js"></script>
<link rel='https://api.w.org/' href='https://stocknews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.1.23" />    <script type="lazyload_ext" >jQuery(document).ready(function($){$("a[rel='magnific']").magnificPopup({type:'image'});});</script>
<script src="https://unpkg.com/analytics/dist/analytics.min.js" ></script>
<script src="https://distill-public.s3.us-east-2.amazonaws.com/distillanalytics.min.js" ></script>
<script>
  const analytics = initAnalytics('ce5cc460-f898-48eb-8b20-f0a690f14d1e');
  analytics.page();
</script> 		<style type="text/css" id="wp-custom-css">
			@media (max-width:1199px) and (min-width:992px) {
    .responsive_head_fix {
        margin-top: 65px;
    }
}

.mobileShow {
  display: none;
}

/* full width of parent */
.mobileShow img{
    width: 100%;
}

/* Smartphone Portrait and Landscape */
@media only screen and (min-device-width: 320px) and (max-device-width: 480px) {
  .mobileShow {
    /*position: fixed; bottom: 0;z-index: 111;display:block;left:10%;padding-bottom:12px;*/
    max-width:320px;
    width:90%;
    position: fixed;
    bottom:0;
    z-index:111;
    display:block;
    left:0;
    padding-bottom:12px;
    right:0;
    margin:0 auto;

  }
}
.close_btn::before
{
content: '✖';
  color: #000;
  font-weight: 600;
  font-family: Arial, sans-serif;
  float:right;
  opacity: 0.5;
  font-size:16px;
}		</style>
		


<!-- Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="https://stocknews.com/wp-content/themes/strappress/js/respond.min.js"  ></script>
<![endif]-->

<link rel="stylesheet" href="/wp-content/themes/strappress-child/fonts/open-sans.css?family=Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&display=swap">
<!--
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script>
    -->

    

    <script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/d01726d73118befddca5357be5de07d2.js"></script>

    <script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/19fe0c8490039cbdba4316a13a8f050f.js"></script>
 


    <script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/7ce117e05fe081ddf77bdf3eff7d12cb.js"></script>
<!--
<script src="//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script>
-->
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/d723082702a47c4d4ea5e798625a4ad0.js"></script>







<script type="lazyload_ext" >jQuery(document).ready(function($){$('a.sn_pop').on('click',function(e){e.preventDefault();return true;});jQuery(".ticker-search").autocomplete({source:'//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',minLength:1,focus:function(event,ui){$(".ticker-search").val(ui.item.label);return false;},select:function(event,ui){window.location="/stock/"+ui.item.value+"/";}}).autocomplete("instance")._renderItem=function(ul,item){return $("<li>").append('<a href="/stock/'+item.value+'/"><strong class="sixteen">'+item.label+'</strong><br><span class="medium-gray">'+item.desc+'</span></a>').appendTo(ul);};$(".ticker-search-big").autocomplete({source:'//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',minLength:1,focus:function(event,ui){$(".ticker-search").val(ui.item.label);return false;},select:function(event,ui){window.location="/stock/"+ui.item.value+"/";}}).autocomplete("instance")._renderItem=function(ul,item){return $("<li>").append('<a href="/stock/'+item.value+'/"><strong class="sixteen">'+item.label+'</strong><br><span class="medium-gray">'+item.desc+'</span></a>').appendTo(ul);};});jQuery(document).ready(function($){$('[data-toggle="popover"]').popover({html:true,trigger:'focus'});});</script>

<script type="lazyload_int" defer="defer" >(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','/wp-content/themes/strappress-child/js/analytics.js','ga');ga('create','UA-64545224-1','auto');ga('send','pageview');</script>












<!-- google ads 072120 -->

            <script defer="defer" data-ad-client="ca-pub-6654551967172224" async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_ext" ></script>
    












    












   
    <script type="lazyload_ext" defer="defer" >(function(d,s,b){var mElmt,primisElmt=d.createElement('script');primisElmt.setAttribute('type','text/javascript');primisElmt.setAttribute('defer','defer');primisElmt.setAttribute('src',s);var elmtInterval=setInterval(function(){mElmt=d.getElementById(b);if(mElmt){mElmt.parentNode.insertBefore(primisElmt,mElmt.nextSibling);mElmt.parentNode.removeChild(mElmt);return clearInterval(elmtInterval);}},1000);})(document,'https://live.primis.tech/live/liveView.php?s=107234','widgetLoaded');</script>


   <script type="lazyload_int" async="" defer="defer" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[728,90],'stocknews-com-articles-top-banner').setTargeting('pos',['top']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[728,90],'stocknews-com-articles-entrplc').setTargeting('pos',['bot1']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});</script>


<script type="lazyload_int" async="" defer="defer" >var gptadslots=[];var googletag=googletag||{cmd:[]};googletag.cmd.push(function(){var REFRESH_KEY='refresh';var REFRESH_VALUE='true';googletag.defineSlot('/21771534901/stocknews.com//articles',[[300,600],[300,250]],'stocknews-com-articles-right-sticky').setTargeting(REFRESH_KEY,REFRESH_VALUE).setTargeting('pos',['sticky']).addService(googletag.pubads());var SECONDS_TO_WAIT_AFTER_VIEWABILITY=30;googletag.pubads().addEventListener('impressionViewable',function(event){var slot=event.slot;if(slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE)>-1){setTimeout(function(){googletag.pubads().refresh([slot]);},SECONDS_TO_WAIT_AFTER_VIEWABILITY*1000);}});googletag.enableServices();});</script>




 <script type="lazyload_int" async="" defer="defer" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[[970,250],[728,90]],'stocknews-com-articles-bottom').setTargeting('pos',['bot']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});</script>




	 


   	   <script type="lazyload_int" async="" defer="defer" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com',[728,90],'stocknews-com-mnetrplc').setTargeting('pos',['mid1']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});</script>


	   






</head>

<body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M36BQWD"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->




        <header>

    

<div style="background:#333;"  class="headerstick">
<div class="container">
<div id="logo" class="hidden-sm hidden-xs" style="height: 40px;width: 360px;"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
    <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/img/sn-green_new_.png" alt="StockNews.com" style="width:198px;height:auto; margin-left:50px;" width="198px" height="18px"/>
</a></div>


<nav class="navbar-collapse collapse navbar-responsive-collapse">

<ul class="nav navbar-bav navbar-right">
    <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
  </ul>

<form class="navbar-form navbar-right" role="search" method="post" id="searchform" action="https://stocknews.com/">
  <div class="input-group">
    <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
    <div class="input-group-btn">
      <button type="submit" class="btn btn-success">Search</button>
    </div>
  </div>
  <input type="hidden" id="symbol_search" name="symbol_search" value="206bf9ba0a" /><input type="hidden" name="_wp_http_referer" value="/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/" /></form>

</nav>

<nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0">
  <div class="container-fluid">

    <div class="navbar-header">
      <div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
        <img src="/img/sn-green.png" style="width:220px;height:auto" width="220px" height="24px" alt="StockNews.com" />
    </a></div>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-bars" style="color:#fff !important;"></span>
      </button>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-search" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-search" style="color: #fff !important;"></span>
      </button>
    </div>

    <div class="collapse navbar-collapse" id="navbar">
                        <ul id="menu-top-nav" class="nav navbar-nav">
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    News<span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/top-stories/">
                                            Top Stories
                                        </a>
                                    </li>

                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/video-news/">
                                            Video News
                                        </a>
                                    </li>

                                    <!--<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/featured-articles/">
										Featured Articles
									  </a>
									</li>-->
                                </ul>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Best Stocks<span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/best-stocks/">
                                            "A" Rated Stocks
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/powr-upgrades-downgrades/">
                                            Upgrades/Downgrades
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/high-yield-dividend-stocks/">
                                            High Yield Dividend Stocks
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/stock-screener/">
                                            Stock Screener
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="/top-stocks-price-target/">
                      Top Stocks by Target Price
                  </a>
              </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/top-dividend-discount-model/">
                                            Dividend Discount Model Stock Valuation
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/stocks/">
                                            Industry Rank
                                        </a>
                                    </li>
                                    <!--  <li class="divider"></li>
									  <li class="menu-item menu-item-type-custom menu-item-object-custom">
										<a href="/powr-ratings/">
										  POWR Ratings&trade;
										</a>
									  </li> -->

                                </ul>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Best ETFs <span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/best-etfs/">
                                            "A" Rated ETFs
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/etfs/">
                                            Best ETF Categories
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="/high-yield-etfs/">
                                            High Yield ETFs
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://report.stocknews.com/7-best-etfs-for-the-next-bull-market/?lead_source=sn-best_etfs_menu&medium=spons-txt&campaign=7etfs&Pagesource=StockNews">
                                            7 Best ETFs
                                        </a>
                                    </li>
                                </ul>
        </li>
          <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a  aria-expanded="false" href="/powr-ratings/">
                  POWR Ratings
              </a>

                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/powr-upgrades-downgrades/">
                                    Upgrades/Downgrades<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
                                </a>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/watchlist/">
                                    Watchlist<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
                                </a>
                            </li>

                            <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                <a href="/stock-screener/">
                                    Screener
                                </a>
                            </li>
                            <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
                                <a class="dropdown-toggle" aria-expanded="false">
                                    Services <span class="caret"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://members.stocknews.com" target="_blank">
                                            Services Home
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://report.stocknews.com/special-offer/powr-platinum/" target="_blank">
                                            POWR Platinum
                                        </a>
                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
	                                                                                <a href="https://report.stocknews.com/special-offer/rtr/" target="_blank">
                                                Reitmeister Total Return
                                            </a> 					                                    </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                                    <a href="https://report.stocknews.com/special-offer/powr-stocks/" target="_blank">
                                                Stocks Under $10
                                            </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                                    <a href="https://report.stocknews.com/special-offer/powr-breakouts/" target="_blank">
                                                POWR Breakouts
                                            </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                                <a href="https://report.stocknews.com/powr-growth/" target="_blank">
                                            POWR Growth
                                        </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                                    <a href="https://report.stocknews.com/special-offer/powr-options/" target="_blank">
                                                POWR Options
                                            </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                            <a href="https://report.stocknews.com/special-offer/powr-value/" target="_blank">
                                            POWR Value
                                        </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                            <a href="https://report.stocknews.com/powr-trends-2020/" target="_blank">
                                            POWR Trends
                                        </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                                                                    <a href="https://report.stocknews.com/special-offer/powr-screens-10/" target="_blank">
                                                POWR Screens 10
                                            </a>
                                                                            </li>
                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://report.stocknews.com/special-offer/premium/" target="_blank">
                                            Premium
                                        </a>
                                    </li>

                                    <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                        <a href="https://wealthpop.com/stock-market-coaching/"  target="_blank">Coaching</a>
                                    </li>

                                </ul>


                                <!--
								<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
								  <a href="/screeners/" class="dropdown-toggle" data-toggle="dropdown" aria-expanded="false">
									Screeners <span class="caret"></span>
								  </a>
								  <ul class="dropdown-menu">
									<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/stock-screener/">
										Stock Screener
									  </a>
									</li>
									<li class="menu-item menu-item-type-custom menu-item-object-custom">
									  <a href="/etf-screener/">
										ETF Screener
									  </a>
									</li>
								  </ul>
								</li>
								-->
                        </ul>
                        <ul class="nav navbar-nav hidden-lg hidden-md">
							                                <li class="menu-item menu-item-type-custom menu-item-object-custom">
                                    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
                                            Join
                                        </a>
                                    </p>
                                </li>
							                        </ul>
                    </div>
    <div class="collapse navbar-collapse" id="navbar-search"> <form class="navbar-form hidden-lg hidden-md" role="search" method="post" id="searchform2" action="https://stocknews.com/">
          <div class="input-group">
            <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" size="17">
            <div class="input-group-btn">
              <button type="submit" class="btn btn-success">Search</button>
            </div>
          </div>
         <input type="hidden" id="symbol_search" name="symbol_search" value="206bf9ba0a" /><input type="hidden" name="_wp_http_referer" value="/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/" />      </form></div>
  </div>
</nav>
</div>
</div>






</header><!-- end of header -->


<br><br><br><br>
  <!--  <div class="text-center center-block" style="background-color:#f0f0f0; padding-bottom:5px; min-height:130px; text-align:center !important; padding-top:110px;"> -->
 <!-- <div id="StockNews_ROS_Top_Leaderboard" class="text-center">
    <script type="text/javascript">
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Top_Leaderboard');
    });
    </script>
</div>
</div> -->




<div class="container">
  <div class="clearfix wrapper ">

    
<div id="content">
    <article style="position:relative;">

            
           <div id='right-outer-sticky' style='position: absolute;top: 1600px;
    left: 85%;'>


<div class="right-margin-ad1" style='position:sticky;top:12%;'><div id='stocknews-com-articles-right-sticky'></div><div class="margin-top">
        <div class="top-stories-sidebar" id="top-stories-sidebar">
    <h3 style="padding-left: 15px;">Most Popular Stories
    </h3>

                    <h4 class="feature-sub bold top-stories-homepage"><a href="/news/spy-inx-dia-iwm-qqq-2023-stock-market-outlook/" class="blue">&bull; 2023 Stock Market Outlook</a></h4>
                                    <h4 class="feature-sub bold top-stories-homepage"><a href="/news/afrm-cano-ffie-3-terrible-stocks-you-need-to-sell-before-2023/" class="blue">&bull; 3 Terrible Stocks You Need to Sell Before 2023</a></h4>
                                                <h4 class="feature-sub bold top-stories-homepage"><a href="/news/dis-amcx-1-risky-stock-you-might-not-want-to-touch-right/" class="blue">&bull; 1 Risky Stock You Might Not Want to Touch Right Now</a></h4>
                                                            <h4 class="feature-sub bold top-stories-homepage"><a href="/news/sq-lcid-roku-3-popular-stocks-investors-have-been-busy-selling-short/" class="blue">&bull; 3 Popular Stocks Investors Have Been Busy Selling Short</a></h4>
                                                                        <h4 class="feature-sub bold top-stories-homepage"><a href="/news/spy-inx-dia-iwm-qqq-stock-investors-in-a-sticky-situation/" class="blue">&bull; Stock Investors in a “Sticky” Situation</a></h4>
                                                 <a href="/top-stories/" class="btn btn-default">View All Top Stories</a>
    </div>

</div></div></div>

                    <header class="news-header">

			
			            <div class="row margin-top">
                <div class="col-lg-0 col-md-2"></div>
                <div class="col-lg-8 col-md-8">


                    <div class="news-event first-news-event">

						                        <h1 class="page-title no-pad-left big-margin-bottom bold">
							Looking for a Deal? 2 Stocks to Buy for a Bargain Right Now</h1>
						                            <h1 class="page-title no-pad-left big-margin-bottom bold">
								                            </h1>
                            <div class="text-center">
                                <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div> -->
                            </div>
						
						
                        <div class="row margin-top">
                            <div class="col-lg-12 text-center">
                                <!--   <div id="StockNews_ROS_Textlink" class="text-center">
    <script type="text/javascript">
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Textlink');
    });
    </script>
</div>
 -->
                            </div>
                        </div>

                        <div><div class="panel-body" style="padding: 0px !important;">
																                                <div class="row">
                                    <div class="col-lg-12" style="max-height:550px; overflow:hidden;min-height:540px;">
                                        <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2021/05/shutterstock_114650083-1-scaled.jpg" alt="NASDAQ: MSFT | Microsoft Corp. News, Ratings, and Charts"  style="height:100%; width:100%; object-fit: cover; margin:auto; display:block; max-height: 550px;min-height:540px;" width="550px" height="481px">
                                    </div>

                                    <div class="col-lg-12 col-md-8">
										<p><strong><a href="/stock/MSFT/">MSFT</a></strong> &#8211; The Fed is expected to slow down its rate hike aggression amid positive inflation data expectations. Moreover, the U.S. consumer sentiment remains strong despite rampant macro headwinds. Amid the broader market sell-off, investor sentiment toward value stocks has improved significantly. Therefore, Investors looking for a good deal might buy quality stocks Microsoft (MSFT) and Taiwan Semiconductor (TSM) for a bargain. Keep reading….</p>
										

										                                    </div>
                                </div>
							                                <div class="row no-margin-top">
                                    <div class="col-lg-12">

                                        <section class="post-meta zero-padding pad-bottom">
											<img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank-square.png" data-src="https://stocknews.com/wp-content/uploads/2021/09/Riddhima-Chakraborty_Headshot_1-200x200.jpg" width="70" height="70" alt="Riddhima Chakraborty" class="avatar avatar-70 wp-user-avatar wp-user-avatar-70 alignnone photo" /><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=riddhima-chakraborty">By Riddhima Chakraborty</a></strong></span><br>											<p style="font-size: 13px; font-weight: 700; color: #777; font-style: normal; display: inline-block;">Dec 13, 2022</a>											                                            <div style="float:right;">                                    <div class="social-wrapper no-margin-bottom no-margin-top">
              <!-- Twitter -->
              <a href="https://twitter.com/intent/tweet?text=%24MSFT+Looking+for+a+Deal%3F+2+Stocks+to+Buy+for+a+Bargain+Right+Now&amp;url=https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target="_blank"><i class="fa fa-twitter"></i></a>
              <!-- Facebook -->
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/" title="Share on Facebook" target="_blank" class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a>
              <!-- Google+ 
              <a href="https://plus.google.com/share?url=https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/" title="Share on Google+" target="_blank" class="sn-social-share btn btn-googleplus"><i class="fa fa-google-plus"></i></a> -->
              <!-- LinkedIn -->
              <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/msft-tsm-looking-for-a-deal-2-stocks-to-buy-for-a/&title=Looking+for+a+Deal%3F+2+Stocks+to+Buy+for+a+Bargain+Right+Now&summary=" title="Share on LinkedIn" target="_blank" class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a>
            </div>
            <script type="lazyload_int" >jQuery(document).ready(function($){jQuery("a.sn-social-share").click(function(){window.open(this.href,'','menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');return false;});});</script></div><br>

                                        </section>

                                    </div>
                                </div></div></div></div></div>
                <div class="col-lg-0 col-md-2"></div>
            </div>
        </header>
        <div class="row">
            <div class="col-lg-12">
                <div style="margin: auto; width: fit-content;">

					                        <div class="text-center" id="stocknews-com-articles-top-banner" style="display:inline;">

                            <script type="lazyload_int" >googletag.cmd.push(function(){googletag.display('stocknews-com-articles-top-banner');});</script>
                        </div>

					                </div>
            </div>
        </div>
    </article>
        <div class="row margin-top">
            <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-8">
                <div class="news-event">

															                </div>




				<div class="post_content" id="articlecontent" style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p><span style="font-weight: 400;">The Fed is expected to keep hiking rates in the coming months to achieve their target inflation of 2%. However, the Fed had indicated a slowdown in the rate hike aggression, and </span><a href="https://www.wsj.com/buyside/personal-finance/fed-rate-hike-december-2022-high-yield-savings-cd-rates-01670868279"><span style="font-weight: 400;">many are now predicting a 50-bps rate hike</span></a><span style="font-weight: 400;"> in December, down from the 75-bps increases seen over the last four launches.</span></p>
<p><span style="font-weight: 400;">Moreover, economists surveyed by Bloomberg </span><a href="https://finance.yahoo.com/news/november-consumer-prices-inflation-data-cpi-december-13-221918648.html"><span style="font-weight: 400;">expect inflation to have slowed again last month</span></a><span style="font-weight: 400;">, projecting headline prices to have risen 0.3% in November and 7.3% over last year.</span></p>
<p><span style="font-weight: 400;">In addition, Bank of America (</span><a href="https://stocknews.com/stock/BAC/"><span style="font-weight: 400;">BAC</span></a><span style="font-weight: 400;">) CEO Brian Moynihan believes that the American </span><a href="https://www.foxbusiness.com/economy/bank-of-america-ceo-predicts-shallow-recession-us-consumer-resilient"><span style="font-weight: 400;">consumer is in “very good shape</span></a><span style="font-weight: 400;">.” Also, the U.S. economy remains resilient despite widespread headwinds. The consumer sentiment index </span><a href="https://markets.businessinsider.com/news/interestrates/u-s-consumer-sentiment-unexpectedly-improves-in-december-inflation-expectations-dip-1031963068"><span style="font-weight: 400;">climbed to 59.1 in December</span></a><span style="font-weight: 400;"> from 56.8 in November, turning out better than consensus estimates.</span></p>
<p><span style="font-weight: 400;">Given this backdrop, quality stocks Microsoft Corporation (</span><a href="https://stocknews.com/stock/MSFT/"><span style="font-weight: 400;">MSFT</span></a><span style="font-weight: 400;">) and Taiwan Semiconductor Manufacturing Company Limited (</span><a href="https://stocknews.com/stock/TSM/"><span style="font-weight: 400;">TSM</span></a><span style="font-weight: 400;">) could be ideal additions to your portfolios. These stocks could be real bargain buys right now.</span></p>
<div class="art-banner-space" id="stocknews-com-articles-4-banner" style="width:100%;min-width:728px;height:90px;text-align:center;"></div><script type="lazyload_int" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[728,90],'stocknews-com-articles-4-banner').setTargeting('pos',['mid4']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});googletag.cmd.push(function(){googletag.display('stocknews-com-articles-4-banner');});</script><p><span style="font-weight: 400;">Value investing has been gaining traction amid the broader market sell-off this year. Investors’ interest in value stocks is evident from the Vanguard Value ETF’s (</span><a href="https://stocknews.com/stock/VTV/"><span style="font-weight: 400;">VTV</span></a><span style="font-weight: 400;">) 5.1% gains over the past six months.</span></p>
<p><b>Microsoft Corporation (</b><a href="https://stocknews.com/stock/MSFT/"><b>MSFT</b></a><b>)</b></p>
<p><span style="font-weight: 400;">MSFT develops, licenses, and supports software, services, devices, and solutions worldwide. The company operates in three segments: Productivity and Business Processes; Intelligent Cloud; and More Personal Computing.</span></p>
<p><span style="font-weight: 400;">On December 12, 2022, MSFT announced </span><a href="https://www.cnbc.com/2022/12/12/microsoft-buys-near-4percent-stake-in-london-stock-exchange-and-launches-10-year-partnership.html"><span style="font-weight: 400;">a decade-long partnership</span></a><span style="font-weight: 400;"> with the London Stock Exchange Group (LSEG) and took approximately a 4% stake in it. LSEG will spend around $2.80 billion on cloud-related products with MSFT. This partnership is expected to be a historic chapter in data analytics, cloud, and Artificial Intelligence in finance.</span></p>
<div class="ftlink" id="ftlink-8" style="text-align:left;height:60px;font-weight:bold; font-size:18px;"><a class="free-report" href="https://report.stocknews.com/free-report/top10stocks/?formplacement=in_article_link_t10">TOP 10 STOCKS FOR THE YEAR AHEAD</a></div><p><span style="font-weight: 400;">In addition, on December 7, 2022, a new Industry Data for Society Partnership was co-launched by MSFT, GitHub, Hewlett Packard Enterprise (</span><a href="https://stocknews.com/stock/HPE/"><span style="font-weight: 400;">HPE</span></a><span style="font-weight: 400;">), LinkedIn, Northumbrian Water Group, R2 Factory, and U.K. Power Networks, a pioneer in cross-industry partnership, to enhance accessible private-sector data for social benefits.</span></p>
<p><span style="font-weight: 400;">MSFT’s forward P/E of 26.45x is 14.1% lower than its five-year average of 30.79x. Its forward Price/Book of 8.89x is 13.9% lower than the five-year average of 10.31x.</span></p>
<p><span style="font-weight: 400;">For its fiscal 2023 first quarter that ended September 30, 2022, MSFT’s total revenue came in at $50.12 billion, up 10.6% year-over-year. Its adjusted net income came in at $17.56 billion, up 2% year-over-year, while its adjusted EPS came in at $2.35, up 3.5% year-over-year. Also, its </span><a href="https://www.investopedia.com/terms/o/operatingincome.asp"><span style="font-weight: 400;">operating income</span></a><span style="font-weight: 400;"> came in at $21.52 billion, up 6.3% year-over-year.</span></p>
<p><span style="font-weight: 400;">Analysts expect MSFT’s revenue to be $212.46 billion in 2023, representing a 7.2% year-over-year rise. The company’s EPS is expected to increase 3.7% year-over-year to $9.55 in 2023. It surpassed EPS estimates in three of four trailing quarters. Over the past month, the stock has gained 2.2% to close the last trading session at $252.51.</span></p>
<div class="art-banner-space" id="stocknews-com-articles-12-banner" style="width:100%;min-width:728px;height:90px;text-align:center;"></div><script type="lazyload_int" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[728,90],'stocknews-com-articles-12-banner').setTargeting('pos',['mid12']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});googletag.cmd.push(function(){googletag.display('stocknews-com-articles-12-banner');});</script><p><span style="font-weight: 400;">MSFT’s </span><a href="https://stocknews.com/powr-ratings/"><span style="font-weight: 400;">POWR Ratings</span></a><span style="font-weight: 400;"> reflect this promising outlook. The stock has an overall B rating, equating to a Buy in our proprietary rating system. The POWR Ratings assess stocks by 118 different factors, each with its own weighting.</span></p>
<p><span style="font-weight: 400;">Also, the stock has a B grade for Stability, Sentiment, and Quality. It is ranked #9 out of 52 stocks in the </span><a href="https://stocknews.com/category/software-business/"><span style="font-weight: 400;">Software – Business</span></a><span style="font-weight: 400;"> industry. Click </span><a href="https://stocknews.com/stock/MSFT/"><span style="font-weight: 400;">here</span></a><span style="font-weight: 400;"> for MSFT’s additional POWR Ratings for Growth, Value, and Momentum.</span></p>
<p><b>Taiwan Semiconductor Manufacturing Company Limited (</b><a href="https://stocknews.com/stock/TSM/"><b>TSM</b></a><b>)</b></p>
<p><span style="font-weight: 400;">Headquartered in Hsinchu City, Taiwan, TSM manufactures, packages, tests, and sells integrated circuits and other semiconductor devices in Taiwan, China, Europe, the Middle East, Africa, Japan, the United States, and internationally.</span></p>
<p><span style="font-weight: 400;">On October 26, 2022, TSM announced the Open Innovation Platform 3DFabric Alliance at the 2022 Open Innovation Platform Ecosystem Forum.</span></p>
<p><span style="font-weight: 400;">Dr. L.C. Lu, TSM’s fellow and vice president of design and technology platform, said, “Through the collective leadership of TSMC and our ecosystem partners, our 3DFabric Alliance offers customers an easy and flexible way to unlock the power of 3D IC in their designs.”</span></p>
<p><span style="font-weight: 400;">TSM’s forward EV/EBITDA of 7.54x is 39.4% lower than the industry average of 12.45x, while its forward Price/Cash Flow of 8.06x is 54.7% lower than the industry average of 17.79x.</span></p>
<p><span style="font-weight: 400;">TSM’s net revenue came in at $20.23 billion for the third quarter that ended September 30, 2022, up 47.9% year-over-year. Its comprehensive income came in at $10.33 billion, up 101% year-over-year, while its EPS came in at $1.79, up 79.8% year-over-year.</span></p>
<p><span style="font-weight: 400;">Street expects TSM’s revenue to increase 31.8% year-over-year to $74.86 billion in 2022. Its EPS is expected to increase 56.6% year-over-year to $6.45 in 2022. It surpassed EPS estimates in all four trailing quarters. Over the past month, the stock has gained 8.9% to close the last trading session at $80.43.</span></p>
<p><span style="font-weight: 400;">TSM has an overall B rating equating to Buy in our POWR Ratings system. It has an A grade for Quality and a B for Growth and Sentiment.</span></p>
<p><span style="font-weight: 400;">It is ranked #12 out of 93 stocks in the </span><a href="https://stocknews.com/category/semiconductor-wireless-chip/"><span style="font-weight: 400;">Semiconductor & Wireless Chip</span></a><span style="font-weight: 400;"> industry. Click </span><a href="https://stocknews.com/stock/TSM/"><span style="font-weight: 400;">here</span></a><span style="font-weight: 400;"> to see the additional POWR Ratings for TSM (Value, Momentum, and Stability).</span></p>
<hr><p>MSFT shares rose $2.61 (+1.03%) in premarket trading Tuesday. Year-to-date, MSFT has declined -24.22%, versus a -15.03% rise in the benchmark S&P 500 index during the same period.</p></body></html>
                <div id ='stocknews-com-articles-bottom-mnetrplc' style="height: 90px; width: 728px;"></div>
                <script type="lazyload_int" async="" defer="defer" >window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/21771534901/stocknews.com//articles',[728,90],'stocknews-com-articles-bottom-mnetrplc').setTargeting('pos',['bot2']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().enableLazyLoad({fetchMarginPercent:500,renderMarginPercent:200,mobileScaling:2.0});googletag.enableServices();});googletag.cmd.push(function(){googletag.display('stocknews-com-articles-bottom-mnetrplc');})</script>
                <div id=""></div>
							<div style="clear:both;"></div><br><h2>About the Author: Riddhima Chakraborty</h2><br><img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank-p.png" data-src='https://stocknews.com/wp-content/uploads/2021/09/Riddhima-Chakraborty_Headshot_1.jpg' style="float:left; padding:5px;width:125px;"  width="125px"  height="109px"><p>Riddhima is a financial journalist with a passion for analyzing financial instruments. With a <a href="https://www.linkedin.com/in/riddhima-chakraborty-24589b19a/"> master's degree in economics</a>, she helps investors make informed investment decisions through her insightful commentaries. <a href="https://stocknews.com/authors/?author=riddhima-chakraborty">More...</a></p><br><div style="clear:both;"></div><h2>More Resources for the Stocks in this Article</h2>
<table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;" >
<tr style="background-color:#5cb85c; color:white;">
    <td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/MSFT/">MSFT</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/TSM/">TSM</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr></table></div></div>                <div align="center" class="margin-top"></div>
            </div>
            <div class="col-lg-2 col-md-2"></div><!-- end of column -->





        </div>
        <!--   <div style="width:100%; padding:5px;">
	                <div id ='stocknews-com-articles-mnetrplc' style="height: 90px; width: 728px;"></div>
              <script async defer>
                  window.googletag = window.googletag || {cmd: []};
                  googletag.cmd.push(function() {
                      googletag.defineSlot('/21771534901/stocknews.com//articles', [728,90], 'stocknews-com-articles-mnetrplc').addService(googletag.pubads());
                      googletag.pubads().enableSingleRequest();
                      googletag.enableServices();
                  });
                  googletag.cmd.push(function() { googletag.display('stocknews-com-articles-mnetrplc'); })
              </script>
		    </div>-->




        <div class="row margin-top">
            <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-10">
                <div id="ent-wid"> <div id="stocknews-com-articles-entrplc"></div></div>

                <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-articles-entrplc');});googletag.cmd.push(function(){googletag.display('stocknews-com-articles-top-banner');});</script>
                <h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Most Popular Stories on StockNews.com</strong></h2>
				





			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-dia-iwm-qqq-2023-stock-market-outlook/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2022/04/buy-sell-scaled.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="200px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-dia-iwm-qqq-2023-stock-market-outlook/" class="black">2023 Stock Market Outlook</a>
				  				</h3>
				40 year investment veteran Steve Reitmeister shares his most complete and up to the minute analysis of what lies ahead in 2023. First a return of the bear market with the S&P 500 (SPY) making news lows. Yet just at the darkest hour the new bull market will emerge ushering in tremendous gains to investors who time it right. Steve shares his trading plan along with top 8 picks to profit on the way to bear market bottom. Next he shares a plan to buy the market bottom with 2 top picks set to rally 100%+. Get the full story below....				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Dec 10, 2022</a> <span class="light-gray">|</span> 7:00am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>





						<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/afrm-cano-ffie-3-terrible-stocks-you-need-to-sell-before-2023/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2021/04/shutterstock_309326384-scaled.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="240px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/afrm-cano-ffie-3-terrible-stocks-you-need-to-sell-before-2023/" class="black">3 Terrible Stocks You Need to Sell Before 2023</a>
				  				</h3>
				The prevailing high inflation and continued interest rate hikes triggered fears of a recession and dampened investor sentiment. Amid such uncertainties, it could be wise to steer clear of fundamentally weak stocks Affirm Holdings (AFRM), Cano Health (CANO), and Faraday Future Intelligent Electric (FFIE). Continue reading…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Dec 9, 2022</a> <span class="light-gray">|</span> 2:55pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>











			  <div style="width:100%; padding:5px;">
	                <div id ='stocknews-com-mnetrplc' style="width: 728px;"></div>
              <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-mnetrplc');})</script>

		    </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/dis-amcx-1-risky-stock-you-might-not-want-to-touch-right/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2017/05/disneyland.jpg" alt=":  |  News, Ratings, and Charts"  width="300px"  height="188px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/dis-amcx-1-risky-stock-you-might-not-want-to-touch-right/" class="black">1 Risky Stock You Might Not Want to Touch Right Now</a>
				  				</h3>
				Amid a sudden change at the helm and challenged by losses in its streaming business, Disney (DIS) has a lot of near-term uncertainties to deal with. Let’s discuss why the stock might be best avoided now. Read on…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Dec 12, 2022</a> <span class="light-gray">|</span> 7:26am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>









			  <div style="width:100%; padding:5px;">
	                <div id ='stocknews-com-mnetrplc' style="width: 728px;"></div>
              <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-mnetrplc');})</script>

		    </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/sq-lcid-roku-3-popular-stocks-investors-have-been-busy-selling-short/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2022/06/shutterstock_639493822-1-scaled.jpg" alt=":  |  News, Ratings, and Charts" width="300px"  height="201px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/sq-lcid-roku-3-popular-stocks-investors-have-been-busy-selling-short/" class="black">3 Popular Stocks Investors Have Been Busy Selling Short</a>
				  				</h3>
				Stronger-than-expected jobs data might lead to the Fed lifting rates higher than investors expect. Increased recessionary fears have sparked a market sell-off lately. Given a highly uncertain market backdrop, we think it could be wise to avoid fundamentally weak popular stocks Block (SQ), Roku (ROKU), and Lucid (LCID), which investors have been recently selling short. Keep reading…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Dec 12, 2022</a> <span class="light-gray">|</span> 7:46am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>







			  <div style="width:100%; padding:5px;">
	                <div id ='stocknews-com-mnetrplc' style="width: 728px;"></div>
              <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-mnetrplc');})</script>

		    </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/dis-amcx-1-risky-stock-you-might-not-want-to-touch-right/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.png" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2017/05/disneyland.jpg" alt=":  |  News, Ratings, and Charts" width="300px"  height="188px"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/dis-amcx-1-risky-stock-you-might-not-want-to-touch-right/" class="black">1 Risky Stock You Might Not Want to Touch Right Now</a>
				  				</h3>
				Amid a sudden change at the helm and challenged by losses in its streaming business, Disney (DIS) has a lot of near-term uncertainties to deal with. Let’s discuss why the stock might be best avoided now. Read on…				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Dec 12, 2022</a> <span class="light-gray">|</span> 7:26am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>

  <div style="width:100%; padding:5px;">
	                <div id ='stocknews-com-mnetrplc' style="width: 728px;"></div>
              <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-mnetrplc');})</script>

		    </div>

                <h3>
                    <a href="/top-stories/" class="btn btn-default width-full margin-top-less" role="button">Read More Stories</a>
                </h3>
                <div align="center"><script async="" defer="defer" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="lazyload_ext" ></script>
                    <!-- Bottom Article Banner Ad (4) -->
                    <ins class="adsbygoogle"
                         style="display:block"
                         data-ad-client="ca-pub-6654551967172224"
                         data-ad-slot="1071597498"
                         data-ad-format="auto"
                         data-full-width-responsive="true"></ins>
                    <script type="lazyload_int" async="" defer="defer" >(adsbygoogle=window.adsbygoogle||[]).push({});</script></div>

            </div>
        </div>



        <div class="row margin-top">
	        <div class="col-lg-0 col-md-2"></div>
            <div class="col-lg-8 col-md-10"><div class="col-lg-12">
                <h3>
                    More Microsoft Corp. (MSFT) News
                    <a href="/stock/MSFT/news/" class="btn btn-default" role="button">View All</a>
                </h3>
                <div class="panel panel-default">
                    <table class="table-condensed table table-striped news mobile-card-view" id="news-stream">
                        <thead>
                        <tr>
                            <th>Event/Date</th>
                            <th>Symbol</th>
                            <th>News Detail</th>
                            <th class="text-right" nowrap>Start Price</th>
                            <th class="text-right" nowrap>End Price</th>
                            <th nowrap>Change</th>
                            <th>POWR Rating</th>
                        </tr>
                        </thead>
                        <tbody>
                        <tr><td colspan="10" class="text-center">Loading, please wait...</td></tr>
                        </tbody>
                    </table>
                </div>
                <a href="/stock/MSFT/" class="btn btn-default width-full margin-top-less">View All MSFT News</a>
            </div></div>
        </div><!-- end of row -->


</div>



<div align="center">

	<div id='stocknews-com-articles-bottom'>
  <script type="lazyload_int" async="" defer="defer" >googletag.cmd.push(function(){googletag.display('stocknews-com-articles-bottom');});</script>
</div>


</div>

<style>
    .mobileShow {
        display: none;
    }

    /* full width of parent */
    .mobileShow img{
        width: 100%;
    }

    /* Smartphone Portrait and Landscape */
    @media only screen and (min-device-width: 320px) and (max-device-width: 480px) {
        .mobileShow {
            /*position: fixed; bottom: 0;z-index: 111;display:block;left:10%;padding-bottom:12px;*/
            max-width:320px;
            width:90%;
            position: fixed;
            bottom:0;
            z-index:111;
            display:block;
            left:0;
            padding-bottom:12px;
            right:0;
            margin:0 auto;

        }
    }
    .close_btn::before
    {
        content: '✖';
        color: #000;
        font-weight: 600;
        font-family: Arial, sans-serif;
        float:right;
        opacity: 0.5;
        font-size:10px;
    }
</style>




<!-- end of content -->



<script type="lazyload_int" >jQuery(document).ready(function($){function symbol_get_snippets(symbol){$.getJSON('https://stocknews.com/wp-content/themes/strappress-child/includes/snippet-json.php?symbol=MSFT&limit=10&historical_prices=1',function(json){$("table#news-stream tbody").html("");var tr=[];for(var i=0;i<json.results.length;i++){if((json.results[i].top_story_headline!="")&&(json.results[i].top_story_headline!=null)){var headline=json.results[i].top_story_headline;}else{var headline=json.results[i].notes;}
tr.push('<tr>');tr.push('<td class="bullorbear-'+json.results[i].bull_or_bear+'a"><strong>'+json.results[i].event_short+'</strong><br><span class="medium-gray">'+json.results[i].snippet_time+'</span></div>');tr.push('<td><strong><a href="/stock/'+json.results[i].symbol+'/">'+json.results[i].symbol+'</strong></td>');tr.push('<td><span class="dark-gray"><a href="https://stocknews.com/news/'+json.results[i].post_slug+'">'+headline+'</a></span></td>');tr.push('<td class="text-right">'+json.results[i].price_when_added+'</td>');tr.push('<td class="text-right grade-'+json.results[i].day_change_color+'">'+json.results[i].day_close+'</td>');tr.push('<td class="grade-'+json.results[i].day_change_color+'">'+json.results[i].day_change+'<br>'+json.results[i].day_pct_change+'</td>');tr.push('<td class="text-center grade-'+json.results[i].powr_grade_color+'"><strong>'+json.results[i].powr_grade+'</strong></td>');tr.push('</tr>');}
$(tr.join('')).appendTo($('table#news-stream tbody')).slideDown("slow");});}
symbol_get_snippets('MSFT');});jQuery(function($){jQuery(document).ready(function(){$('.post_content').find('a[href^="http"]').not('a[href*=stocknews]').attr('target','_blank');console.log('sn_user_logged_in'," | ");var tickerPos,ratingReplace="";var stockData={"replace_stocks":[{"stock":"MSFT"},{"stock":"TSM"}]};for(tickerPos in stockData.replace_stocks){ratingReplace='(<strong><a href="https://stocknews.com/stock/'+stockData.replace_stocks[tickerPos].stock+'">'+stockData.replace_stocks[tickerPos].stock+'</a></strong> - <a href="https://report.stocknews.com/sign-up/getratings?ticker='+stockData.replace_stocks[tickerPos].stock+'" style="color:green; font-style:italic;">Get Rating</a>)'
replaceTickers(tickerPos,stockData,ratingReplace);}});function replaceTickers(tickerPos,stockData,ratingReplace){let stockTicker=stockData.replace_stocks[tickerPos].stock;let regexTicker=new RegExp('\\(([^)]+)(\\b'+stockTicker+'\\b)([^)]+)\\)','g')
let str=document.getElementById("articlecontent").innerHTML;let res=str.replace(regexTicker,ratingReplace);document.getElementById("articlecontent").innerHTML=res;console.log(stockTicker);}});</script>


        

</div><!-- end of wrapper-->


</div><!-- end of container -->

<footer id="footer" class="clearfix">
  <div class="container">
    <hr>
    <div id="footer-wrapper">
      <div class="row margin-bottom">
        <div class="col-lg-6">
          ©2022 StockNews.com                </div><!-- end column -->
                          <div class="col-lg-6 text-right">
                <a href="/about/">About Us</a> | <a href="/contact/">Contact Us</a> | <a href="/performance/">Performance</a>
                |<a href="/privacy/">Privacy Policy</a> | <a href="/legal/">Terms of Use</a>
            </div>
              </div><!-- end row -->
            <div class="row">
        <div class="col-lg-6">
          <p><small>Copyright © 2022. Market data provided is at least 10-minutes delayed and hosted by <a href="https://www.barchart.com/solutions" target="_blank">Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href="http://www.barchart.com/solutions/company/terms-and-privacy">disclaimer</a>.</small></p>
        </div>
        <div class="col-lg-6"
          <p><small>Automated Insights by <a href="https://sixjupiter.com"  target="_blank">SixJupiter</a>.
          <br><br>
          <em>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" rel="nofollow">Privacy Policy</a> and <a href="https://policies.google.com/terms" rel="nofollow">Terms of Service</a> apply.</em></small>
          </p>
        </div>
      </div>
          </div><!-- end #footer-wrapper -->
  </div> <!-- end container -->
</footer><!-- end #footer -->


<script>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/c0cdb36ce3889b88d10e5a9feb70ef4d.js"></script>
<script type="lazyload_ext" src="https://www.google.com/recaptcha/api.js?render=6LcSLq8UAAAAADO3HTWuB2LvCuMip3r9ZcPMAZF9" ></script>
<script>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcSLq8UAAAAADO3HTWuB2LvCuMip3r9ZcPMAZF9","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/1a9fe5cbb314c1c5dab91329fe38f019.js"></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/517cc6100c7ef58db32e5b56eda1eecb.js"></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/0f89cdbddb63b5e0832b54787c9bc205.js"></script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/7693550e6aecc8a67c39c8d4da25519a.js"></script>

<!-- AST – IMS - [StockNews_PopUp] -->
<div id="StockNews_PopUp_PopUp" class="text-center">
  <!--<script type="text/javascript">
  apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });
  </script>-->
</div>
<!-- End AST – IMS - [StockNews_PopUp] -->


<!-- Push Monkey code  -->



<!-- sn media net script -->



<!-- sn media net script -->

<!-- pardot script -->
<script type="lazyload_ext" >piAId='890453';piCId='1072';piHostname='pi.pardot.com';(function(){function async_load(){var s=document.createElement('script');s.type='text/javascript';s.src=('https:'==document.location.protocol?'https://pi':'http://cdn')+'.pardot.com/pd.js';var c=document.getElementsByTagName('script')[0];c.parentNode.insertBefore(s,c);}
if(window.attachEvent){window.attachEvent('onload',async_load);}
else{window.addEventListener('load',async_load,false);}})();</script>

<span></span>

<!-- pardot script -->
<div class="mobileShow" id="mobileShow">
	<span class="close_btn" onclick="document.getElementById('mobileShow').style.display='none'"></span>



</div>
<script type="lazyload_int" >var $=jQuery;$(function(){$globFAllow=false;console.log('fs');$('form[class=infusion-form]').on('submit',function(e){console.log(e)
if($globFAllow){}else{e.preventDefault();}
$email=$(this).find("input[type='email']").val();if($email==undefined){$email=$(this).find("#email").val();}
$form=$(this)
var xhr=new XMLHttpRequest();xhr.onload=function(){$tst=JSON.parse(this.responseText)[0];console.log(this.responseText);if($tst=='true')
{$globFAllow=true;e.currentTarget.submit();return true;}
else{$form.append("</br><span style='color: #ff0000'>"+$tst+"</span>");$globFAllow=false;return false;}
if($form.attr("id")=="home"||$form.attr("id")=="free-ns-form")
{grecaptcha.reset();}};var data=new FormData();data.append("email",$email);if($form.attr("id")=="home")
{data.append("f-id","home");data.append("g-recaptcha-response",grecaptcha.getResponse(1));}else if($form.attr("id")=="free-ns-form"){data.append("f-id","free-ns-form");data.append("g-recaptcha-response",grecaptcha.getResponse(0));}else{data.append("f-id","none");}
xhr.open("POST","https://stocknews.com/v/index_tst.php?",true);xhr.send(data);});});</script>
<script type="lazyload_int" src="https://stocknews.com/wp-content/cache/w3-cache/all-js/a2cee1f6424a231d898cd316bf0885bd.js"></script><script>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</script></body>
</html>