<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
	
<!--Session Page view:  -->
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="google-site-verification" content="DaNWVY0maeaUOhfiAFFy8wvW4ukJs_U0JDO8am8J-ps" />

<title>VZ: 3 "Strong Buy" Dow Jones Dividend Stocks Yielding 3%</title>
<!--| StockNews.com-->
<link rel="icon" type="image/png" href="" />

<link rel='dns-prefetch' href='//www.google.com' />
<meta property="og:title" content="VZ: 3 "Strong Buy" Dow Jones Dividend Stocks Yielding 3% | StockNews.com"/>
<meta property="og:description" content="While stocks in the Dow Jones Industrial Average have not kept up with tech stocks, there are company's set to benefit from ongoing trends. Here are three strong companies yielding over 3%: Verizon Communications (VZ), Pfizer (PFE), and 3M Company (MMM)."/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/"/>
<meta property="og:site_name" content="StockNews.com"/>
<meta property="og:image" content="https://stocknews.com/wp-content/uploads/2020/09/vz-pfe-mmm-scaled.jpg"/>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="VZ: 3 "Strong Buy" Dow Jones Dividend Stocks Yielding 3% | StockNews.com">
<meta name="description" content="Verizon Communications Inc.(NYSE:VZ): While stocks in the Dow Jones Industrial Average have not kept up with tech stocks, there are company's set to benefit from ongoing trends. Here are three strong companies yielding over 3%: Verizon Communications (VZ), Pfizer (PFE), and 3M Company (MMM)."/>
<meta name="keywords" content="NYSE:VZ, Verizon Communications Inc. , Telecom - Domestic, Commentary"/>
<script type="application/ld+json">
{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/"
 },
 "headline": "3 \"Strong Buy\" Dow Jones Dividend Stocks Yielding 3%",
  "image": {
    "@type": "ImageObject",
    "url": "https://stocknews.com/wp-content/uploads/2020/09/vz-pfe-mmm-scaled.jpg" },
  "datePublished": "2020-09-02T13:40:35-04:00",
 "dateModified": "",
 "author": {
    "@type": "Person",
    "name": "StockNews.com Staff"
 },
  "publisher": {
    "@type": "Organization",
    "name": "StockNews.com",
    "logo": {
        "@type": "ImageObject",
        "url": "https://stocknews.com/img/sn-green.png"
    }
 },
 "description": "Verizon Communications Inc.(NYSE:VZ) While stocks in the Dow Jones Industrial Average have not kept up with tech stocks, there are company's set to benefit from ongoing trends. Here are three strong companies yielding over 3%: Verizon Communications (VZ), Pfizer (PFE), and 3M Company (MMM)."
}
</script>
<link rel="canonical" href="https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/"/>








<script src="https://stocknews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp" ></script>

<script src="https://stocknews.com/wp-content/themes/strappress/js/responsive-modernizr.js?ver=2.5.3" ></script>


<link rel='https://api.w.org/' href='https://stocknews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stocknews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstocknews.com%2Fsingle-snippet-page%2F&#038;format=xml" />
    <script type="lazyload">
    // <![CDATA[
    jQuery(document).ready(function($){
        $("a[rel='magnific']").magnificPopup({
                type:'image'
        });
    });  
    // ]]>
    </script>
		<link rel="stylesheet" href="https://stocknews.com/wp-content/cache/wnw-cache/all-css/a026065a76006abb1ab9c24891727dd2.css" /><style id="wp-custom-css">
			@media (max-width:1199px) and (min-width:992px) {
    .responsive_head_fix {
        margin-top: 65px;
    }
}		</style>
		 


<!-- Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="https://stocknews.com/wp-content/themes/strappress/js/respond.min.js"></script>
<![endif]-->



<!--
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script>
-->







<!--
<script src="//ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script>
-->








<script type="lazyload"data-cfasync="false">
  jQuery(document).ready(function($){
    $('a.sn_pop').on('click', function(e) {e.preventDefault(); return true;});
    $( ".ticker-search" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $( ".ticker-search-big" ).autocomplete({
      source: '//stocknews.com/wp-content/themes/strappress-child/autocomplete-search.php',
      minLength: 1,
      focus: function( event, ui ) {
        $( ".ticker-search" ).val( ui.item.label );
        return false;
      },
      select: function (event, ui) {
            window.location = "/stock/"+ui.item.value+"/";
        }
    })
    .autocomplete( "instance" )._renderItem = function( ul, item ) {
      return $( "<li>" )
        .append( '<a href="/stock/'+item.value+'/"><strong class="sixteen">' + item.label + '</strong><br><span class="medium-gray">' + item.desc + '</span></a>' )
        .appendTo( ul );
    };
    $('[data-toggle="popover"]').popover({html: true, trigger: 'focus'});
  });
</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64545224-1', 'auto');
  ga('send', 'pageview');
</script>







<!-- Google Tag Manager -->
<script type="lazyload"async="">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MR8XMKP');</script>
<!-- End Google Tag Manager -->






<!-- google ads 072120 -->
    <script defer="defer" data-ad-client="ca-pub-6654551967172224" async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" ></script>



</head>

<body class="page-template page-template-single-snippet-page page-template-single-snippet-page-php page page-id-78">
	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MR8XMKP"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
                 

         
        <header>
   
    

<div style="background:#333;"  class="headerstick">
<div class="container">
<div id="logo" class="hidden-sm hidden-xs"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
    <img src="/img/sn-green.png" alt="StockNews.com" style="width:360px;height:auto" />
</a></div>


<nav class="navbar-collapse collapse navbar-responsive-collapse">
  
<ul class="nav navbar-bav navbar-right">
    <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
  </ul>

<form class="navbar-form navbar-right" role="search" method="post" id="searchform" action="https://stocknews.com/">
  <div class="input-group">
    <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" autocomplete="off" size="17"> 
    <div class="input-group-btn">
      <button type="submit" class="btn btn-success">Search</button>
    </div>
  </div>
  <input type="hidden" id="symbol_search" name="symbol_search" value="f37db9c3fe" /><input type="hidden" name="_wp_http_referer" value="/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/" /></form>
  
</nav>

<nav class="navbar navbar-inverse navbar-static-top navbar-lower sm-margin-top" style="background:#222;border-radius:5px 5px 0 0">
  <div class="container-fluid">

    <div class="navbar-header">
      <div class="hidden-lg hidden-md sm-logo" style="float:left; padding-top:10px"><a href="https://stocknews.com/" title="StockNews.com" rel="home">
        <img src="/img/sn-green.png" style="width:220px;height:auto" alt="StockNews.com" />
    </a></div>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-bars" style="color:#fff !important;"></span>
      </button>
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-search" aria-expanded="false"> <span class="sr-only">Toggle navigation</span>
        <span class="fa fa-search" style="color: #fff !important;"></span>
      </button>
    </div>

    <div class="collapse navbar-collapse" id="navbar">
      <ul id="menu-top-nav" class="nav navbar-nav">
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            News<span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/top-stories/">
                Top Stories
              </a>
            </li>
                       
             <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/video-news/">
                Video News
              </a>
            </li>
            <!--<li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/featured-articles/">
                Featured Articles
              </a>
            </li>-->
          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Best Stocks<span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/best-stocks/">
                "A" Rated Stocks
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/powr-upgrades-downgrades/">
                Upgrades/Downgrades
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/high-yield-dividend-stocks/">
                High Yield Dividend Stocks
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stock-screener/">
                Stock Screener
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="/top-dividend-discount-model/">
                      Dividend Discount Model Stock Valuation
                  </a>
              </li>
             <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stocks/">
                Industry Rank
              </a>
            </li>
          <!--  <li class="divider"></li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/powr-ratings/">
                POWR Ratings&trade;
              </a>
            </li> -->
            
          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Best ETFs <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/best-etfs/">
                "A" Rated ETFs
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/etfs/">
                Best ETF Categories
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/high-yield-etfs/">
                High Yield ETFs
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="https://report.stocknews.com/7-best-etfs-for-the-next-bull-market/?lead_source=sn-best_etfs_menu&medium=spons-txt&campaign=7etfs">
                      7 Best ETFs
                  </a>
              </li>
          </ul>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/powr-ratings/">
            POWR Ratings&trade;
          </a>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/powr-upgrades-downgrades/">
            Upgrades/Downgrades<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
          </a>
        </li>
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/watchlist/">
            Watchlist<!--<span class="hidden-md"> <span class="badge">New</span></span>-->
          </a>
        </li>
        
        <li class="menu-item menu-item-type-custom menu-item-object-custom">
          <a href="/stock-screener/">
            Screener
          </a>
        </li>
         <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a class="dropdown-toggle" aria-expanded="false">
            Services <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com" target="_blank">
                Services Home
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com/reitmeister-total-return/" target="_blank">
                Reitmeister Total Return
              </a>
            </li>
              <li class="menu-item menu-item-type-custom menu-item-object-custom">
                  <a href="https://members.stocknews.com/powr-charts/" target="_blank">
                      POWR Charts
                  </a>
              </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://members.stocknews.com/service/powr-trends/" target="_blank">
                POWR Trends
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="https://stocknews.com/powr-ratings/" target="_blank">
                Premium
              </a>
            </li>
          
          </ul>
        
        
        <!--
        <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">
          <a href="/screeners/" class="dropdown-toggle" data-toggle="dropdown" aria-expanded="false">
            Screeners <span class="caret"></span>
          </a>
          <ul class="dropdown-menu">
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/stock-screener/">
                Stock Screener
              </a>
            </li>
            <li class="menu-item menu-item-type-custom menu-item-object-custom">
              <a href="/etf-screener/">
                ETF Screener
              </a>
            </li>
          </ul>
        </li>
        -->
      </ul>
      <ul class="nav navbar-nav hidden-lg hidden-md">
                 <li class="menu-item menu-item-type-custom menu-item-object-custom">
    <p class="navbar-btn"><a href="https://stocknews.com/members/login" class="btn btn-warning">Login</a> <a href="https://stocknews.com/registration/free/" class="btn btn-warning">
        Join
      </a>
    </p>
  </li>
              </ul>
    </div>
    <div class="collapse navbar-collapse" id="navbar-search"> <form class="navbar-form hidden-lg hidden-md" role="search" method="post" id="searchform2" action="https://stocknews.com/">
          <div class="input-group">
            <input name="ticker" id="ticker" type="text" class="form-control ticker-search" placeholder="Ticker or Company" autocomplete="off" size="17"> 
            <div class="input-group-btn">
              <button type="submit" class="btn btn-success">Search</button>
            </div>
          </div>
         <input type="hidden" id="symbol_search" name="symbol_search" value="f37db9c3fe" /><input type="hidden" name="_wp_http_referer" value="/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/" />      </form></div>
  </div>
</nav>
</div>
</div>

    <!--nada -->


</header><!-- end of header -->


<br><br><br><br>
  <!--  <div class="text-center center-block" style="background-color:#f0f0f0; padding-bottom:5px; min-height:130px; text-align:center !important; padding-top:110px;"> -->
 <!-- <div id="StockNews_ROS_Top_Leaderboard" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Top_Leaderboard');
    });
    </script>
</div>
 -->
</div> 



    
<div class="container">
  <div class="clearfix wrapper">

    
  <div id="content">
    <article>
      <header>

      
        <div class="row margin-top">
          <div class="col-lg-0 col-md-2"></div>
          <div class="col-lg-8 col-md-8">
            <div class="news-event">

                  <h1 class="page-title no-pad-left big-margin-bottom bold">
                3 "Strong Buy" Dow Jones Dividend Stocks Yielding 3%</h1>
                            <h1 class="page-title no-pad-left big-margin-bottom bold">
                              </h1>
              <div class="text-center">
   <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div> -->
  </div>
              
              
              <div class="row margin-top">
                <div class="col-lg-12 text-center">
               <!--   <div id="StockNews_ROS_Textlink" class="text-center">
    <script>
    apntag.anq.push(function() {
        apntag.showTag('StockNews_ROS_Textlink');
    });
    </script>
</div>
 -->
                </div>
              </div>

              <div><div class="panel-body" style="padding: 0px !important;">

                                  <div class="row">
                    <div class="col-lg-12" style="max-height:550px; overflow:hidden;">
                      <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=50,onerror=redirect,height=540/https://stocknews.com/wp-content/uploads/2020/09/vz-pfe-mmm-scaled.jpg" alt="NYSE: VZ | Verizon Communications Inc.  News, Ratings, and Charts" style="margin:auto; display:block; max-height: 550px;">
                    </div>

                    <div class="col-lg-12 col-md-8">
                       <p><strong><a href="/stock/VZ/">VZ</a></strong> &#8211; While stocks in the Dow Jones Industrial Average have not kept up with tech stocks, there are company&#8217;s set to benefit from ongoing trends. Here are three strong companies yielding over 3%: Verizon Communications (VZ), Pfizer (PFE), and 3M Company (MMM).</p>
                

                                    </div>
                  </div>
                                <div class="row no-margin-top">
                  <div class="col-lg-12">

                    <section class="post-meta zero-padding pad-bottom">
                     <img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src='https://stocknews.com/wp-content/w3-webp/uploads/2020/08/sidharath.jpgw3.webp' style="float:left; padding:5px;width:80px;" class="author-meta-image"><span class="post-meta zero-padding pad-bottom author-meta"><strong><a href="https://stocknews.com/authors/?author=sidharath-gupta">By Sidharath Gupta</a></strong></span><br>                  <a href="">Sep 2, 2020</a>                                    <div style="float:right;">                                    <div class="social-wrapper no-margin-bottom no-margin-top">
              <!-- Twitter -->
              <a href="https://twitter.com/intent/tweet?text=%24VZ+3+%22Strong+Buy%22+Dow+Jones+Dividend+Stocks+Yielding+3%25&amp;url=https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/&amp;via=stocknewsdotcom" title="Share on Twitter" class="sn-social-share btn btn-twitter" target="_blank"><i class="fa fa-twitter"></i></a>
              <!-- Facebook -->
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/" title="Share on Facebook" target="_blank" class="sn-social-share btn btn-facebook"><i class="fa fa-facebook"></i></a>
              <!-- Google+ 
              <a href="https://plus.google.com/share?url=https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/" title="Share on Google+" target="_blank" class="sn-social-share btn btn-googleplus"><i class="fa fa-google-plus"></i></a> -->
              <!-- LinkedIn -->
              <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://stocknews.com/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/&title=3+%22Strong+Buy%22+Dow+Jones+Dividend+Stocks+Yielding+3%25&summary=" title="Share on LinkedIn" target="_blank" class="sn-social-share btn btn-linkedin"><i class="fa fa-linkedin"></i></a>
            </div>
            <script type="lazyload">
              jQuery(document).ready(function($){
                jQuery("a.sn-social-share").click(function() {
                  window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');
                  return false;
                });
              });
            </script></div><br>

                </section>

                  </div>
                </div></div></div></div></div>
            <div class="col-lg-0 col-md-2"></div>
        </div>
      </header>
          <div class="row">
              <div class="col-lg-12">
                  <div style="margin: auto; width: fit-content;">
                        <div id="StockNews_ROS_Top_Leaderboard"></div>
                  </div>
              </div>
          </div>

          <div class="row margin-top">
              <div class="col-lg-0 col-md-2"></div>
              <div class="col-lg-8 col-md-8">
                  <div class="news-event">

                                                      </div>




            <div class="right-margin-ad" style="position: absolute; right:-210px; top:20%"><div style="width:200px !important;"><div class="panel panel-default"> <div class="panel-heading"> <h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3> </div><div class="panel-body"> <form role="form" action="/v/" method="GET" class="form-inline"> <p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p><input name="tag_id" type="hidden" value="193"><input name="redirect_url" type="hidden" value="https://stocknews.com/registration/"> <div class="input-group" style="display: block !important;"> <input class="form-control" type="email" name="email" value="" placeholder="Your Email Address..." id="email" style="font-size:13px !important;"> <div align="center"><span class="input-group-btn"> <button style="background-color:#ffa200;-moz-border-radius:5px;-webkit-border-radius:5px;border-radius:5px;border:1px solid #92a394;display:inline-block;cursor:pointer;color:#ffffff;font-family:Arial;font-size:17px;padding: 5px 44px;text-decoration:none;text-shadow:0px 1px 0px #556353;margin-top: 5px;" type="submit">Subscribe</button> </span></div></div></form> <script data-src="https://sk687.infusionsoft.app/app/webTracking/getTrackingCode" ></script><script data-src="https://sk687.infusionsoft.com/app/timezone/timezoneInputJs?xid=b8eca134cbe7a3685442b13f285af63c" ></script></div></div></div></div><div class="post_content" id="articlecontent" style="Open Sans, sans-serif !important; font-size:19px !important;"><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>The Dow Jones Industrial Average (DJIA) is a price-weighted index that constitutes 30 blue-chip companies in the United States. While the stocks in the index have a long track record of outperformance, the overall index is underperforming the other major indexes — the S&P 500 and the Nasdaq Composite — so far this year.</p>
<p>The DJIA’s almost flat year-to-date return compares to the Nasdaq Composite’s 31.2% return and the S&P 500’s 8.7% gain. The skyrocketing performance of some of the tech stocks have helped the S&P 500 and Nasdaq hit record highs in August. But the DJIA components, primarily major industrial and financial stocks, haven’t generated the same interest, as these industries have not capitalized on the pandemic as some of the major tech players.</p>
<p>However, the DJIA has displayed a solid recovery since the market crash in mid-March and is close to showing a positive return year-to-date. If you want to benefit from the index’s revival, there are a number of stocks to choose from based on fundamental strength. But given the predictions of continued market and economic uncertainties, it would be a good idea to consider stocks that offer solid dividend income along with strong fundamentals. If the index fails to continue its recovery, then dividend stocks can at least help you generate a steady income.   Verizon Communications Inc. (<a href="https://stocknews.com/stock/VZ/">VZ</a>), Pfizer, Inc. (<a href="https://stocknews.com/stock/PFE/">PFE</a>), and 3M Company (<a href="https://stocknews.com/stock/MMM/">MMM</a>) are three high dividend-paying DJIA stocks with solid  fundamentals.</p>
<div><div style="border-top:1px solid #eee; margin-top:10px; border-bottom:1px solid #eee; margin-bottom:10px;"><br><p style="text-align:center; font-family: arial; font-size:25px; font-weight:bold;"><a href="https://report.stocknews.com/7-safe-haven-dividend-stocks/?lead_source=sn-below_article&medium=spons-img&campaign=7shds" target="_blank">7 <em>"SAFE HAVEN"</em> Dividend Stocks for Turbulent Times</a></p></div></div><p><strong>Verizon Communications Inc. <a href="https://stocknews.com/stock/VZ/">(VZ)</a></strong></p>
<p>VZ provides communications, information and entertainment products and services to consumers, businesses, and governmental agencies. Its segments include Wireless and Wireline. The company pays an annual dividend of $2.46, which yields 4.14%. It has a four-year average dividend yield of 4.67%. The company has been consistently increasing its dividend payout amount after its third quarter each year and has been uniformly paying quarterly dividends since becoming a public company in 1983. Over the past 10 years, the average dividend per share growth rate for VZ has been 3.4% per year. The most recent dividend declared by VZ was $0.615 for its second quarter that ended in June 2020.</p>
<p>VZ generated a free cash flow of $10.2 billion in its last reported quarter, registering a 100.8% growth from the comparable quarter last year. The company also generated $14.7 billion cash flow from operating activities during the quarter, accounting for a 68% rise year-over-year. Revenue for the quarter increased 0.8% year-over-year to $132 billion, while net income grew 7.7% year-over-year to $19.3 billion.</p>
<div class="text-center" id="StockNews_ROS_RightRail_1" style="padding-right:20px"></div><p>EPS for the quarter came in at $1.18, beating the consensus estimate by 2.6%. This also indicates a year-over-year increase of 19%. Moreover, with the next-gen B2B application and growing subscriber loyalty, the street expects EPS to grow 3.4% next year. The stock closed yesterday’s trading session at $59.16. It has already recovered more than 17.6% from its March low.</p>
<p>How does VZ stack up for the<a href="https://stocknews.com/stock/VZ/"> POWR Ratings</a>?</p>
<p>A for Trade Grade</p>
<div class="text-center" id="StockNews_ROS_Intext_Leaderboard" style="margin-bottom:6px"></div><p>A for Buy & Hold Grade</p>
<p>A for Peer Grade</p>
<p>A for Industry Rank</p>
<p>A for Overall POWR Rating.</p>
<p>You can’t ask for better. It is ranked #1 out of 24 stocks in the<a href="https://stocknews.com/category/telecom-domestic/"> Telecom – Domestic</a> industry.</p>
<p><strong>Pfizer, Inc. (</strong><a href="https://stocknews.com/stock/PFE/"><strong>PFE</strong></a><strong>)</strong></p>
<div class="text-center" id="StockNews_ROS_RightRail_2" style="float:right"></div><p>PFE develops, manufactures, and sells healthcare products worldwide. Its COVID-19 vaccine candidate BNT162b2, which the company is developing in partnership with BioNTech (<a href="https://stocknews.com/stock/BNTX">BNTX</a>), has recently<a href="https://www.pfizer.com/news/press-release/press-release-detail/pfizer-and-biontech-share-positive-early-data-lead-mrna"> entered late-stage trials</a> after experiencing positive early data. The company pays an annual dividend of $1.52, which translates into a yield of 4.12%. The company has a four-year average dividend yield of 3.78%. PFE has been reliably increasing its dividend payout amount during the first quarter each year and has been uniformly paying a quarterly dividend. Over the past five years, the average dividends per share growth rate for PFE was 6.7%. The most recent dividend declared by the company was $0.38 in July 2020.</p>
<p>The company generated a free cash flow of $3.1 billion in the second quarter, a 52% increase year-over-year. It also reported free cash flow margin of 26%. Operating cash flow for the quarter stood $3.56 billion. It delivered a solid top-line of $11.8 billion with a 6% operational revenue growth from its Biopharma segment. The company reported a net income of $3.4 million and a 29% profit margin for the quarter.</p>
<p>EPS for the quarter came in $0.78, beating the consensus estimate by 18.2%. Moreover, PFE has beaten EPS estimates in three of the trailing four quarters, which is impressive. The street anticipates EPS to grow 14% year-over-year next year, but the EPS could skyrocket if the company succeeds in the race to combat this devastating virus by developing an effective vaccine.</p>
<p>It’s no surprise that PFE is rated a Buy in our POWR Ratings system. It also has a grade of A for Trade Grade, Peer Grade, and Industry Rank, and a B in Buy & Hold Grade. It is ranked #17 out of 231 stocks in the<a href="https://stocknews.com/category/pharmaceuticals/"> Medical – Pharmaceuticals</a> industry.</p>
<p><strong>3M Company (</strong><a href="https://stocknews.com/stock/MMM/"><strong>MMM</strong></a><strong>)</strong></p>
<p>MMM manufactures products related to electronics, telecommunications, industrial, consumer and office, health care, safety, and other markets. It operates through four business segments – Safety and Industrial, Transportation and Electronics, Health Care, and Consumer.</p>
<p>MMM pays an annual dividend of $5.88, which translates into a yield of 3.57%. The company has a four-year average dividend yield of 2.85%. The company has been constantly increasing its dividend payout amount during the first quarter each year and has been consistently paying quarterly dividends since becoming a public company in 1983. Over the past 10 years, the average dividend per share growth rate for MMM was 10.9%. The most recent dividend declared by 3M was $1.47 for its third quarter ending in September 2020. This is an increase of 2% year-over-year.</p>
<p>Free cash flow for the firm increased 23.5% year-over-year to $1.5 billion in the last reported quarter. The company also generated $1.9 billion in cash flow from operations, a 14% improvement year-over-year. While the company delivered a top-line of $7.18 billion, net income grew 14.5% year-over-year to $1.3 billion. EPS for the quarter came in $2.22, increasing 15.6% year-over-year. Moreover, with the ongoing adjustments to manufacturing and supply chain operations and evolving demand trends, EPS is expected to grow 9.6% next year. The stock closed yesterday’s trading session at $164.8, gaining more than 10.4% over the last six months. Additionally, MMM is trading at a 9.7% discount to its all-time high of $182.55.</p>
<p>MMM’s strong momentum is reflected in its POWR Ratings, it has a Buy rating with a grade of A in Trade Grade and Industry Rank, and a B in Buy & Hold Grade and Peer Grade. Within the<a href="https://stocknews.com/category/industrial-machinery/"> Industrial – Machinery</a>, it’s ranked #21 out of 59 stocks.</p>
<p><strong><em>Want More Great Investing Ideas?</em></strong></p>
<p><a href="https://sk687.isrefer.com/go/7betf/sn/ra" data-saferedirecturl="https://www.google.com/url?q=https://sk687.isrefer.com/go/7betf/sn/ra&source=gmail&ust=1598982775177000&usg=AFQjCNFZ3lGcnAI2oLjuH33SW9_JNlTZCg">7 Best ETFs for the <em>NEXT </em>Bull Market</a></p>
<p><a href="https://stocknews.com/news/spy-inx-dia-iwm-qqq-beware-stocks-in-september/" data-saferedirecturl="https://www.google.com/url?q=https://stocknews.com/news/spy-inx-dia-iwm-qqq-beware-stocks-in-september/&source=gmail&ust=1598982775177000&usg=AFQjCNFgMeYzdWJkJ6T-LTeAkaX3-3nMMw">Beware Stocks in September?</a></p>
<p><a href="https://sk687.isrefer.com/go/9gs/sn/art_txt">9 “<em>BUY THE DIP</em>” Growth Stocks for 2020</a></p>
<hr><p>VZ shares were trading at $60.65 per share on Wednesday afternoon, up $1.49 (+2.52%). Year-to-date, VZ has gained 2.01%, versus a 11.83% rise in the benchmark S&P 500 index during the same period.</p><script>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</script></body></html>
<div id="StockNews_ROS_Bottom_Leaderboard"></div><div style="clear:both;"></div><br><h2>About the Author: Sidharath Gupta</h2><br><img data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src='https://stocknews.com/wp-content/w3-webp/uploads/2020/08/sidharath.jpgw3.webp' style="float:left; padding:5px;width:125px;"><p>Sidharath’s passion for the markets and his love of words guided him to becoming a financial journalist. <a href="https://www.linkedin.com/in/sidgupta70/">He began his career as an Equity Analyst</a>, researching stocks and preparing in-depth research reports. Sidharath is currently pursuing the CFA program to deepen his knowledge of financial anlaysis and investment strategies. <a href="https://stocknews.com/authors/?author=sidharath-gupta">More...</a></p><br><div style="clear:both;"></div><h2>More Resources for the Stocks in this Article</h2>
<table style="margin:auto; width:100%; text-align:center; font-size:18px; font-family:arial;border:1px solid #DDD; margin-top:20px; margin-bottom:20px;" >
<tr style="background-color:#5cb85c; color:white;">
    <td>Ticker</td><td>POWR Rating</td><td>Industry Rank</td><td>Rank in Industry</td></tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/VZ/">VZ</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/PFE/">PFE</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr><tr style="text-align:center;">
    <td><a href="https://stocknews.com/stock/MMM/">MMM</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td><td><a href="https://stocknews.com/registration/free/?tag_id=2089" style="color:green; font-style:italic;">Get Rating</a></td>
  </tr></table></div></div>           <div align="center" class="margin-top"><div style="clear: both;"></div>
<div class="panel panel-default" style="max-width:750px;" id="topstories">

  <div class="panel-heading">
    <h3 class="panel-title"><span class="glyphicon glyphicon-envelope" aria-hidden="true"></span> Get Free Updates</h3>
  </div>
  <div class="panel-body">


            <p class="fourteen">Join thousands of investors who get the latest news, insights and top rated picks from StockNews.com!</p>
            <!-- The following code must be included to ensure your sign-up form works properly. -->
            <form role="form" method="GET" action="/v/" id="validate">
             <input name="tag_id" type="hidden" value="203">
    <input name="redirect_url" type="hidden" value="https://stocknews.com/thanks/">
            <div class="input-group">
            <input class="form-control" type="email" name="email" value="" placeholder="Enter Your Email Address" id="email">
            <span class="input-group-btn">
              <input type="submit" class="btn btn-primary" data-enabled="enabled" role="button" value="Subscribe">
            </span>
            </div>
          </form>


  </div>
</div>
<script type="lazyload">
var $ = jQuery;
$(function(){
  $('form[name=cc_form]').submit(function(){
    $.post($(this).attr('action'), $(this).serialize(), function(json) {
      alert(json);
    }, 'json');
    return false;
  });
});
</script>
</div>
          </div>
              <div class="col-lg-2 col-md-2"></div><!-- end of column -->



    </div>
     <!--   <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>-->




      <div class="row margin-top">
        <div class="col-lg-2 col-md-1"></div>
      <div class="col-lg-8 col-md-10">
        <div id="stocknews_ros_belowpost_1"></div><br>
      <h2 class="page-title no-pad-left big-margin-bottom bold"><strong>Most Popular Stories on StockNews.com</strong></h2>
     




			
			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/spy-inx-aapl-qqq-tsla-will-stocks-fall-into-historical-september-slump/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/08/jnj-scaled.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/spy-inx-aapl-qqq-tsla-will-stocks-fall-into-historical-september-slump/" class="black">Will Stocks Fall into Historical September Slump?</a>
				  				</h3>
				September is typically an unkind month for the stock market (SPY). On top of that we are coming into Presidential Election season which has crushed the market in previous Septembers. Thus, for as euphoric as investors feel right now, perhaps they should consider a dose of caution at this time. Plus notes on recent AAPL & TSLA stock splits.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Sep 2, 2020</a> <span class="light-gray">|</span> 8:09am				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>





						<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/09/vz-pfe-mmm-scaled.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/vz-pfe-mmm-3-strong-buy-dow-jones-dividend-stocks-yielding-3/" class="black">3 "Strong Buy" Dow Jones Dividend Stocks Yielding 3%</a>
				  				</h3>
				While stocks in the Dow Jones Industrial Average have not kept up with tech stocks, there are company's set to benefit from ongoing trends. Here are three strong companies yielding over 3%: Verizon Communications (VZ), Pfizer (PFE), and 3M Company (MMM).				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Sep 2, 2020</a> <span class="light-gray">|</span> 1:40pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>


<script language="javascript" data-src="https://live.sekindo.com/live/liveView.php?s=98944&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed1277phwmyzxj&subId=[SUBID_ENCODED]" ></script>



			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/fb-pins-socl-twtr-snap-is-social-media-the-new-tobacco/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/08/ge-bynd-spwr.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/fb-pins-socl-twtr-snap-is-social-media-the-new-tobacco/" class="black">Is Social Media the New Tobacco?</a>
				  				</h3>
				Social media stocks have a lot in common. Both sell addictive products with high margins that produce a considerable amount of negative externalities. Like tobacco, social media is likely to get larger and more powerful, until governments step in and increase regulations to curb their rise.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Sep 2, 2020</a> <span class="light-gray">|</span> 1:11pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>









			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/fhb-insw-este-gifi-4-downgraded-stocks-to-avoid/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/08/acb-4-scaled.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/fhb-insw-este-gifi-4-downgraded-stocks-to-avoid/" class="black">4 DOWNGRADED Stocks to AVOID</a>
				  				</h3>
				Stocks that underperform during bull markets should be avoided. The POWR Ratings can help you find these underperformers since it rates stocks on a daily basis. FHB, INSW, ESTE, and GIFI are four stocks that were recently downgraded.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Sep 2, 2020</a> <span class="light-gray">|</span> 2:56pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>







			  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>			<hr>

			<div class="margin-bottom">
			  <div class="pull-left no-mobile-pull pad-right">
				<a href="/news/fb-pins-socl-twtr-snap-is-social-media-the-new-tobacco/"><img class="img-rounded three-hundo" data-class="LazyLoad" src="https://stocknews.com/wp-content/uploads/blank.pngw3.webp" data-src="/cdn-cgi/image/fit=scale-down,format=auto,q=60,onerror=redirect,height=200/https://stocknews.com/wp-content/uploads/2020/08/ge-bynd-spwr.jpg" alt=":  |  News, Ratings, and Charts"></a>
			  </div>
			  <div class="overflow-fix margin-top-mobile">
				<div class="pad-left pad-top bb-2">				<h3 class="bold zero-margins pad-bot pad-top">
				  <a href="/news/fb-pins-socl-twtr-snap-is-social-media-the-new-tobacco/" class="black">Is Social Media the New Tobacco?</a>
				  				</h3>
				Social media stocks have a lot in common. Both sell addictive products with high margins that produce a considerable amount of negative externalities. Like tobacco, social media is likely to get larger and more powerful, until governments step in and increase regulations to curb their rise.				<section class="post-meta zero-padding pad-bottom margin-top">
				  <a href="">Sep 2, 2020</a> <span class="light-gray">|</span> 1:11pm				</section>
				</div>

			  </div>
			  <div class="clearfix"></div>
			</div>

  <div style="width:100%; padding:5px;">
        <div id="StockNews_ROS_BelowPost_1" class="text-center">
      
    </div>
      </div>

       <h3>
            <a href="/top-stories/" class="btn btn-default width-full margin-top-less" role="button">Read More Stories</a>
          </h3>
          <div align="center"><script async="" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" ></script>
<!-- Bottom Article Banner Ad (4) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6654551967172224"
     data-ad-slot="1071597498"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

      </div>
      </div>



      <div class="row margin-top">
        <div class="col-lg-12">
          <h3>
            More Verizon Communications Inc.  (VZ) News
            <a href="/stock/VZ/news/" class="btn btn-default" role="button">View All</a>
          </h3>
          <div class="panel panel-default">
            <table class="table-condensed table table-striped news mobile-card-view" id="news-stream">
              <thead>
                <tr>
                  <th>Event/Date</th>
                  <th>Symbol</th>
                  <th>News Detail</th>
                  <th class="text-right" nowrap>Start Price</th>
                  <th class="text-right" nowrap>End Price</th>
                  <th nowrap>Change</th>
                  <th>POWR Rating</th>
                </tr>
              </thead>
              <tbody>
                <tr><td colspan="10" class="text-center">Loading, please wait...</td></tr>
              </tbody>
            </table>
          </div>
          <a href="/stock/VZ/" class="btn btn-default width-full margin-top-less">View All VZ News</a>
        </div>
      </div><!-- end of row -->

    </article>


  </div><!-- end of content -->
  


  <script data-src="//ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js" ></script>
  <script type="lazyload">
  jQuery(document).ready(function($){
    function symbol_get_snippets(symbol) {
      $.getJSON('https://stocknews.com/wp-content/themes/strappress-child/includes/snippet-json.php?symbol=VZ&limit=10&historical_prices=1',
        function (json) {
          $("table#news-stream tbody").html("");
          var tr=[];
          for (var i = 0; i < json.results.length; i++) {
            if ((json.results[i].top_story_headline != "") && (json.results[i].top_story_headline != null)) {
              var headline = json.results[i].top_story_headline;
            } else {
              var headline = json.results[i].notes;
            }
            tr.push('<tr>');
            tr.push('<td class="bullorbear-' + json.results[i].bull_or_bear + 'a"><strong>' + json.results[i].event_short + '</strong><br><span class="medium-gray">' + json.results[i].snippet_time + '</span></div>');
            tr.push('<td><strong><a href="/stock/' + json.results[i].symbol + '/">' +  json.results[i].symbol + '</strong></td>');
            //tr.push('<td><a href="/stock/' + json.results[i].symbol + '/">' + json.results[i].company + '</a></td>');
            tr.push('<td><span class="dark-gray"><a href="https://stocknews.com/news/' + json.results[i].post_slug + '">' + headline + '</a></span></td>');
            tr.push('<td class="text-right">' + json.results[i].price_when_added + '</td>');
            tr.push('<td class="text-right grade-' + json.results[i].day_change_color + '">' + json.results[i].day_close + '</td>');
            tr.push('<td class="grade-' + json.results[i].day_change_color + '">' + json.results[i].day_change + '<br>' + json.results[i].day_pct_change + '</td>');
            //tr.push('<td class="grade-' + json.results[i].ttm_color + '">' + json.results[i].ttm_pct_change_formatted + '</td>');
            tr.push('<td class="text-center grade-' + json.results[i].powr_grade_color + '"><strong>' + json.results[i].powr_grade + '</strong><br><small>' + json.results[i].powr_grade_text + '</small></td>');
                        tr.push('</tr>');
          }
          $(tr.join('')).appendTo($('table#news-stream tbody')).slideDown("slow");
      });
    }
    symbol_get_snippets('VZ');
  });

  //Make all extrnal links target '_blank'
  jQuery(function($) {

      $('.post_content').find('a[href^="http"]').not('a[href*=stocknews]').attr('target','_blank');
      });

  //Change Stock Tickers to Get Rating Links

  let tickerPos, ratingReplace = "";

  let stockData = {"replace_stocks":[{"stock":"VZ"},{"stock":"PFE"},{"stock":"MMM"}]};

      
  for (tickerPos in stockData.replace_stocks) {
      ratingReplace = '(<strong><a href="https://stocknews.com/stock/' + stockData.replace_stocks[tickerPos].stock + '">' + stockData.replace_stocks[tickerPos].stock + '</a></strong> - <a href="https://stocknews.com/registration/free/?tag_id=3269" style="color:green; font-style:italic;">Get Rating</a>)'
      replaceTickers(tickerPos);
  }

  function replaceTickers(tickerPos) {
      let stockTicker = stockData.replace_stocks[tickerPos].stock;
      let regexTicker = new RegExp('\\(([^)]+)'+ stockTicker +'([^)]+)\\)')
      let str = document.getElementById("articlecontent").innerHTML;
      let res = str.replace(regexTicker, ratingReplace);
      document.getElementById("articlecontent").innerHTML = res;
  }

        </script>


        </div><!-- end of wrapper-->


</div><!-- end of container -->

<footer id="footer" class="clearfix">
  <div class="container">
    <hr>
    <div id="footer-wrapper">
      <div class="row margin-bottom">
        <div class="col-lg-6">
          ©2020 StockNews.com                </div><!-- end column -->
                      <div class="col-lg-6 text-right">
          <a href="/about/">About Us</a> | <a href="/contact/">Contact Us</a> | <a href="/privacy/">Privacy Policy</a> | <a href="/legal/">Terms of Use</a>
        </div>
              </div><!-- end row -->
            <div class="row">
        <div class="col-lg-6">
          <p><small>Copyright © 2020. Market data provided is at least 10-minutes delayed and hosted by <a href="https://www.barchart.com/solutions" target="_blank">Barchart Solutions</a>.<br>Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use, please see <a href="http://www.barchart.com/solutions/company/terms-and-privacy">disclaimer</a>.</small></p>
        </div>
        <div class="col-lg-6"
          <p><small>Automated Insights by <a href="https://sixjupiter.com"  target="_blank">SixJupiter</a>.
          <br><br>
          <em>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" rel="nofollow">Privacy Policy</a> and <a href="https://policies.google.com/terms" rel="nofollow">Terms of Service</a> apply.</em></small>
          </p>
        </div>
      </div>
          </div><!-- end #footer-wrapper -->
  </div> <!-- end container --> 
</footer><!-- end #footer -->


<script type="lazyload"async="">(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='d1a293004a063000b79b40002eed8d007d2680005842eb00f4865000f034f400';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>    <script type="application/javascript">
      var ajaxurl = "https://stocknews.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
    <script>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/stocknews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>


<script>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LchJtYUAAAAAEElEanUrnd4BKqz0D3BgliK1AKc","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>





<!-- AST – IMS - [StockNews_PopUp] -->
<div id="StockNews_PopUp_PopUp" class="text-center">
  <script type="lazyload">
  apntag.anq.push(function() {
    apntag.showTag('StockNews_PopUp_PopUp');
  });
  </script>
</div>
<!-- End AST – IMS - [StockNews_PopUp] -->


<!-- Push Monkey code  -->

<!-- dfp script-->
<script type="lazyload"defer="defer"data-cfasync="false"> (function() { window.advBidxc = window.advBidxc || {}; window.advBidxc.startTime = new Date().getTime(); function loadScript(tagSrc) { var scriptTag = document.createElement('script'), placeTag = document.getElementsByTagName("script")[0]; scriptTag.type = 'text/javascript'; scriptTag.async = true; scriptTag.src = tagSrc; placeTag.parentNode.insertBefore(scriptTag, placeTag); } var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' + window.location.hostname; loadScript(mnSrc); })(); </script>
<!-- dfp script -->
<script>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</script></body>
</html>